LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris and OpenSolaris.
General Sun, SunOS and Sparc related questions also go here.

Notices

Reply
 
Search this Thread
Old 08-19-2005, 10:13 AM   #1
jsheffie
Member
 
Registered: Dec 2004
Location: Florida, USA
Distribution: Suse 10.0, OSX.4, Solaris 10
Posts: 163

Rep: Reputation: 30
ssh is not starting!!!


I just installed solaris 10 3/05 and am attempting to start ssh

I ran the following sets of commands:

svcadm enable ssh
svcadm enable -r ssh
svcadm restart ssh
svcadm restart -r ssh
svcadm enable svc:/network/ssh:default


I also went into /ets/ssh/sshd_config and edit the file to listen on "ipaddress"
I also disabled listening on IPv6 interfaces, thinking that might be the issue.

Am I missing something? I'm new to the whole svcadm thing.

Thanks
 
Old 08-19-2005, 10:18 AM   #2
jsheffie
Member
 
Registered: Dec 2004
Location: Florida, USA
Distribution: Suse 10.0, OSX.4, Solaris 10
Posts: 163

Original Poster
Rep: Reputation: 30
here is a little more information

running svcadm -v enable -r ssh I receive the following printout:

svc:/network/ssh:default enabled.
svc:/system/filesystem/local enabled.
svc:/milestone/single-user enabled.
svc:/system/identity:node enabled.
svc:/network/loopback enabled.
svc:/system/filesystem/minimal enabled.
svc:/system/filesystem/usr enabled.
svc:/system/filesystem/root enabled.
svc:/system/device/local enabled.
svc:/milestone/devices enabled.
svc:/system/manifest-import enabled.
svc:/network/physical enabled.
svc:/system/cryptosvc enabled.
svc:/system/filesystem/minimal:default enabled.
svc:/system/utmp enabled.
svc:/milestone/sysconfig enabled.

running svcs | grep ssh directly after produces the following output

offline 10:52:18 svc:/network/ssh:default

thanks
 
Old 08-19-2005, 11:37 AM   #3
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,507

Rep: Reputation: 360Reputation: 360Reputation: 360Reputation: 360
There's a shell script that may help you at:
http://dcs.nac.uci.edu/~strombrg/Solaris-notes.html

look after "svcadm clear ssh"
 
Old 08-19-2005, 11:58 AM   #4
jsheffie
Member
 
Registered: Dec 2004
Location: Florida, USA
Distribution: Suse 10.0, OSX.4, Solaris 10
Posts: 163

Original Poster
Rep: Reputation: 30
thanks for the reply, but the script isn't working...
I receive this error:

./script: maxtime: not found
./script: /etc/ssh/ssh_host_key: not found

when I type:svcs -d network/ssh:default I receive the following...

STATE STIME FMRI
online 10:52:21 svc:/network/loopback:default
online 10:52:27 svc:/network/physical:default
online 10:52:34 svc:/system/cryptosvc:default
online 10:52:38 svc:/system/filesystem/local:default
online 10:52:48 svc:/system/utmp:default
offline 10:52:17 svc:/system/filesystem/autofs:default

shouldn't autofs be online?
In order to have ssh work should I have installed more apps from the companion cd (I dont think so but hey I could be wrong)

I will take another look at that script.

Thanks
 
Old 08-19-2005, 12:14 PM   #5
jsheffie
Member
 
Registered: Dec 2004
Location: Florida, USA
Distribution: Suse 10.0, OSX.4, Solaris 10
Posts: 163

Original Poster
Rep: Reputation: 30
looked at the script and removed the following lines because "ssh_host_key" did not exist in the /etc/ssh/ directory:

if [ -f "$SSHD_DIR/ssh_host_key" ]
then
:
else
maxtime 180 /usr/bin/ssh-keygen -trsa1 -b 1024 -f
"$SSHD_DIR/ssh_host_key" -N ''
fi


I ran the scrip and it completed without error. checked the services again and ssh is still not running.


thanks though.
 
Old 08-19-2005, 01:49 PM   #6
jsheffie
Member
 
Registered: Dec 2004
Location: Florida, USA
Distribution: Suse 10.0, OSX.4, Solaris 10
Posts: 163

Original Poster
Rep: Reputation: 30
I have attempted to start a dependancy (nisplus required for autofs) using the -r option and recevied the following error when it tried to start sshd

# svcadm Aug 19 14:42:38 svc.startd[7]: svc:/network/ssh:default: Method "/lib/svc/method/sshd start" failed with exit status 255.
Aug 19 14:42:38 svc.startd[7]: svc:/network/ssh:default: Method "/lib/svc/method/sshd start" failed with exit status 255.
Aug 19 14:42:38 svc.startd[7]: svc:/network/ssh:default: Method "/lib/svc/method/sshd start" failed with exit status 255.
Aug 19 14:42:39 svc.startd[7]: network/ssh:default failed

any ideas?
 
Old 08-19-2005, 02:02 PM   #7
jsheffie
Member
 
Registered: Dec 2004
Location: Florida, USA
Distribution: Suse 10.0, OSX.4, Solaris 10
Posts: 163

Original Poster
Rep: Reputation: 30
Fixed it...

The issue was that I am having to go through hyperterminal as an interface for this headless v100 and hyperterminal does not like skipping line. part of /etc/ssh/sshd_config had a character inserted into causing the issue.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ssh-agent is starting? Vgui Slackware 3 10-21-2005 09:30 PM
Starting ssh on fedora tobycatlin Linux - Software 5 05-13-2005 07:52 AM
starting kde over SSH Danathar Slackware 6 12-02-2004 10:29 AM
Starting SSH problem satimis Linux - Software 4 10-28-2003 09:04 PM
starting X through ssh msound Linux - General 15 06-25-2003 12:30 AM


All times are GMT -5. The time now is 10:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration