LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris and OpenSolaris.
General Sun, SunOS and Sparc related questions also go here.

Notices

Reply
 
Search this Thread
Old 12-05-2012, 02:42 AM   #1
routers
Member
 
Registered: Aug 2005
Location: Malaysia - KULMY / CNXTH
Distribution: Slackware, Fedora, FreeBSD, Sun O/S 5.10, CentOS
Posts: 771
Blog Entries: 6

Rep: Reputation: 75
Solaris 11 "zone" dhcp not worked


Hi there , i have
sol-11 which is main host
sol-11dev which is zone

the issue is sol-11dev is not changin ip to new
dhcp ip when connected to the new network
but no issue with sol-11

i have rebooted sol-11dev zone several time but the old ip is still there and not renew to the new ip. FYI my home and office use diffrent network segment but both use dhcp

is there any way to retify this ?

here extra info
Code:
root@sol-11:~# ifconfig -a
lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
	inet 127.0.0.1 netmask ff000000 
net0: flags=1004943<UP,BROADCAST,RUNNING,PROMISC,MULTICAST,DHCP,IPv4> mtu 1500 index 2
	inet 192.168.1.166 netmask ffffff00 broadcast 192.168.1.255
	ether 0:26:9e:ac:c6:9d 
lo0: flags=2002000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv6,VIRTUAL> mtu 8252 index 1
	inet6 ::1/128 
net0: flags=20002004941<UP,RUNNING,PROMISC,MULTICAST,DHCP,IPv6> mtu 1500 index 2
	inet6 fe80::226:9eff:feac:c69d/10 
	ether 0:26:9e:ac:c6:9d
Code:
root@sol-11dev:~# ifconfig -a
lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
        inet 127.0.0.1 netmask ff000000 
vnic1: flags=1004843<UP,BROADCAST,RUNNING,MULTICAST,DHCP,IPv4> mtu 1500 index 2
        inet 10.1.1.5 netmask ffffff00 broadcast 10.1.1.255
        ether 2:8:20:e9:66:ea 
net0: flags=1004843<UP,BROADCAST,RUNNING,MULTICAST,DHCP,IPv4> mtu 1500 index 3
        inet 10.1.1.4 netmask ffffff00 broadcast 10.1.1.255
        ether 2:8:20:5a:3f:17 
lo0: flags=2002000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv6,VIRTUAL> mtu 8252 index 1
        inet6 ::1/128 
vnic1: flags=20002004841<UP,RUNNING,MULTICAST,DHCP,IPv6> mtu 1500 index 2
        inet6 fe80::8:20ff:fee9:66ea/10 
        ether 2:8:20:e9:66:ea 
net0: flags=20002004841<UP,RUNNING,MULTICAST,DHCP,IPv6> mtu 1500 index 3
        inet6 fe80::8:20ff:fe5a:3f17/10 
        ether 2:8:20:5a:3f:17
thanks
 
Old 12-07-2012, 03:16 PM   #2
blueh2o
Member
 
Registered: Jul 2011
Posts: 63

Rep: Reputation: 2
Your zone networks need to be of the exclusive type to use DHCP. Can you post your zone configuration?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem creating second zone: "Copying <0> files to the zone." AlucardZero Solaris / OpenSolaris 0 07-20-2010 04:12 PM
"Ignoring out-of-zone data" errors with my DNS Zone file zyzzogeton Linux - Networking 2 12-17-2009 09:51 AM
Ndiswrapper "Invalid driver" error - but it worked before i switched distros! drewbug01 Linux - Wireless Networking 5 11-01-2006 01:36 PM
Lost DHCP Lease when putting computer in "Standby" mode for a "long" time pnellesen Linux - Networking 1 01-07-2005 12:44 AM
Sound: "No such device" with cs4614 on Debian. It worked with RedHat 9 goozlq Linux - Software 7 10-14-2004 07:16 PM


All times are GMT -5. The time now is 06:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration