LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris and OpenSolaris.
General Sun, SunOS and Sparc related questions also go here.

Notices

Reply
 
Search this Thread
Old 03-28-2012, 12:02 PM   #1
trekgirl
Member
 
Registered: Feb 2009
Location: Bremerton, WA, USA
Distribution: Red Hat
Posts: 60

Rep: Reputation: 26
Setting up a Solaris 10 LDAP client


So I am trying to setup a Solaris 10 box as an LDAP client. I have created the certificate db and imported the cert based on the directions at https://blogs.oracle.com/baban/entry...etup_ssl_using. The LDAP server is successfully authenticating Linux boxes, and I have enabled v2 binds since that seems to be what Solaris wants to use. I initialize the client and I get this message:
ldap_cachemgr[10787]: libsldap: makeConnection: failed to open connection to oly-infra-ldap1 (I have tried name and IP and both get the same message)
When I do an ldapclient list, this is the output:
NS_LDAP_FILE_VERSION= 2.0
NS_LDAP_BINDDN=our bind account
NS_LDAP_BINDPASSWD= our passwd
NS_LDAP_SERVERS= oly-infra-ldap1 (again I have tried the IP here as well)
NS_LDAP_SEARCH_BASEDN= our base dn, same as linux
NS_LDAP_AUTH: tls:simple
NS_LDAP_CACHETTL= 0
NS_LDAP_CREDENTIAL LEVEL= proxy
NS_LDAP_SERVICE_AUTH_METHOD= pam_ldap:tls:simple
NS_LDAP_HOST_CERTPATH= /var/ldap

I have not configured PAM yet but it was having the connection issue before I put the service method authentication in so I don't think that is the issue.
Any help would be greatly appreciated. Solaris is a bit of a mystery to me, but we have a whole product line running on it.
As an aside, any books you would recommend for Solaris would also be greatly appreciated.
 
Old 03-29-2012, 11:20 AM   #2
trekgirl
Member
 
Registered: Feb 2009
Location: Bremerton, WA, USA
Distribution: Red Hat
Posts: 60

Original Poster
Rep: Reputation: 26
Still hoping for a reply...if anyone has any ideas.
 
Old 03-30-2012, 03:47 PM   #3
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,481

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
Such a redacted ldapclient output doesn't help figuring out what the issue can be.
Anyway, here are some starting points:
- Are you using the standard ldaps port ?
- What directory server software are you using ?
- Did you look at its access logs ?
- Did you look at /var/ldap/cachemgr.log ?
- What says
Code:
svcs -xv ldap/client
?

In any case, you should probably first start to set-up the ldap naming service without encryption.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Solaris 10 LDAP Client to 389 DS(Linux) sanitycheck Solaris / OpenSolaris 6 11-02-2011 11:38 AM
Solaris 10 LDAP Client to 389 DS(Linux) sanitycheck Linux - Server 1 09-29-2011 02:55 PM
how to setup open ldap server and solaris 10 as ldap client maheshlad Linux - Software 1 10-10-2009 12:55 AM
authconfig Equivalent for Solaris 10 (for LDAP client) custangro Solaris / OpenSolaris 2 10-07-2009 10:31 AM
how to configure ldap client on solaris 9 capricorn80 Solaris / OpenSolaris 78 01-29-2008 02:08 AM


All times are GMT -5. The time now is 04:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration