LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Home Forums Tutorials Articles Register
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris, OpenSolaris, OpenIndiana, and illumos.
General Sun, SunOS and Sparc related questions also go here. Any Solaris fork or distribution is welcome.

Notices


Reply
  Search this Thread
Old 10-05-2013, 05:36 PM   #1
austinramsay
Member
 
Registered: Jul 2007
Posts: 277

Rep: Reputation: 31
Setting ip settings on boot


How can I tell solaris 11 to set my net0 ip settings to 192.168.200.100 netmask 255.255.255.0 on boot? Also what do I need to edit to set my default route to 192.168.200.105? I've been doing route add default 192.168.200.105 after each reboot.
 
Old 10-05-2013, 06:49 PM   #2
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,790

Rep: Reputation: 653Reputation: 653Reputation: 653Reputation: 653Reputation: 653Reputation: 653
I'm a Solaris newb but this may work (happy to be corrected):

Code:
# unconfigure and remove any dhcp info
ifconfig net0 unplumb
rm -f /etc/dhcp.*
ifconfig net0 plumb

# set IP
cat << EOF > /etc/hostname.net0
192.168.200.100/24 broadcast up
EOF

# add subnet to known networks
cat << EOF >> /etc/netmasks
192.168.200.0    255.255.255.0
EOF

# set default gateway
echo "192.168.200.105" > /etc/defaultrouter
You'll need to this from the console not via ssh
 
Old 10-06-2013, 05:50 AM   #3
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris 11.4, Oracle Linux, Mint, Debian/WSL
Posts: 9,789

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
Solaris 11 new IP stack obsoleted most of the previous way to configure networking.

You should now use dladm, netadm, ipadm, route and the likes to do it if you really want locally configured addresses.

It is however much simpler to rely on a dhcp server (i.e. use ncp Automatic profile).

See http://www.oracle.com/technetwork/ar...g-1632927.html
 
1 members found this post helpful.
  


Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
netconfig not setting eth0 settings on boot austinramsay Slackware 2 10-05-2013 07:56 PM
Setting network settings OpsVentus Programming 2 12-20-2005 02:52 PM
setting up network (proxy settings) sharadbirmiwal Linux - Networking 1 01-27-2005 08:04 AM
Setting aumix settings across boot sbrewer Linux - Hardware 1 12-27-2004 03:50 PM
Mandrake 10.0 Community Not Properly Setting Wireless Settings on Boot-up ajkessel Linux - Wireless Networking 0 05-14-2004 07:03 AM

LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris

All times are GMT -5. The time now is 09:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration