LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris and OpenSolaris.
General Sun, SunOS and Sparc related questions also go here.

Notices

Reply
 
Search this Thread
Old 10-06-2005, 02:14 PM   #1
madamson
LQ Newbie
 
Registered: Oct 2005
Posts: 2

Rep: Reputation: 0
not allowing me to login as other users


OK! I was having major permissions problems with my software. I went into root and gave permissions to users as much as possible but to no avail. Accidently, I did chmod 555 on usr folder. Now I can only login as root and solaris will not let me log in as anything else.
I add users in the solaris management console.
Please helpppp!!!
M
 
Old 10-06-2005, 04:04 PM   #2
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,500

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
Quote:
I went into root and gave permissions to users as much as possible but to no avail.
how ?
Quote:
Accidently, I did chmod 555 on usr folder.
did you restore the permissions back to their original values ?
Quote:
Now I can only login as root and solaris will not let me log in as anything else.
Well, at least you didn't lock you out !
 
Old 10-07-2005, 01:14 AM   #3
anuode
Member
 
Registered: Nov 2004
Location: china
Distribution: Mandrake 10.1 Official
Posts: 37

Rep: Reputation: 15
under default,when you add a new user to your system,the user's home directory will not be created.
so you can't login as the user! you must make a home directory for the user and chown,then vi /etc/passwd
file .now ,it should be ok!
 
Old 10-07-2005, 01:35 AM   #4
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,500

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
Quote:
the user's home directory will not be created.
so you can't login as the user!
This is wrong, you can login as a user missing an home directory, it just defaults to "/".
See line 1749 of http://cvs.opensolaris.org/source/xr.../login/login.c
 
Old 10-07-2005, 01:58 AM   #5
anuode
Member
 
Registered: Nov 2004
Location: china
Distribution: Mandrake 10.1 Official
Posts: 37

Rep: Reputation: 15
thanks,I'm wrong!sorry
but ,I have encountered the same problem, i worked as my method,and now it's ok!
thanks again
 
Old 10-07-2005, 02:11 AM   #6
anuode
Member
 
Registered: Nov 2004
Location: china
Distribution: Mandrake 10.1 Official
Posts: 37

Rep: Reputation: 15
I just have a try
I rename my home directory /export/home/anuode to /export/home/anuode.old .
then logout and login
I can't login normally,and only start a failsafe session
why?
 
Old 10-07-2005, 02:23 AM   #7
technopark02
Member
 
Registered: Feb 2005
Distribution: Solaris 8 - 11, JDS Linux 3.0
Posts: 99

Rep: Reputation: 15
Perhaps the initiator is not able to login to JDS as normal user. It is not so uncommon to encounter such problems, if files like .ICEauthority are owned by root user, and if there are insufficient privileges for normal users to access those files.

Simply changing the ownership, or making all the files {in the home directory of the user} accessible to normal user(s) may resolve the issue.

----
>> I add users in the solaris management console.
Did you change the ownership of the home directory of the user?

It is not that hard to create a new user from command line, really. The following example shows the simple steps to create a new user called "madamson":

1. mkdir -p /export/home/madamson (Create the home directory for the user, before creating the user)
2. useradd -s /bin/csh -d /export/home/madamson madamson (default shell will be Csh. Do a "man useradd" for the other options)
3. chown -R madamson /export/home/madamson (Let the user own his home directory)
4. passwd madamson (Change the password)
 
Old 10-07-2005, 05:49 AM   #8
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,500

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
Quote:
useradd -s /bin/csh ...
Don't promote csh, it's so outdated and useless ...
My best choice is ksh, then bash.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Allowing users to shutdown - Slack 10.1 amwink Slackware 31 08-22-2006 11:59 AM
vsftpd not allowing users to log in Rokkun Linux - Software 6 11-14-2004 07:46 PM
Allowing *some* users to mount ugenn Linux - General 8 03-01-2004 10:48 PM
allowing /mnt/ to all users bcf2 Mandriva 1 02-18-2004 05:10 PM
Allowing Users commands Atroxic Linux - Newbie 2 02-01-2002 11:06 PM


All times are GMT -5. The time now is 08:09 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration