LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris and OpenSolaris.
General Sun, SunOS and Sparc related questions also go here.

Notices

Reply
 
Search this Thread
Old 04-01-2005, 01:43 AM   #1
voldi
LQ Newbie
 
Registered: Apr 2005
Location: Singapore
Posts: 5

Rep: Reputation: 0
Question NIC disappear after rebooting (Solaris 10 x86)


Dear members,

I would like to ask for any suggestion regarding my problem:

1. I am installing Solaris 10 x86 into my PC.

2. After installation, the system didn't recognize my NIC, which is DLink 538TX Ethernet (PCI)

3. I downloaded the driver for this NIC, and put it on a floppy drive (.itu)

4. When rebooting, I enter the configuration assistant then press F4

5. The system read the floppy (supplemental driver software), and after pressing F4 then F2 twice, I saw the Dlink driver recognized by the system

6. I proceed to reboot the PC.

7. Using the terminal (over the GUI), I use these command:

#prtconf <enter>

I saw this entry, which is my DLink NIC:

"pci1186, 1300, instance #1"

8. next I use this command

#devfsadm -v

9. followed by this:

# ifconfig rf1 plumb

10. then I configure the IP address:

#ifconfig rf1 10.8.9.98 netmask 255.255.255.0 broadcast 10.8.9.255

11. The next step is to bring up the rf1:

#ifconfig rf1 up

12. I added also the gateway:

#route add default 10.8.9.2

13. I tried to ping other machine, it works perfectly...

14. I applied this command:

#touch /reconfigure

15. up to this point, I am able to continue installing applications, accessing network, etc.

But after I rebooted my PC, the system unable to recognize the NIC. And when I do

#prtconf

it displays :

pci1186,1300 (driver not attached)

And I have to redo all the steps above again....

Could someone help me on this matter? I am quite frustrated on this (I've done it 3x...).

FYI, this is my first Solaris installation. Previously I already installed other UNIX-like system (Linux, FreeBSD, Mac OSX) without encountering this problem.

Thanks in advance.
 
Old 04-01-2005, 06:21 AM   #2
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,289

Rep: Reputation: 69
Try :
touch /reconfigure
sys-unconfig
 
Old 04-04-2005, 07:27 AM   #3
voldi
LQ Newbie
 
Registered: Apr 2005
Location: Singapore
Posts: 5

Original Poster
Rep: Reputation: 0
Question Still have the problem.

Quote:
Originally posted by keefaz
Try :
touch /reconfigure
sys-unconfig
Thanks for the suggestion... but it seems that it is still the same...

When I did sys-unconfig, the system tried to detect my NIC as "rtls0", which is incorrect. Everytime I reconfigure the DLink NIC manually, the system always referred it as "rf1". Why the system can't recognize "rf1" but tried to use "rtls0" instead?


I've been thinking.... at the step where the Configuration Assistant read my floppy where the driver for the DLink NIC resides, does the system copied the driver to the harddrive or only read it from the floppy?

Is there any way to copy the driver to the harddrive manually and let Solaris read it when booting?

Thx.

.V.
 
Old 04-04-2005, 12:52 PM   #4
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,481

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
Quote:
I downloaded the driver for this NIC
Where did you get the driver ?
Any installation notes there ?
Is it tested with Solaris 10 ?
Which release of Solaris 10 are you using ?
Quote:
# ifconfig rf1 plumb
10. then I configure the IP address:
#ifconfig rf1 10.8.9.98 netmask 255.255.255.0 broadcast 10.8.9.255
11. The next step is to bring up the rf1:
#ifconfig rf1 up
This can be shorten to:
Code:
ifconfig rf1 plumb 10.8.9.98 netmask 255.255.255.0 broadcast 10.8.9.255 up
or better, to make setting persistants:
Code:
# echo 10.8.9.98 > /etc/hostname.rf1
# echo 10.8.9.2 > /etc/defaultrouter
Why is you driver rf1, is there a rf0 ?
Have you more than one ethernet interface ?
Quote:
When I did sys-unconfig, the system tried to detect my NIC as "rtls0", which is incorrect.
What makes you think this is incorrect ?
Solaris 10 already includes a realtek driver named rtls, perhaps the driver you installed is conflicting with the builtin one.
 
Old 04-04-2005, 10:42 PM   #5
voldi
LQ Newbie
 
Registered: Apr 2005
Location: Singapore
Posts: 5

Original Poster
Rep: Reputation: 0
Please see my answers in between your lines below:

(Originally posted by jlliagre)

Where did you get the driver ?

http://www.tools.de/solaris/itu/

Any installation notes there ?

I followed the installation notes.

Is it tested with Solaris 10 ?

The driver is for Solaris 9/10.

Why is you driver rf1, is there a rf0 ? Have you more than one ethernet interface ?

No, I only have 1 NIC installed

What makes you think this is incorrect ? Solaris 10 already includes a realtek driver named rtls, perhaps the driver you installed is conflicting with the builtin one.

Before I use the driver which I downloaded, the system didn't recognize the NIC... actually I tried rtls0, but nothing... Btw, even the NIC light was off.


Thanks...
 
Old 04-05-2005, 01:47 AM   #6
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,481

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
There's definitely two drivers competing to handle your NIC, rf which is an open source driver from Masayuki Murayama and rtls which is the official driver from RealTek.

Some suggestions:

- Check if your card is known (and known once) to the driver's alias file /etc/driver_aliases:
Code:
grep "pci1186,1300" /etc/driver_aliases
- if more than one line shows up, remove all but the one you want to try with an text editor. (make a backup copy of /etc/driver_aliases as any mistake may make your system hang on reboot).

- You can tell the O/S to load a specific driver without rebooting, e.g.:
Code:
update_drv -a -i '"pci1186,1300"' rtls
- Check if the driver specific configuration file is there:
/usr/kernel/drv/<drivername>.conf (e.g. rf.conf or rtls.conf)

- If you have a modem card, try removing it (it may be the one picking rf0).

Last edited by jlliagre; 04-05-2005 at 01:49 AM.
 
Old 04-05-2005, 11:15 PM   #7
voldi
LQ Newbie
 
Registered: Apr 2005
Location: Singapore
Posts: 5

Original Poster
Rep: Reputation: 0
Please find my reply between your lines:
(Originally posted by jlliagre)

Check if your card is known (and known once) to the driver's alias file /etc/driver_aliases

rtls "pci1186,1300"


Check if the driver specific configuration file is there:
/usr/kernel/drv/<drivername>.conf (e.g. rf.conf or rtls.conf)


No, there is neither rf.conf nor rtls.conf. How can I add the .conf file?


If you have a modem card, try removing it (it may be the one picking rf0).

I've removed the modem card. I can't install and run any NIC with the modem attached.


You can tell the O/S to load a specific driver without rebooting.

I will do it at end-of-day, since I am still working with the PC now...


Thanks, have a nice day...

.V.
 
Old 04-08-2005, 01:40 AM   #8
voldi
LQ Newbie
 
Registered: Apr 2005
Location: Singapore
Posts: 5

Original Poster
Rep: Reputation: 0
Finally....

Finally the problem was settled... thanks to Swame in Solaris Forum in http://forum.sun.com for the help.

Here I quote his answer to my problem, so anyone who experience the same problem can be helped.

Thanks guys for trying to help me.

.V.


--------------------------------------------------------------------


Swame wrote:


I experienced a similiar issue with an .itu .. TBH I never did find out how to make .itu permanent. But here is an alternate solution
Fire up you're editor; open /boot/solaris/devicedb/master; go down to the following entry:

pci10ec,8139 pci10ec,8139 net pci none "Realtek 8139 Fast Ethernet"


Copy that line directly below itself, changing the pci10ec,8139
portion to this :

pci1186,1300



Don't put that editor away yet ...Next edit /etc/driver_aliases

rtls "pci1186,1300"


Then proceed with your reconfigure.
Note: You will see a note that the driver does not support ...etc. @ boot. It does, I haven't figured out why that message occurs, but rest assured, the card will work.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
great solaris website for newbies http://solaris-x86.org/ feetyouwell Solaris / OpenSolaris 2 12-06-2006 12:14 AM
Solaris Installation - System Keeps Rebooting qs_tahmeed Solaris / OpenSolaris 3 07-18-2005 12:34 AM
vncserver for solaris x86? szehanz Solaris / OpenSolaris 3 04-26-2005 12:33 PM
How to get free x86 Solaris??? CONWON Solaris / OpenSolaris 2 09-01-2003 12:52 PM
solaris on an x86 Robert0380 Solaris / OpenSolaris 6 08-29-2003 02:34 AM


All times are GMT -5. The time now is 04:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration