LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris and OpenSolaris.
General Sun, SunOS and Sparc related questions also go here.

Notices

Reply
 
Search this Thread
Old 08-16-2010, 04:11 AM   #1
anupalbal
LQ Newbie
 
Registered: Aug 2010
Posts: 2

Rep: Reputation: 0
Nagios does not show the sidebar


I am having a peculiar issue wherein when I try to open the Nagios main page I don't get the side bar. Once I refresh the page, the side bar and main page are shown correctly. Apart from this I don't have any issues with. It updates the service status of remote clients, I can access various pages on it. It is more of an annoyance and I would just like to understand why it is doing it. I am putting down as much detail as I can. I am newbie to nagios so please let me know if you need more information.
1) Nagios version - 3.2.0
2) Using apache from coolstack
3) When I first hit the nagios page I can see the below in the access log of apache located at /opt/coolstack/apache2/logs
0.0.0.0 - nagiosadmin [16/Aug/2010:17:56:58 +1000] "GET /nagios/ HTTP/1.1" 200 718
0.0.0.0 - nagiosadmin [16/Aug/2010:17:56:58 +1000] "GET /nagios/side.php HTTP/1.1" 200 718
0.0.0.0 - nagiosadmin [16/Aug/2010:17:56:58 +1000] "GET /nagios/main.php HTTP/1.1" 200 2382
0.0.0.0 - nagiosadmin [16/Aug/2010:17:56:58 +1000] "GET /nagios/main.php HTTP/1.1" 200 2382

4) Once hit refresh on the page I see the below update in the same log
0.0.0.0 - nagiosadmin [16/Aug/2010:17:57:15 +1000] "GET /nagios/ HTTP/1.1" 200 718
0.0.0.0 - nagiosadmin [16/Aug/2010:17:57:15 +1000] "GET /nagios/side.php HTTP/1.1" 200 4309
0.0.0.0 - nagiosadmin [16/Aug/2010:17:57:15 +1000] "GET /nagios/main.php HTTP/1.1" 200 2382

Any ideas..?
 
Old 08-16-2010, 12:15 PM   #2
quanta
Member
 
Registered: Aug 2007
Location: Vietnam
Distribution: RedHat based, Debian based, Slackware, Gentoo
Posts: 724

Rep: Reputation: 100Reputation: 100
- Which browser are you using? Did you try with other?
- Could you please take a screenshot and post up here?

Last edited by quanta; 08-16-2010 at 12:24 PM.
 
Old 08-17-2010, 12:17 AM   #3
anupalbal
LQ Newbie
 
Registered: Aug 2010
Posts: 2

Original Poster
Rep: Reputation: 0
I am using firefox 3.6.8. However I am getting the same behavior on IE7 and Safari. Also I should mention that I am using Solaris 10 U7. Have uploaded a screen shot.
Attached Images
File Type: jpg nagios.JPG (123.1 KB, 5 views)
 
Old 08-17-2010, 12:44 AM   #4
quanta
Member
 
Registered: Aug 2007
Location: Vietnam
Distribution: RedHat based, Debian based, Slackware, Gentoo
Posts: 724

Rep: Reputation: 100Reputation: 100
- Refer to this thread.
- Try to increase debug level and see what you get
- Try to upgrade to latest stable version - 3.2.1.
 
  


Reply

Tags
nagios


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Nagios 3.1.2 + RHEL 5.3 You don't have permission to access /nagios/ on this server psix Linux - Server 12 05-14-2011 07:26 AM
cannot find Nagios web interface (Nagios 3.2.0) and O/S = Fedora 10 gutiojj Linux - Newbie 7 02-04-2010 09:55 AM
Nagios Daemon, PID not found but rc.nagios runs agentc0re Slackware 1 07-03-2007 03:47 PM
LXer: Nagios 2.5 and Oreon 1.3 (Nagios web front end) installation with screenshots LXer Syndicated Linux News 0 08-11-2006 06:33 PM
LXer: Nagios and Oreon (Nagios web front end) installation and Configuration LXer Syndicated Linux News 0 07-18-2006 09:33 PM


All times are GMT -5. The time now is 04:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration