LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Solaris / OpenSolaris (http://www.linuxquestions.org/questions/solaris-opensolaris-20/)
-   -   make: Warning: Both `makefile' and `Makefile' exist ? (http://www.linuxquestions.org/questions/solaris-opensolaris-20/make-warning-both-%60makefile-and-%60makefile-exist-757493/)

malli42108 09-24-2009 09:26 AM

make: Warning: Both `makefile' and `Makefile' exist ?
 
hi i installed perl-5.8.4 in solaris 8 machine.

all installation process goes correctly.

i approached below steps:

1.rm -f config.sh Policy.sh
2.sh configure -de
3.make
4.make test
5.make install

first two steps went correctly. when i give make it shows below info:

root@andd233 # make depend
root@andd233 # make
make: Warning: Both `makefile' and `Makefile' exist
make install.perl install.man STRIPFLAGS= DESTDIR=""
make: Warning: Both `makefile' and `Makefile' exist
Current working directory /usr/perl5/perl-5.8.4
make: Fatal error: Don't know how to make target `wince.h'
Current working directory /usr/perl5/perl-5.8.4
*** Error code 1
make: Fatal error: Command failed for target `install'

i saw makefile & Makefile in /usr/perl5/perl-5.8.4 directory.

when i tried to move these files to some other locations ,again these two files generating.

how to solve this issue? any idea?

Nutster 10-01-2009 06:37 AM

First, might I recommend installing 5.10.1 instead? It is available from cpan.org. I installed in on my Ubuntu Linux box with no difficulties.

Second, speaking of cpan.org, let's look at what their ports page has to say.
Quote:


Sun Solaris

Starting from Solaris 8 Perl 5 ships standard with Solaris. (Perl 5.005_03 with Solaris 8 (SunOS 5.8), SunOS 5.9 ("Solaris 9") includes Perl 5.6.1, SunOS 5.10 ("Solaris 10") includes Perl 5.8.4 (plus a lot of perl5-porters patches)
  • ActiveState pkgadd, ActiveState formats
  • SiePerl for Solaris by Siemens, contains several modules
  • Sun Freeware pkgadd format. Also a lot of other software available.
  • Prebuilt Perls by Rich Megginson, a special installer is used.

Maybe one of these can help. I have not tested these links, but they look promising.

That said, make usually looks for "makefile", then "Makefile" in the current directory for its script, unless you use the -f option.

It is interesting that both files are appearing, but that should not prevent you from compiling and installing perl. make should be reading "makefile" and ignoring "Makefile". It is giving you a warning in case you are modifying "Makefile" and hoping that those changes will be executed.

I hope these ideas help.

malli42108 10-08-2009 09:34 AM

hi

I installed perl-5.8.8 successfully. with below steps

rm -f config.sh Policy.sh
sh Configure -de
make
make test
make install

all went successfully.

but when i give this command old perl version displayed.
root@andd233 # perl -v

This is perl, version 5.005_03 built for sun4-solaris

Copyright 1987-1999, Larry Wall

Perl may be copied only under the terms of either the Artistic License or the
GNU General Public License, which may be found in the Perl 5.0 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using `man perl' or `perldoc perl'. If you have access to the
Internet, point your browser at http://www.perl.com/, the Perl Home Page.

root@andd233 #

how to get 5.8.8 version?

jlliagre 10-08-2009 10:35 AM

Use the full path to the perl release you just installed, possibly /usr/local/bin/perl.

Nutster 10-09-2009 12:41 PM

You might want to change your PATH variable to look at /usr/local/bin (or wherever the new version is) before /usr/bin (or where the original version was). which perl will tell you which perl you are going to execute.

malli42108 10-24-2009 09:09 AM

hi
thanks for your support.
i resolved my issue by giving this.
#/usr/local/bin/perl


All times are GMT -5. The time now is 10:50 AM.