LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris and OpenSolaris.
General Sun, SunOS and Sparc related questions also go here.

Notices

Reply
 
Search this Thread
Old 03-07-2008, 04:27 AM   #1
LinuxLover
Member
 
Registered: Feb 2004
Distribution: Solaris 10/11 , RHEL 6 ,AIX 7.1
Posts: 188

Rep: Reputation: 32
imap pop3 on solaris 10


Hello everyone,

I am trying to configue imap/pop3 on solaris 10 x86 server.

I have installed

openssl

imap-2006e

packages from www.sunfreeware.com .

Now I am trying to configure with the help of

http://www.sunfreeware.com/sol_10_imap_setup.html


But when after writing following in /etc/inetd.conf file

pop stream tcp nowait root /usr/local/sbin/ipop2d ipop2d
pop3 stream tcp nowait root /usr/local/sbin/ipop3d ipop3d
imap stream tcp nowait root /usr/local/sbin/imapd imapd
pop3s stream tcp nowait root /usr/local/sbin/ipop3d ipop3d
imaps stream tcp nowait root /usr/local/sbin/imapd imapd


I give the command
#inetconv -f

It does not accpet pop3s and imaps line and produces the following error.



[/usr/local/sbin]# inetconv -f
100235/1 -> /var/svc/manifest/network/rpc/100235_1-rpc_ticotsord.xml
Importing 100235_1-rpc_ticotsord.xml ...Done
inetconv: Error /etc/inet/inetd.conf line 27 invalid or inconsistent fields: service-name protocol
pop3 -> /var/svc/manifest/network/pop3-tcp.xml
Importing pop3-tcp.xml ...Done
imap -> /var/svc/manifest/network/imap-tcp.xml
Importing imap-tcp.xml ...Done
inetconv: Error /etc/inet/inetd.conf line 30 invalid or inconsistent fields: service-name protocol
inetconv: Error /etc/inet/inetd.conf line 31 invalid or inconsistent fields: service-name protocol


what should I do now?
 
Old 03-07-2008, 05:14 AM   #2
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,507

Rep: Reputation: 360Reputation: 360Reputation: 360Reputation: 360
Are pop3s and imaps defined in the /etc/services file ?
 
Old 03-07-2008, 06:34 AM   #3
LinuxLover
Member
 
Registered: Feb 2004
Distribution: Solaris 10/11 , RHEL 6 ,AIX 7.1
Posts: 188

Original Poster
Rep: Reputation: 32
Thank jlliagre
you are genius.



Above problem solved when I added two line in /etc/services
pop3s 995/tcp
imaps 993/tcp


Now some queries about that

I have created ssl certificate as give link at
http://www.sunfreeware.com/sol_10_imap_setup.html


When I try to connect a user from client machine receiving following error in server log file

Mar 7 04:25:11 alpha.example.com ipop3d[779]: [ID 890198 mail.alert] Unable to load certificate from /usr/local/ssl/certs/ipop3d.pem, host=[192.168.20.230]
Mar 7 04:25:13 alpha.example.com ipop3d[780]: [ID 890198 mail.alert] Unable to load certificate from /usr/local/ssl/certs/ipop3d.pem, host=[192.168.20.230]
[/]#
 
Old 03-08-2008, 03:54 AM   #4
LinuxLover
Member
 
Registered: Feb 2004
Distribution: Solaris 10/11 , RHEL 6 ,AIX 7.1
Posts: 188

Original Poster
Rep: Reputation: 32
Thanks buddy!

At last I am able to solve this problem too.

I am using the command

cd /usr/local/ssl/certs
/usr/local/ssl/bin/openssl req -new -x509 -nodes -out imapd.pem \
-keyout imapd.pem -days 365

Which is creating the certificate with the name of imapd.pem

While my imap application is trying to load pop3d.pem


I just replace the name and problem solved.

Thanks
 
Old 10-22-2009, 09:49 AM   #5
spanoudo
LQ Newbie
 
Registered: Oct 2009
Posts: 3

Rep: Reputation: 0
Hi guys I have a similar problem. I installed the SFWimap package from the solaris 10 companion CD.

I got to install the POP3 and IMAP servers. I also tried the secure IMAP and PO3 servers according to the same thread. When I tried to connect with secure IMAP there was no connection and on the solaris console I got the message:

Oct 21 20:33:05 hercules imapd[1013]: This server does not support SSL

Well, I searched a little and decided to install openssl 9.8 (from www.sunfreeware.com). After installing I rebooted the machine but I continue getting the same message.

Can you help me in getting my server to support SSL?

Thank you,
Nikos
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
pop3,imap dev_dks Linux - Networking 1 09-18-2006 03:01 AM
Pop3/imap jarrell Linux - General 6 07-15-2006 01:02 AM
courier imap can't auth. imap and pop3 adrianmak Linux - Software 1 12-11-2005 04:22 PM
qmail - different between POP3-IMAP -- Please help me b:z Linux - General 1 06-14-2005 06:14 AM
POP3 Imap Problems Cynthia Blue Linux - Software 2 11-13-2004 10:55 PM


All times are GMT -5. The time now is 02:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration