LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris and OpenSolaris.
General Sun, SunOS and Sparc related questions also go here.

Notices

Reply
 
Search this Thread
Old 11-18-2008, 04:48 PM   #16
code933k
Member
 
Registered: Aug 2007
Location: Bogot, Colombia. South America
Distribution: ArchLinux / Source Mage GNU Linux (test branch) / openSUSE
Posts: 130

Rep: Reputation: Disabled
Smile


Quote:
Originally Posted by jlliagre View Post
That wouldn't change terminals launched with the gui. I should be possible to do the same with the gnome launch script though.
Right! Anytime I need something like this, usually go to /usr/local/bin and replace the desired command with the one of my own.
 
Old 11-18-2008, 08:25 PM   #17
Jaxn
Member
 
Registered: Apr 2005
Location: Sweden
Distribution: Debian
Posts: 142

Rep: Reputation: 15
Then make a new profile in your gnome-terminal. Change which command you start the terminal with to
Quote:
gnome-terminal --geometry 76x44
in that profile. Start new terminals with this profile.

Change alias to same command in your ~/.bashrc

(Or you can make this new profile the default in gnome-terminal after you have tested it a while)

You could possible change it in gnome settings, but I have no time to look that up for you.

PS: This is an Gnome issue, not OpenSolaris DS:

Last edited by Jaxn; 11-18-2008 at 08:30 PM. Reason: Some cleaning up
 
Old 11-20-2008, 12:40 PM   #18
lifestream
LQ Newbie
 
Registered: Nov 2008
Posts: 2

Rep: Reputation: 0
Please type this in a terminal:
gksudo gedit /usr/share/applications/gnome-termninal.desktop
(Or however you get to root in open solaris)
Scroll all the way to the bottom.
Look for the line:
Exec=gnome-terminal
And replace it with:
Exec=gnome-terminal --geometry 77x48
Save, close, and then open any gnome-terminal. It will have the new geometry.

I know it works becase it just tested it myself.
 
Old 11-20-2008, 03:42 PM   #19
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,491

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
gksudo isn't implemented under Solaris as sudo isn't part of it.

You are right changing that Exec entry in the /usr/share/applications/gnome-terminal.desktop file will affect terminals launched from the menu. That won't change those open from the desktop though.
 
Old 11-20-2008, 06:17 PM   #20
lifestream
LQ Newbie
 
Registered: Nov 2008
Posts: 2

Rep: Reputation: 0
Quote:
Originally Posted by jlliagre View Post
gksudo isn't implemented under Solaris as sudo isn't part of it.
Yeah i wasn't sure but I included the info just in case.
Quote:
That won't change those open from the desktop though.
Big deal?! Just right click it and change it to have the new geometry? Oh, like that's difficult :P
 
Old 11-20-2008, 07:36 PM   #21
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,491

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
Not sure about what you suggest with right clicking.

I was referring to the terminal window launched by right clicking on the desktop and choosing the "Open Terminal" (or "Open in Terminal") menu entry. That one ignores the /usr/share/applications/gnome-terminal.desktop setting.
 
Old 11-22-2008, 01:53 AM   #22
Jaxn
Member
 
Registered: Apr 2005
Location: Sweden
Distribution: Debian
Posts: 142

Rep: Reputation: 15
Have you tried that change of profile and then making that profile your new default profile?
Shold work, as looking though gconf settings for your account for gnome-terminal also should work. There is a graphical and a terminal tool for changing those.
 
Old 11-22-2008, 11:39 AM   #23
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,491

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
Can you tell where in the gnome-terminal profile you can set its geometry ? I don't find any place to do it.
 
Old 11-29-2008, 04:03 PM   #24
Jaxn
Member
 
Registered: Apr 2005
Location: Sweden
Distribution: Debian
Posts: 142

Rep: Reputation: 15
Sigh... Look at answer #17 in this thread...
 
Old 11-30-2008, 01:47 AM   #25
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,491

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
Precisely. I was asking about that setting that I doesn't find. Please clarify.
 
Old 07-01-2009, 02:03 AM   #26
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,533
Blog Entries: 28

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
Lightbulb

Hello jillagre
Quote:
Originally Posted by jlliagre View Post
Precisely. I was asking about that setting that I doesn't find. Please clarify.
I understand you want to customize the geometry of the gnome-terminal window you get when you right click on the desktop and choose "Open terminal" or on a nautilus (non Side Pane) folder and choose "Open in terminal".

Regards "Open in terminal" only, the facility is provided by the open-in-terminal package and, AFAIK, there is no way to get it to do what you want.

You can do what you want (and a lot more) using the nautilus-actions package. First exploration of nautilus-actions suggests it is a very flexible tool, easily allowing a superset of open-in-terminal's facilities and thus obsoleting open-in-terminal except for very basic functionality or restricted environments.

Here's how to use nautilus-actions to set up a "Open root terminal here" in the same place as "Open in terminal" (I find Microsoft's wording more comprehensible than Gnome's; you don't open the directory in the terminal, you start the terminal in the directory). "Open terminal here" would be similar, without "-x su -" in the parameters.

root# aptitude install nautilus-actions

Applications→System→Preferences→Nautilus Actions Configuration
Add
Menu item and action
Label: Open root terminal here
Tooltip: <empty>
Icon: <your choice; not required if icons not displayed>
Path: /usr/bin/gnome-terminal
Parameters: --geometry=1028x768+0+0 --working-directory=%d -x su -
Conditions
Only folders: selected
The new menu item was not visible until logging off and back on (restarting nautilus). Same for configuration adjustments.

Anybody know if nautilus-actions can add context menu items to nautilus' Side Pane tree view folders -- and, if so, how?

Best

Charles

Last edited by catkin; 07-01-2009 at 02:08 AM. Reason: Better English and removed terminal profile
 
Old 07-22-2009, 05:48 PM   #27
ADxD_7
Member
 
Registered: May 2007
Location: CO
Distribution: Solaris , Redhat , Debian
Posts: 152

Rep: Reputation: 23
Quote:
Originally Posted by wrapster View Post
Hi all,

I have a very trivial question to ask,pls dont mind
I wanted to change the terminal size to 77*48 by default
How do i do it?
I looked around in the "profiles" tab under the edit section of terminal, but couldnt change it as default.
I am using snv_89

Thanks
I know this thread has been all over the place but.... the easiest way to do this is edit /usr/share/vte/termcap/xterm and look for

:co#115:it#8:li#36:\

( well dont pay attention to the numbers I put those there) - put 77 after "co#" and put 48 after "li#" - every terminal you open anywhere will default to this size

Sorry if I did not understand or missed something in the thread...but this has always worked best for me -

Edit: O wow this is an old thread...sorry for resurrecting it

Last edited by ADxD_7; 07-22-2009 at 05:50 PM.
 
Old 07-23-2009, 01:54 AM   #28
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,533
Blog Entries: 28

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
Hello ADxD_7
Quote:
Originally Posted by ADxD_7 View Post
I know this thread has been all over the place but.... the easiest way to do this is edit /usr/share/vte/termcap/xterm and look for

:co#115:it#8:li#36:\

( well dont pay attention to the numbers I put those there) - put 77 after "co#" and put 48 after "li#" - every terminal you open anywhere will default to this size

Sorry if I did not understand or missed something in the thread...but this has always worked best for me -

Edit: O wow this is an old thread...sorry for resurrecting it
Thanks for the info. Just tried it but didn't work for xterm or gnome-terminal. Some re-initialisation required? Which system does it work on for you?

Best

Charles
 
Old 07-23-2009, 12:05 PM   #29
ADxD_7
Member
 
Registered: May 2007
Location: CO
Distribution: Solaris , Redhat , Debian
Posts: 152

Rep: Reputation: 23
Quote:
Originally Posted by catkin View Post
Hello ADxD_7 Thanks for the info. Just tried it but didn't work for xterm or gnome-terminal. Some re-initialisation required? Which system does it work on for you?

Best

Charles
Well the only thing you should have to do is exit all gnome-terminal processes - and it should change it - I forgot that it only works for gnome-terminal not for xterm...sorry - easiest way to make it so xterm opens that size is put

alias xterm='xterm -geometry 77x48'

into your .bashrc or .cshrc or wherever is applicable for you
 
Old 07-24-2009, 09:20 AM   #30
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,533
Blog Entries: 28

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
Hello ADxD_7
Quote:
Originally Posted by ADxD_7 View Post
Well the only thing you should have to do is exit all gnome-terminal processes - and it should change it - I forgot that it only works for gnome-terminal not for xterm...sorry - easiest way to make it so xterm opens that size is put

alias xterm='xterm -geometry 77x48'

into your .bashrc or .cshrc or wherever is applicable for you
Thanks. It worked, not after exiting all terminals but after rebooting (might have worked after logoff/on but was rebooting anyway). This may be the only way of changing the terminal provided by the open-in-terminal package.

Kind of weird that a file called xterm should affect gnome-terminal -- and not xterm!!! Nobody ever said Linux was consistent

Best

Charles
 
  


Reply

Tags
context, menu, nautilus, nautilusactions, terminal


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
change font size in terminal window homerjpbody Linux - Newbie 3 08-08-2008 09:26 PM
terminal size perl sci3ntist Programming 1 09-02-2007 11:51 PM
How to change font color and font size in terminal ? wlaw Linux - Newbie 3 05-15-2007 08:57 PM
How do i change the size of a xterm window or lanch one with a specified size? Garavix Linux - Newbie 2 04-20-2006 09:06 PM
Terminal Screen Size slappycakes Linux - Newbie 5 11-26-2003 05:33 PM


All times are GMT -5. The time now is 01:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration