LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris and OpenSolaris.
General Sun, SunOS and Sparc related questions also go here.

Notices

Reply
 
Search this Thread
Old 10-02-2008, 09:55 AM   #1
wrapster
Member
 
Registered: May 2008
Posts: 155

Rep: Reputation: 30
how to change the size of terminal?


Hi all,

I have a very trivial question to ask,pls dont mind
I wanted to change the terminal size to 77*48 by default
How do i do it?
I looked around in the "profiles" tab under the edit section of terminal, but couldnt change it as default.
I am using snv_89

Thanks
 
Old 10-03-2008, 05:13 AM   #2
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,522

Rep: Reputation: 365Reputation: 365Reputation: 365Reputation: 365
I don't know if there is a default configuration file. You can create a launcher script passing the sizing option as an alternative:
Code:
gnome-terminal --geometry 77x48
 
Old 10-03-2008, 09:14 AM   #3
wrapster
Member
 
Registered: May 2008
Posts: 155

Original Poster
Rep: Reputation: 30
This did not change anything !
It just pops up another terminal but again with the default size!
 
Old 10-03-2008, 09:40 AM   #4
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,522

Rep: Reputation: 365Reputation: 365Reputation: 365Reputation: 365
Hmm, double check. It certainly works fine with me.
 
Old 10-04-2008, 02:02 AM   #5
wrapster
Member
 
Registered: May 2008
Posts: 155

Original Poster
Rep: Reputation: 30
Yes i did recheck it.
But even though i specify the geometry a terminal opens up with the default config only
 
Old 10-04-2008, 03:53 AM   #6
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,522

Rep: Reputation: 365Reputation: 365Reputation: 365Reputation: 365
You mean when you run the command "gnome-terminal --geometry 77x48" from the command line, a 80x24 terminal window is showing up ??
 
Old 10-04-2008, 10:31 AM   #7
wrapster
Member
 
Registered: May 2008
Posts: 155

Original Poster
Rep: Reputation: 30
yes!
And secondly i even exited all the gnome apps that were running thinking that it will take effect after everything is quit
but still no use!
 
Old 10-04-2008, 04:23 PM   #8
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,522

Rep: Reputation: 365Reputation: 365Reputation: 365Reputation: 365
Try "gnome-terminal --disable-factory --geometry 20x20 &"

If the size is still wrong, post the output of "ptree $$" run from the new terminal window.
 
Old 10-05-2008, 09:59 AM   #9
wrapster
Member
 
Registered: May 2008
Posts: 155

Original Poster
Rep: Reputation: 30
It still didnt work!

ptree o/p
Code:
bash-3.2# ptree $$
986   gnome-terminal
  2869  sh
    2872  bash
      2873  ptree 2872
 
Old 10-05-2008, 12:33 PM   #10
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,522

Rep: Reputation: 365Reputation: 365Reputation: 365Reputation: 365
I think you missed to run the ptree command from the new window, not the one from where you ran the gnome-terminal command.
 
Old 10-08-2008, 03:49 AM   #11
wrapster
Member
 
Registered: May 2008
Posts: 155

Original Poster
Rep: Reputation: 30
no i did run it from another window!
and thats what i got
 
Old 10-08-2008, 03:55 AM   #12
wrapster
Member
 
Registered: May 2008
Posts: 155

Original Poster
Rep: Reputation: 30
Ok so the mistake i was doing is instead of using "x" i was using *
Since it was multiplication ..didnt realize. Am sorry

But this command will only spawn only one terminal with the specified geometry... and i dont have a .bashrc file either!
So if i do a ctrl+shift+n
The next window opens up with the default geo only
How do i make it permanent
 
Old 10-08-2008, 04:54 AM   #13
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,522

Rep: Reputation: 365Reputation: 365Reputation: 365Reputation: 365
Quote:
Originally Posted by wrapster View Post
no i did run it from another window!
and thats what i got
You are still missing what I asked for. Should you have understood my request, the * vs x confusion would have been detected earlier as the bogus argument would have been printed in the ptree output.
Quote:
But this command will only spawn only one terminal with the specified geometry... and i dont have a .bashrc file either!
What .bashrc has to do with it ?
Quote:
So if i do a ctrl+shift+n
The next window opens up with the default geo only
You can use ctrl-shift-t (new tab) instead. The size remains identical.
Quote:
How do i make it permanent
As far as I know, you can't unless you are ready to patch and contribute to the gnome-terminal code.
 
Old 11-13-2008, 12:20 AM   #14
code933k
Member
 
Registered: Aug 2007
Location: Bogotá, Colombia. South America
Distribution: ArchLinux / Source Mage GNU Linux (test branch) / openSUSE
Posts: 130

Rep: Reputation: Disabled
Quote:
Originally Posted by wrapster View Post
Ok so the mistake i was doing is instead of using "x" i was using *
Since it was multiplication ..didnt realize. Am sorry

But this command will only spawn only one terminal with the specified geometry... and i dont have a .bashrc file either!
So if i do a ctrl+shift+n
The next window opens up with the default geo only
How do i make it permanent
Inside ~/.bashrc write
Code:
alias gnome-terminal="gnome-terminal --your-arguments $@"
If that's what you were expecting for.
 
Old 11-13-2008, 02:47 AM   #15
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,522

Rep: Reputation: 365Reputation: 365Reputation: 365Reputation: 365
That wouldn't change terminals launched with the gui. I should be possible to do the same with the gnome launch script though.
 
  


Reply

Tags
context, menu, nautilus, nautilusactions, terminal


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
change font size in terminal window homerjpbody Linux - Newbie 3 08-08-2008 10:26 PM
terminal size perl sci3ntist Programming 1 09-03-2007 12:51 AM
How to change font color and font size in terminal ? wlaw Linux - Newbie 3 05-15-2007 09:57 PM
How do i change the size of a xterm window or lanch one with a specified size? Garavix Linux - Newbie 2 04-20-2006 10:06 PM
Terminal Screen Size slappycakes Linux - Newbie 5 11-26-2003 06:33 PM


All times are GMT -5. The time now is 10:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration