LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris and OpenSolaris.
General Sun, SunOS and Sparc related questions also go here.

Notices

Reply
 
Search this Thread
Old 12-26-2007, 03:59 AM   #1
abd_bela
Member
 
Registered: Dec 2002
Location: algeria
Distribution: redhat 7.3, debian lenny
Posts: 598

Rep: Reputation: 31
How to change keyboard layout


HI,
I am new to solaris, but my knowleges on linux ( debian ) is good, i need equivalent for some linux commands. ( a summarize doc is welcome, I downloaded one: Linux to Solaris from treklogic, but not complete enough, and I want to use the opensolaris, it seems close to debian, with gnome desktop)

I ve installed the opensolaris ( in-preview 31 octobre).

1. I don't find where to change the default keybaord, although gnome is the gui used, I can't find in /etc/X11, the xorg.conf or X11Config. The kbd command doesn't work for X11. There is not in added applet the corresponding to keyboard layout.

2. How to detect the network card, if it not assign at the installation? the logical name on linux is eth0, what is on Solaris

3. How to configure the source to add software ( a-la-apt-get of debian)

4. Is there as in linux CTRL-ALT-F2, F6 to switch to text consol?

best regards

thanks for help
bela
 
Old 12-26-2007, 08:59 AM   #2
yawe_frek
Member
 
Registered: Sep 2005
Distribution: feather 0.72-usb, DSL,CentOS,Ubuntu, Redhat 9
Posts: 144

Rep: Reputation: 15
in similar case.

i am redhat user
 
Old 12-26-2007, 09:18 AM   #3
crisostomo_enrico
Member
 
Registered: Dec 2005
Location: Madrid
Distribution: Solaris 10, Solaris Express Community Edition
Posts: 547

Rep: Reputation: 35
2 - the name depends on the driver it uses. There are plenty of posts in linuxquestions.org to begin troubleshoot this issue. I'm not an expert, indeed.
3 - Solaris doesn't (yet) have a network package repository to add software from. That's one of the goals of project Indiana.
4 - You can either temporarily disable desktop login with dtconfig (read man page for details), or choose to login at the console from the menu you have right there in the GUI login or you can boot in single user mode.

By the way, weren't you asked during installation to choose the keyboard layout? Or do you want to change it just for one user? I'm using Solaris Express Developer Edition 09/07 but since a couple of versions I had, I added some keyboard layouts to my user configuration and switch between them with ctrl+space. I don't remember where I configured it, though, I should check at home, but it's should just be the keyboard configuration applet of GNOME.
 
Old 12-26-2007, 11:05 AM   #4
crisostomo_enrico
Member
 
Registered: Dec 2005
Location: Madrid
Distribution: Solaris 10, Solaris Express Community Edition
Posts: 547

Rep: Reputation: 35
I confirm that I added some keyboard layouts in my user GNOME configuration using the "Input methods" applet and it works like a charm.

Have you tried this?
 
Old 12-27-2007, 02:45 PM   #5
kebabbert
Member
 
Registered: Jul 2005
Posts: 462

Rep: Reputation: 41
3. There are several different package managers under Solaris. blastwave.org is one. CBE is another. This issue is being worked on, in Solaris version "indiana".
 
Old 12-27-2007, 03:28 PM   #6
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,502

Rep: Reputation: 357Reputation: 357Reputation: 357Reputation: 357
1.
Code:
/usr/sbin/eeprom kbd-type Norwegian
Your mileage may vary ...
 
Old 01-07-2008, 04:15 AM   #7
abd_bela
Member
 
Registered: Dec 2002
Location: algeria
Distribution: redhat 7.3, debian lenny
Posts: 598

Original Poster
Rep: Reputation: 31
Quote:
Originally Posted by crisostomo_enrico View Post
I confirm that I added some keyboard layouts in my user GNOME configuration using the "Input methods" applet and it works like a charm.

Have you tried this?
There is no input applet, on opensolaris (in-preview), I can't find it, what it the callback command for it!!
 
Old 01-07-2008, 06:28 AM   #8
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,502

Rep: Reputation: 357Reputation: 357Reputation: 357Reputation: 357
What about my eeprom suggestion ?
Did you try it or is it irrelevant to your locale/keyboard ?
 
Old 01-07-2008, 11:55 AM   #9
crisostomo_enrico
Member
 
Registered: Dec 2005
Location: Madrid
Distribution: Solaris 10, Solaris Express Community Edition
Posts: 547

Rep: Reputation: 35
Quote:
I'm using Solaris Express Developer Edition 09/07
I quote myself: I said that there's such applet in Solaris Express Developer Edition, and as far as I know (I'm not a GNOME user on linux), that applet is pretty common in the recent GNOME installations I saw, that's why I went straight to it. Didn't you see any "Input methods" applet in your Preferences menu item?

Last edited by crisostomo_enrico; 01-07-2008 at 11:56 AM.
 
Old 01-07-2008, 12:00 PM   #10
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,502

Rep: Reputation: 357Reputation: 357Reputation: 357Reputation: 357
Beware of the confusion created by the recent Indiana branding as "Open Solaris distribution" while until recently, the de facto Open Solaris distribution was "Solaris Express".

It is possible that the gnome input applet didn't make it to Indiana.
 
Old 01-29-2008, 07:43 AM   #11
peter.nienhuis
LQ Newbie
 
Registered: Jan 2008
Posts: 3

Rep: Reputation: 0
keyboard layout sol express 0907

Hi, i found out the /etc/default/kbd file has to be changed manually, uncomment LAYOUT and specify the language (in my case Spanish)this will override the eeprom settings and will get you access
 
Old 01-30-2008, 03:26 AM   #12
yvesvanbelle
Member
 
Registered: Jan 2007
Location: Belgium
Distribution: Debian, Ubuntu, Mandriva
Posts: 67

Rep: Reputation: 15
Hello abd_bela,

If you want to change the keyboard layout of Xorg, you can use as su (not su-) the command /usr/X11/bin/xorgcfg. This will give you a GUI to change the keyboard layout.

Best regards,

Yves

Last edited by yvesvanbelle; 01-30-2008 at 03:27 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot change keyboard layout mikerobinson Linux - Hardware 10 04-20-2009 03:54 PM
xfce change keyboard layout tramni1980 Slackware 1 07-12-2007 01:58 PM
Need to change keyboard layout anti.corp Solaris / OpenSolaris 4 04-02-2006 06:02 AM
Why I cannot change my keyboard layout? GregSP Mandriva 3 01-14-2006 05:48 PM
How do i change the keyboard layout? ArmedCoder Linux - Hardware 0 11-20-2003 06:25 PM


All times are GMT -5. The time now is 11:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration