LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Solaris / OpenSolaris (http://www.linuxquestions.org/questions/solaris-opensolaris-20/)
-   -   How to change keyboard layout (http://www.linuxquestions.org/questions/solaris-opensolaris-20/how-to-change-keyboard-layout-609160/)

abd_bela 12-26-2007 04:59 AM

How to change keyboard layout
 
HI,
I am new to solaris, but my knowleges on linux ( debian ) is good, i need equivalent for some linux commands. ( a summarize doc is welcome, I downloaded one: Linux to Solaris from treklogic, but not complete enough, and I want to use the opensolaris, it seems close to debian, with gnome desktop)

I ve installed the opensolaris ( in-preview 31 octobre).

1. I don't find where to change the default keybaord, although gnome is the gui used, I can't find in /etc/X11, the xorg.conf or X11Config. The kbd command doesn't work for X11. There is not in added applet the corresponding to keyboard layout.

2. How to detect the network card, if it not assign at the installation? the logical name on linux is eth0, what is on Solaris

3. How to configure the source to add software ( a-la-apt-get of debian)

4. Is there as in linux CTRL-ALT-F2, F6 to switch to text consol?

best regards

thanks for help
bela

yawe_frek 12-26-2007 09:59 AM

in similar case.

i am redhat user

crisostomo_enrico 12-26-2007 10:18 AM

2 - the name depends on the driver it uses. There are plenty of posts in linuxquestions.org to begin troubleshoot this issue. I'm not an expert, indeed.
3 - Solaris doesn't (yet) have a network package repository to add software from. That's one of the goals of project Indiana.
4 - You can either temporarily disable desktop login with dtconfig (read man page for details), or choose to login at the console from the menu you have right there in the GUI login or you can boot in single user mode.

By the way, weren't you asked during installation to choose the keyboard layout? Or do you want to change it just for one user? I'm using Solaris Express Developer Edition 09/07 but since a couple of versions I had, I added some keyboard layouts to my user configuration and switch between them with ctrl+space. I don't remember where I configured it, though, I should check at home, but it's should just be the keyboard configuration applet of GNOME.

crisostomo_enrico 12-26-2007 12:05 PM

I confirm that I added some keyboard layouts in my user GNOME configuration using the "Input methods" applet and it works like a charm.

Have you tried this?

kebabbert 12-27-2007 03:45 PM

3. There are several different package managers under Solaris. blastwave.org is one. CBE is another. This issue is being worked on, in Solaris version "indiana".

jlliagre 12-27-2007 04:28 PM

1.
Code:

/usr/sbin/eeprom kbd-type Norwegian
Your mileage may vary ...

abd_bela 01-07-2008 05:15 AM

Quote:

Originally Posted by crisostomo_enrico (Post 3001989)
I confirm that I added some keyboard layouts in my user GNOME configuration using the "Input methods" applet and it works like a charm.

Have you tried this?

There is no input applet, on opensolaris (in-preview), I can't find it, what it the callback command for it!!

jlliagre 01-07-2008 07:28 AM

What about my eeprom suggestion ?
Did you try it or is it irrelevant to your locale/keyboard ?

crisostomo_enrico 01-07-2008 12:55 PM

Quote:

I'm using Solaris Express Developer Edition 09/07
I quote myself: I said that there's such applet in Solaris Express Developer Edition, and as far as I know (I'm not a GNOME user on linux), that applet is pretty common in the recent GNOME installations I saw, that's why I went straight to it. Didn't you see any "Input methods" applet in your Preferences menu item?

jlliagre 01-07-2008 01:00 PM

Beware of the confusion created by the recent Indiana branding as "Open Solaris distribution" while until recently, the de facto Open Solaris distribution was "Solaris Express".

It is possible that the gnome input applet didn't make it to Indiana.

peter.nienhuis 01-29-2008 08:43 AM

keyboard layout sol express 0907
 
Hi, i found out the /etc/default/kbd file has to be changed manually, uncomment LAYOUT and specify the language (in my case Spanish)this will override the eeprom settings and will get you access

yvesvanbelle 01-30-2008 04:26 AM

Hello abd_bela,

If you want to change the keyboard layout of Xorg, you can use as su (not su-) the command /usr/X11/bin/xorgcfg. This will give you a GUI to change the keyboard layout.

Best regards,

Yves


All times are GMT -5. The time now is 01:15 PM.