LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris and OpenSolaris.
General Sun, SunOS and Sparc related questions also go here.

Notices

Reply
 
Search this Thread
Old 09-30-2009, 09:13 AM   #1
czezz
Member
 
Registered: Nov 2004
Location: Poland/Warsaw
Distribution: Slackware/Solaris
Posts: 571

Rep: Reputation: 30
CDE graphical-login/cde-login in maintenance state


I installed Solaris 10 and when system started up I cant connect to it via Xmanager. (ssh works fine).

I have checked svcs for CDE:
Code:
[root@server /] svcs -a | grep cde
disabled       15:03:57 svc:/network/rpc/cde-calendar-manager:default
online         15:04:29 svc:/network/rpc/cde-ttdbserver:tcp
online         15:04:33 svc:/network/cde-spc:default
maintenance    15:41:49 svc:/application/cde-printinfo:default
maintenance    16:00:50 svc:/application/graphical-login/cde-login:default
so digged deeper for application/graphical-login/cde-login:default - it must be a cause of problem.

Code:
[root@server /] svcs -x svc:/application/graphical-login/cde-login:default
svc:/application/graphical-login/cde-login:default (CDE login)
 State: maintenance since Wed Sep 30 16:00:50 2009
Reason: Start method failed repeatedly, last exited with status 137.
   See: http://sun.com/msg/SMF-8000-KS
   See: dtlogin(1)
   See: /var/svc/log/application-graphical-login-cde-login:default.log
Impact: This service is not running.
...so fially I have check log file:
Code:
cat /var/svc/log/application-graphical-login-cde-login:default.log

[ wrz 30 15:58:25 Leaving maintenance because clear requested. ]
[ wrz 30 15:58:25 Enabled. ]
[ wrz 30 15:58:25 Executing start method ("lib/svc/method/svc-dtlogin") ]
ld.so.1: dtlogin: fatal: libtt.so.2: open failed: No such file or directory
Killed
[ wrz 30 15:58:25 Method "start" exited with status 137 ]
[ wrz 30 16:00:50 Leaving maintenance because clear requested. ]
[ wrz 30 16:00:50 Enabled. ]
[ wrz 30 16:00:50 Executing start method ("lib/svc/method/svc-dtlogin") ]
ld.so.1: dtlogin: fatal: libtt.so.2: open failed: No such file or directory
Killed
[ wrz 30 16:00:50 Method "start" exited with status 137 ]
...and now I completly have no idea what to do ?
Does anyone understand what happans here ?
 
Old 09-30-2009, 09:20 AM   #2
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,500

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
The SUNWtltk package contains the libtt.so.2 file. Either this package is corrupted on your machine or simply missing.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
To switch from console login to CDE login Paris Heng Solaris / OpenSolaris 2 04-23-2009 07:53 PM
My CDE GUI login is disappeared !? txn Solaris / OpenSolaris 11 03-13-2008 03:14 PM
How can I get MAILMSG in CDE login AbrahamJose AIX 0 06-14-2006 09:58 PM
Not able to login as user on CDE vishnu Solaris / OpenSolaris 4 02-06-2006 01:36 AM
Logging failed CDE login ]un]ie Solaris / OpenSolaris 5 12-19-2004 07:18 AM


All times are GMT -5. The time now is 09:34 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration