LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Solaris / OpenSolaris
User Name
Password
Solaris / OpenSolaris This forum is for the discussion of Solaris and OpenSolaris.
General Sun, SunOS and Sparc related questions also go here.

Notices

Reply
 
Search this Thread
Old 03-17-2008, 05:34 AM   #1
czezz
Member
 
Registered: Nov 2004
Distribution: Slackware/Solaris
Posts: 590

Rep: Reputation: 30
Adding 2nd NIC


I have already configured int. hme0. (159.107.88.150 mask 255.255.0.0 gw 159.107.88.254)

To add another unused int fjgi0 I had executed
Code:
ifconfig fjgi0 plumb
. This made that fjgi0 int. is viewable.


What I need to do now is to add this int. to network 192.168.0.0.

Is it just enough to add entries like below:

/etc/inet/ipnodes
127.0.0.1 localhost
159.107.88.150 prode1 loghost
192.168.0.2 temp1

/etc/defaultrouter
159.107.88.254
??? - what gateway should be used now ?

/etc/netmasks
159.107.0.0 255.255.0.0
192.168.0.0 255.255.255.0

/etc/hosts
127.0.0.1 localhost
159.107.88.150 prod1 loghost
192.168.0.2 temp1

and create /etc/hostname.fjgi0
temp1

Should it just work like that after execute:
Code:
svcadm restart network/physical
If not how multi-NIC configuration should looks like ?
 
Old 03-17-2008, 05:40 AM   #2
jlliagre
Moderator
 
Registered: Feb 2004
Location: Outside Paris
Distribution: Solaris10, Solaris 11, Mint, OL
Posts: 9,522

Rep: Reputation: 365Reputation: 365Reputation: 365Reputation: 365
These steps look okay to me.
 
Old 03-17-2008, 05:57 AM   #3
czezz
Member
 
Registered: Nov 2004
Distribution: Slackware/Solaris
Posts: 590

Original Poster
Rep: Reputation: 30
Dont know why but after I plugged cable into fjgi0 port (which is on additional card) the LED's wont light. Also no traffic can be found.
I checked wire and it's OK.

Wonder is it maybe a matter of hardware... not configuration.
Will be digging into that.

Thanks for confirmation
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Solaris 10 adding/seeing 2nd Nic jonfa Solaris / OpenSolaris 7 05-03-2007 09:53 AM
Adding 2nd NIC diff subnet - looking for how to? tiger.woods Linux - Networking 2 04-11-2007 03:55 PM
Adding 2nd NIC for LAN EgoX Linux - Networking 8 02-13-2006 09:45 PM
Adding 2nd NIC to FC4 Machine lucktsm Linux - Networking 3 01-07-2006 09:12 PM
Problem with adding a 2nd NIC to RH 7.0 IHawk Linux - Networking 0 02-18-2001 10:44 PM


All times are GMT -5. The time now is 02:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration