LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware - Installation (http://www.linuxquestions.org/questions/slackware-installation-40/)
-   -   while install run, laptop turn power to off (http://www.linuxquestions.org/questions/slackware-installation-40/while-install-run-laptop-turn-power-to-off-939138/)

xavier_slackware 04-10-2012 03:28 PM

while install run, laptop turn power to off
 
Hi to all,

I try to install Slackware from DVD. In middle installation, the laptop turn power to off.

How can I run all installation on laptops ?

Thanks, see you.

ukiuki 04-10-2012 06:42 PM

Could you post hardware specifications please? Does this machine turn off while installing any other system?
This may be issue with the internal fan and the machine is overheating so it just turn off as safety masure.

Regards

xavier_slackware 04-11-2012 07:16 AM

Hi ukiuki,

Hardware is a acer ASPIRE 5315.

Yes, in Ubuntu installation if I set noapic noacpi and nolpaic the isntallation finally OK.

How can I it in Slackware installation ?

Thanks, see you.

blue_k 04-11-2012 10:30 AM

Quote:

Originally Posted by xavier_slackware (Post 4650061)
Hi ukiuki,

Hardware is a acer ASPIRE 5315.

Yes, in Ubuntu installation if I set noapic noacpi and nolpaic the isntallation finally OK.

How can I it in Slackware installation ?

Thanks, see you.

Before booting, type those in as the kernel parameters.

xavier_slackware 04-11-2012 12:24 PM

Quote:

Originally Posted by blue_k (Post 4650207)
Before booting, type those in as the kernel parameters.

I type 'hugesmp.s noapic nolapic noacpi' before booting installation with same result.

Ideas ? Thanks, see you.

onebuck 04-18-2012 11:05 AM

Member response
 
Hi,

Quote:

Originally Posted by xavier_slackware (Post 4650302)
I type 'hugesmp.s noapic nolapic noacpi' before booting installation with same result.

Ideas ? Thanks, see you.

Look at kernel-parameters.txt;
Quote:

acpi= [HW,ACPI,X86] Advanced Configuration and Power Interface Format: { force | off | strict | noirq | rsdt } force -- enable ACPI if default was off off -- disable ACPI if default was on noirq -- do not use ACPI for IRQ routing strict -- Be less tolerant of platforms that are not strictly ACPI specification compliant. rsdt -- prefer RSDT over (default) XSDT copy_dsdt -- copy DSDT to memory See also Documentation/power/pm.txt, pci=noacpi
So you would use acpi=off or pci=noacpi (pci.txt) as parameter to pass to the kernel.

So;
Code:

hugesmp.s noapic nolapic acpi=off
Or
hugesmp.s noapic nolapic pci=noacpi

Would be correct.

slackjawed 10-27-2013 07:38 PM

slackware power off during installation
 
Hi all,

I am having the same problem, my 3 year old toshiba satellite laptop powers off early during installation even though I ran the commands you recommended here

hugesmp.s noapic nolapic acpi=off -- actually slackware only recognises huge.s not hugesmp.c
Or
hugesmp.s noapic nolapic pci=noacpi

Neither of them worked though, just about to give up on slackware, any thoughts anyone?

---------- Post added 10-27-13 at 08:38 PM ----------

btw, it's the latest slackware 14


All times are GMT -5. The time now is 09:04 PM.