LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices

Reply
 
Search this Thread
Old 10-12-2012, 12:24 AM   #1
velikij
Member
 
Registered: Oct 2005
Location: Santa Cruz, CA, USA
Distribution: Ubuntu Precise, Xubuntu Precise, Debian 6.0, Slackware 14, others.
Posts: 34

Rep: Reputation: 0
Exclamation VIA Technologies, Inc. VT8623 [Apollo CLE266] - xorg with openchrome segfaults


My video card on an old VIA-based system is not getting configured properly. The card is VIA Technologies, Inc. VT8623 [Apollo CLE266] integrated CastleRock graphics (rev 03).

Linux distro/version and kernel version:
Slackware 14.0
Linux trippy 3.2.29 #2 Mon Sep 17 14:10:59 CDT 2012 i686 VIA Samuel 2 CentaurHauls GNU/Linux
vendor_id : CentaurHauls
cpu family : 6
stepping : 3
model : 7
model name : VIA Samuel 2
cpu MHz : 799.014
cache size : 64 KB
cpuid level : 1
bogomips : 1598.02
clflush size : 32
MemTotal: 469872 kB
MemFree: 10460 kB

I tried configuring X with the xorgsetup program, resulting in an xorg.conf file which looked reasonable to me, but the openchrome driver crashes during initialization with startx.

I then added some modifications to xorg.conf, like

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
Option "DPMS"
HorizSync 28-51
VertRefresh 43-60
EndSection

and

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
... on to "Depth 24".

but, looking at the end of /var/log/Xorg.0.log,there is a segfault:

[ 96846.932] (II) CHROME(1): VIAGetRec
[ 96846.932] (**) CHROME(1): Depth 24, (--) framebuffer bpp 32
[ 96846.932] (==) CHROME(1): RGB weight 888
[ 96846.933] (==) CHROME(1): Default visual is TrueColor
[ 96846.933] (--) CHROME(1): Chipset: CLE266
[ 96846.933]
[ 96846.933] Backtrace:
[ 96846.934] 0: /usr/bin/X (xorg_backtrace+0x49) [0x81b54b9]
[ 96846.934] 1: /usr/bin/X (0x8048000+0x170d26) [0x81b8d26]
[ 96846.934] 2: linux-gate.so.1 (__kernel_rt_sigreturn+0x0) [0xffffe410]
[ 96846.934]
[ 96846.934] Segmentation fault at address (nil)
[ 96846.934]
Fatal server error:
[ 96846.934] Caught signal 11 (Segmentation fault). Server aborting
[ 96846.934]

I can attach the xorg.conf and Xorg.0.log files etc, if necessary.

This system formerly ran some old versions of Ubuntu and recently Debian 6.0 with no problem, also with an openchrome driver. I have another similar system which still runs Debian 6.0. with the openchrome driver.
 
Old 10-14-2012, 02:44 AM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,156

Rep: Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012
If not already done I suggest you fallback to vesa till you solve the issue with openchrome. As root:
(1) "mv /etc/X11/xorg.conf /etc/X11/xorg.conf-openchrome"
(2) "cp /etc/X11/xorg.conf-vesa /etc/X11/xorg-vesa.conf"
(3) startx
 
Old 10-14-2012, 08:08 PM   #3
velikij
Member
 
Registered: Oct 2005
Location: Santa Cruz, CA, USA
Distribution: Ubuntu Precise, Xubuntu Precise, Debian 6.0, Slackware 14, others.
Posts: 34

Original Poster
Rep: Reputation: 0
Exclamation xorg.conf and Xorg.0.log

Thank you, Didier! For some reason, this didn't work. Here are my xorg.conf file and resulting Xorg.0.log file.

I am using what I believer to be the original xorg.conf.vesa file. I had tried various xorg.conf files, including one generated by booting the live slax CD - even though that is based on an earlier slackware version.
Attached Files
File Type: txt xorg.conf.txt (15.5 KB, 4 views)
File Type: log Xorg.0.log (6.9 KB, 4 views)
 
Old 10-14-2012, 08:10 PM   #4
velikij
Member
 
Registered: Oct 2005
Location: Santa Cruz, CA, USA
Distribution: Ubuntu Precise, Xubuntu Precise, Debian 6.0, Slackware 14, others.
Posts: 34

Original Poster
Rep: Reputation: 0
By the way, the slax live CD did boot and display X.

Perhaps I failed to install something crucial for running the vesa driver.
 
Old 10-15-2012, 03:36 AM   #5
el chapulín
Member
 
Registered: Sep 2012
Posts: 75

Rep: Reputation: 19
Go into the BIOS setup and ensure that you've allocated enough RAM to the VGA - 32MB is usually enough, but anything below that and you might have problems.
 
Old 10-15-2012, 04:35 AM   #6
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,156

Rep: Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012
It seems vesa can't be used because your GPU is already claimed by a conflicting kernel driver, as says the X log:
Code:
[   681.975] vesa: Ignoring device with a bound kernel driver
Please provide lsmod's output so we know which one it is. Then we will simply blacklist the involved driver and you should be able to start X. There is no point in tweaking your xorg.conf file, its settings are not involved in this issue.

So simply type:

Code:
lsmod > lsmod.txt
and append lsmod.txt to your next post.

EDIT In addition, type:
Code:
lspci -k | grep -A3 VGA > lspci.txt
and append lspci.txt to your next post.

Last edited by Didier Spaier; 10-15-2012 at 04:39 AM. Reason: EDIT added
 
Old 10-16-2012, 07:11 PM   #7
velikij
Member
 
Registered: Oct 2005
Location: Santa Cruz, CA, USA
Distribution: Ubuntu Precise, Xubuntu Precise, Debian 6.0, Slackware 14, others.
Posts: 34

Original Poster
Rep: Reputation: 0
Exclamation

Looks like here's the problem - thanks, Didier!

# lspci -k | grep -A3 VGA
01:00.0 VGA compatible controller: VIA Technologies, Inc. VT8623 [Apollo CLE266] integrated CastleRock graphics (rev 03)
Subsystem: VIA Technologies, Inc. VT8623 [Apollo CLE266] integrated CastleRock graphics
Kernel driver in use: vt8623fb

I also attached the basic lsmod ouput.

I don't think there's a BIOS memory allocation problem, as someone suggested - this system has run several Linux distros, including the latest Debian, with no display problem, usually with an openchrome driver.

The via8623 driver is possibly the manufacturer's driver, distinct from both vesa and openchrome.

So, how do I blacklist the offending driver?

Peter
Attached Files
File Type: txt lsmod.txt (1.8 KB, 2 views)

Last edited by velikij; 10-16-2012 at 07:16 PM.
 
Old 10-17-2012, 02:12 AM   #8
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,156

Rep: Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012
vt8623fb is a kernel module included in the kernel, not a proprietary driver

My guess is that it is loaded at boot simply because it is intended for your chipset. It is easy to check. If you issue the command "modinfo vt8623fb" you will get this:
Code:
filename:       /lib/modules/2.6.37.6-smp/kernel/drivers/video/vt8623fb.ko
description:    fbdev driver for integrated graphics core in VIA VT8623 [CLE266]
license:        GPL
author:         (c) 2006 Ondrej Zajicek <santiago@crfreenet.org>
alias:          pci:v00001106d00003122sv*sd*bc*sc*i*
depends:        svgalib,vgastate
vermagic:       2.6.37.6-smp SMP mod_unload 686 
parm:           mode_option:Default video mode ('640x480-8@60', etc) (charp)
parm:           mode:Default video mode e.g. '648x480-8@60' (deprecated) (charp)
parm:           mtrr:Enable write-combining with MTRR (1=enable, 0=disable, default=1) (int)
I have put in bold the vendor Id and the Device Id. My guess is that if you type this:
Code:
lspci -nn - grep VGA
you will see this at the end of the output:
Code:
[1106:3122]
This would confirm that.

But another kernel module, viafb, could be used for your chipset, as it has, among others, the same alias line as vt8623 (you can check typing "modinfo viafb", it is the last alias line).

About vt8623fb, the help text in kernel's configuration says:
Quote:
Driver for CastleRock integrated graphics core in the VIA VT8623 [Apollo CLE266] chipset.
And about viafb:
Quote:
This is the frame buffer device driver for Graphics chips of VIA
UniChrome (Pro) Family (CLE266,PM800/CN400,P4M800CE/P4M800Pro/
CN700/VN800,CX700/VX700,P4M890) and Chrome9 Family (K8M890,CN896
/P4M900,VX800)
It happens that your chipset includes both a VT8623 and a CLE266 devices as shows the block diagram on this page. So one would think that both vt8623fb and viafb modules be loaded, but this is not the case as the output of lsmod shows, probably because the kernel can handle only one frame buffer driver at a time.

Long story short, type this as root:
Code:
echo "blacklist vt8623fb" > /etc/modprobe.d/blacklist-vt8623fb.conf
then reboot and start X.

You should have X working now.

In addition, if I am correct it was probably not necessary to use vesa instead of chrome as I suggested in my previous post. To check that you can try to revert the switch in X configuration files after blacklisting vt8623fb. In fact if simply blacklisting vt8623fb don't work you can either try to use the X config file for chrome or blacklist viafb as well as vt8623fb.

Please inform us of the outcome, whatever it be.

PS To clarify a bit you need two kinds of drivers for your video card to use it under X: a kernel driver and a driver for X.

Last edited by Didier Spaier; 10-17-2012 at 04:17 PM.
 
Old 10-17-2012, 04:11 PM   #9
velikij
Member
 
Registered: Oct 2005
Location: Santa Cruz, CA, USA
Distribution: Ubuntu Precise, Xubuntu Precise, Debian 6.0, Slackware 14, others.
Posts: 34

Original Poster
Rep: Reputation: 0
Thank you! I set up blacklisting as you describe, and eventually the Xfce screen came up (meanwhile, I ssh'd in from another computer, ran 'top', and saw that X was taking about 98% of the CPU. It took 2-3 minutes - I left the room and came back. The screen res. was 1024x768.

I'll try with openchrome a bit later this evening. Also I should look at memory usage during startup - perhaps there was some swapping involved.

- Peter Belew
 
Old 10-18-2012, 08:00 PM   #10
velikij
Member
 
Registered: Oct 2005
Location: Santa Cruz, CA, USA
Distribution: Ubuntu Precise, Xubuntu Precise, Debian 6.0, Slackware 14, others.
Posts: 34

Original Poster
Rep: Reputation: 0
Exclamation

Partial status update: I tried reverting to the 'original' xorg.conf, which loads the openchrome and vesa drivers, apparently, and again got a segfault. I have not changed blacklisting yet, however. So I'll try various other changes, including blacklisting, tomorrow or on the weekend.

I'm attaching Xorg.0.log.old from trying openchrome.

The problem is partially solved in the sense that I can use the framebuffer vesa driver, but that starts up REALLY slowly.
Attached Files
File Type: txt Xorg.0.log.old.txt (9.2 KB, 3 views)
 
Old 10-19-2012, 01:01 AM   #11
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,156

Rep: Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012
According to this page your card is well supported by the openchrome X driver.

I would start again from the beginning.

(1) Delete your X config file. None should be needed.
(2) Do not blacklist openchrome. Delete the file /etc/modprobe.d/blacklist-vt8623fb.conf
(3) Reboot
(4) start X

I something don't go well, send your lsmod and X log.

PS I assume you made a full Slackware 14 installation, without anything coming from elsewhere.
 
Old 10-19-2012, 08:56 PM   #12
velikij
Member
 
Registered: Oct 2005
Location: Santa Cruz, CA, USA
Distribution: Ubuntu Precise, Xubuntu Precise, Debian 6.0, Slackware 14, others.
Posts: 34

Original Poster
Rep: Reputation: 0
I removed xorg.conf from /etc/X11, and removed the blacklist file from /etc/modprobe.d, then rebooted, logged in, and ran startx. The same thing happened.

I have not installed anything from outside the slackware 14 distro. I did skip some packages or groups, possibly something was omitted, like some kind of framebuffer driver? For text mode, I'm not using a framebuffer, but I suspect that's unrelated.

I'm attaching the Xorg.0.log and lsmod.txt files.
Also, I'm attaching the same files, and xorg.conf, from the Debian 6.0 system running on another computer with the same VIA hardware, in a following reply.
Attached Files
File Type: txt lsmod.19oct.txt (1.8 KB, 2 views)
File Type: txt Xorg.0.log.txt (8.0 KB, 5 views)
 
Old 10-19-2012, 08:59 PM   #13
velikij
Member
 
Registered: Oct 2005
Location: Santa Cruz, CA, USA
Distribution: Ubuntu Precise, Xubuntu Precise, Debian 6.0, Slackware 14, others.
Posts: 34

Original Poster
Rep: Reputation: 0
Exclamation

Here are the files from Debian 6.0 on similar hardware:
Attached Files
File Type: txt lsmod-debian.txt (3.2 KB, 1 views)
File Type: txt xorg.conf-debian.txt (1.7 KB, 1 views)
File Type: txt Xorg.0.log-debian.txt (39.2 KB, 3 views)
 
Old 10-20-2012, 04:58 AM   #14
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,156

Rep: Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012Reputation: 1012
In Debian's lsmod the "via" kernel module shows, so try to do this :
(1) blacklist again the vt8623fb kernel module
(2) after reboot, type "modprobe via" and check that the via module be loaded
(3) start X

It should work even with no X config file. In case of a problem try the same steps with the xorg.conf-debian as xorg.conf (only because your card do not support a resolution higher than 1024x1024, but xorg-server should be smart enough to detect that, shouldn't it?).

Aside from that your Slackware 14 lsmod shows that a lot less modules are loaded than with Debian - and with my Slackware 14 as well, as shows my attached lsmod file.

So my question is: which kernel do you use? Did you configure it yourself, or may be it is a huge-smp one? In any case install the stock generic-smp included in Slackware 14 instead. You will need to make an initrd , see /boot/README.initrd for instructions.

Last word: with Slackware, making a full install (apart from the KDEI series) is highly recommended, unless you have very few space on your hard disk.
Attached Files
File Type: txt lsmod_slack14.txt (3.8 KB, 2 views)
 
Old 10-20-2012, 10:30 AM   #15
velikij
Member
 
Registered: Oct 2005
Location: Santa Cruz, CA, USA
Distribution: Ubuntu Precise, Xubuntu Precise, Debian 6.0, Slackware 14, others.
Posts: 34

Original Poster
Rep: Reputation: 0
Thanks, I'll try that later today.

This cpu won't run the smp kernels. I'm running the 'huge' kernel, I believe - this works on this via Samuel 2 cpu.

I see you must be using an nvidia card - with the nouveau driver.

Peter
 
  


Reply

Tags
openchrome, xorg.conf


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xorg 1.12.3 with OpenChrome 0.2.906 on VIA VT8623 (CLE266): Seg. fault! kraileth Linux - Hardware 9 11-14-2012 09:11 AM
Xorg -configure SegFaults kauaianspunger Linux - Software 17 12-06-2011 07:45 PM
[SOLVED] xorg segfaults with nvidia driver after upgrade to 13.1 htitan Slackware 4 06-06-2010 02:28 PM
openchrome and xorg dogbird Slackware 27 04-21-2010 11:15 AM
Xorg Problems - Via Chip with OpenChrome - After Update via Synaptic deathawaits Debian 4 09-24-2008 09:31 PM


All times are GMT -5. The time now is 01:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration