LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices

Reply
 
Search this Thread
Old 10-27-2012, 08:36 AM   #1
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,225

Rep: Reputation: 49
VFS: Cannot open root device "801" or unknownblock(8,1).


Hi:

I have two hard disks in my machine. In primary-master, I have slack 12.0 and in primary-slave, slack 14.0, which I have just installed. I allowed the installer to write a lilo.conf through a series of questions he did.

These are the main lines left in lilo.conf:
Code:
boot=/dev/sda
root=/dev/sdb1     # slack 14
The system booted OK. However, I have IDE-ATAPI drives and in slack 12 they have always been called hd (hda, hdb) in my machine. Now I added, in a second image section,
Code:
root=/dev/sda1     # slack 12
First lilo told "the boot sector and the map file are in different disks". Then I commented out one of the image sections, ran lilo, uncommented after, ran agian and this time lilo did not complained. But while booting 14.0 did well, 12.0 when booting said: 'VFS: Cannot open root device "801" or unknownblock(8,1)'. Amy sugggestion?

EDIT: why did 12.0 saw the drives as /dev/hd and 14.0 sees them as /dev/sd? Is some scsi emulation being made?

Last edited by stf92; 10-27-2012 at 08:45 AM.
 
Old 10-27-2012, 09:06 AM   #2
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,485

Rep: Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856
You have jumped from Slackware 12.0 to Slackware 14.0 and hit the libata switchover problem. http://alien.slackbook.org/blog/robb...tchover-howto/

Try changing 'root=/dev/sda1 # slack 12' to 'root=/dev/hda1 # slack 12' in your lilo.conf. You will need to use the lilo version in Slackware 14 to write the changes. The version of lilo in Slackware 12.0 will not handle the increased size of the kernel in Slackware 14.0.
 
Old 10-27-2012, 11:19 AM   #3
stf92
Senior Member
 
Registered: Apr 2007
Location: Buenos Aires.
Distribution: Slackware
Posts: 3,225

Original Poster
Rep: Reputation: 49
I could give you another element of diagnostic: lilo is giving me 'The boot sector and map file are not on the same disks'. I understand the boot sector is the MBR. So, to have the boot sector in, e.g. /dev/sda is to have 'boot=/dev/sda' in lilo.conf, I think. And the location of the map file can be given lilo by means of 'map=/mnt/boot', though I don't know if I must give the path or the full path (/mnt/boot or /mnt/boot/map).

I'll try to add these modifications too, allend.

Another question, a bit off-topic I have for you: can the misuse of the map= option destroy data in one of the disks, I mean personal data such as an electronic book for example?

EDIT: I can't make lilo stop notifying 'The boot sector and map file are in different disks'. I've tried to put it in the global section and in the per-image section of the affected partition but uselessly. Is this file created by lilo. But he needs the old /boot/map, does he?

Last edited by stf92; 10-27-2012 at 11:36 AM.
 
Old 10-27-2012, 08:48 PM   #4
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,485

Rep: Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856Reputation: 856
My method for dealing with partitions is to create subdirectories in /boot and place copies of the relevant kernel and initrd in the subdirectories.

My system was initially set up with a Slackware 32 bit install. To boot my Slackware 64 bit install I have a subdirectory /boot/Slackware64/ which contains 'vmlinuz-generic-3.2.29' and 'initrd.gz'
My /etc/lilo.conf has
Code:
image = /boot/Slackware64/vmlinuz-generic-3.2.29
initrd = /boot/Slackware64/initrd.gz
label = Slackware64
root = /dev/sda11
When I am in my Slackware 64 bit install I have my Slackware 32 bit install mounted on /Slackware32. I can edit /Slackware32/etc/lilo.conf and then I use 'lilo -r /Slackware32' to rerun lilo. Note that you need the partition with the lilo.conf to be used to be mounted for the -r option to lilo to work.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VFS: Cannot open root device "(null)" or unknow-block(8,1) persson121 Linux - General 2 04-17-2011 06:33 AM
VFS: Cannot open root device "<NULL>" or unknown-block(8.22) aleksanteri Linux From Scratch 1 10-30-2007 05:02 AM
2.6.19: VFS: Cannot Open root device "sda1" or unknown-block(0,0) havok1977 Linux - Kernel 18 05-03-2007 05:25 PM
VFS: Cannot open root device "801" Nille_kungen Slackware 1 12-18-2005 08:36 PM
VFS: Cannot open root device "1601" or unknown-block(22,1) takehora Slackware 3 06-11-2004 09:34 PM


All times are GMT -5. The time now is 06:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration