LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware - Installation (http://www.linuxquestions.org/questions/slackware-installation-40/)
-   -   startx asks for libpam.so.0 (http://www.linuxquestions.org/questions/slackware-installation-40/startx-asks-for-libpam-so-0-a-193697/)

emme259 06-15-2004 05:37 AM

startx asks for libpam.so.0
 
It's the first time I install slackware,
after having completed the installation without error or warning I've logged in as root and tried the startx to run the gui (it should bring up KDE), but the command fails with a message wich indicates that some process cannot find the library libpam.so.0

As far as I've understood this library is used to manage the autentication in almost all the distro with the exception of slackware.

The most straigtforward solution would be to try and download the library from the net, but I've understood that there should be no need of it in slackware.

So the question is what's wrong with my installation?


Ciao,
M.

320mb 06-15-2004 06:46 PM

http://slackpacks.tchelinux.com.br/pam/Latest-9.0/

might help, maybe............

emme259 06-17-2004 08:16 AM

Thanks for the really usefull link!

I've downloaded and installed PAM and now I can launch xfree86.
when I try startx it fails the following message:

Authentication failed - cannot start x server
Perhaps you do not have console ownership

Really strange since I'm running the command as root. There must be something wrong in the PAM configuration.


All times are GMT -5. The time now is 05:59 AM.