LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware - Installation (http://www.linuxquestions.org/questions/slackware-installation-40/)
-   -   Speakup on 13.37 and 14.0 No Go (http://www.linuxquestions.org/questions/slackware-installation-40/speakup-on-13-37-and-14-0-no-go-4175457811/)

SlackmanNKC 04-11-2013 12:59 PM

Speakup on 13.37 and 14.0 No Go
 
Hello,
I am a long-time Slackware user, and I am also blind. Trying to install a newer version of Slack--again. Unfortunately, I haven't been able to get the install DVD (32 bit edition) to come up talking. I have a DEC Talk express external synthesizer that has worked fine on numerous earlier versions of Slackware dating back to 7.0, but I have never been able to get this to work on either 13.37 or 14.0. Using the following line upon booting from DVDs
speakup.s speakup.synth=dectlk speakup.ser=1
I have tried with and without the serial port specification. This is the only external synthesizer I have, so haven't been able to test to see if this is a DEC issue. Also, there is only one serial port on this mainboard, but I am certain it and the synth are functional: they work fine with 13.0. 13.1 also works, but am unable to change any synthesizer parameter in 13.1.

The Speakup web site appears abandoned, and E-mails sent to their mailing list to subscribe are returned undeliverable.

frankiej 04-12-2013 08:05 AM

I saw a README.TXT in the kernels/speakup.s directory of 13.37 and 14.0. It looks like Pat put the speakup functionality in the hugesmp.s kernel now so a separate speakup.s kernel is unnecessary. Try just using the default hugesmp.s kernel (or huge.s) with your other parameters.

SlackmanNKC 04-12-2013 09:02 AM

Terrific idea. I will give that a shot.

I can tell something has happened with the serial port when I tried the speakup.s kernel. The next time the system starts up the synthesizer speaks garbage for a second or two before the Slackware bootup messages start.

I would really like to get this working. I have these new 3Tb drives that don't seem fully supported in 13.0. Otherwise, I was quite happy with the existing install.

SlackmanNKC 04-14-2013 11:56 AM

Quote:

Originally Posted by frankiej (Post 4930319)
I saw a README.TXT in the kernels/speakup.s directory of 13.37 and 14.0. It looks like Pat put the speakup functionality in the hugesmp.s kernel now so a separate speakup.s kernel is unnecessary. Try just using the default hugesmp.s kernel (or huge.s) with your other parameters.

It was a great idea, but it didn't work. Tried both, and with the same result -- nothing. As before, tried with and without the speakup.ser=1 parameter.


All times are GMT -5. The time now is 03:49 PM.