Register a domain and help support LQ
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Slackware - Installation This forum is for the discussion of installation issues with Slackware.


  Search this Thread
Old 02-01-2004, 05:34 PM   #1
LQ Newbie
Registered: Feb 2004
Posts: 1

Rep: Reputation: 0
Sound doesnot work

I am new to slackware. I have installed slackware 9.1 but am not able to get the sound to work. I have creative SB Live! sound card and have configured it using alsaconf. I have changed the volumes for all possible options in alsamixer with no avail.

I tried using xmms, mpg321, as root and as well as normal user but I don't get any sound (no error either except if I use ctrl-z with mpg321 some times I see alsa_write error.) . I did lsmod to check if the sound module was loaded and I found that emu10k1 was loaded along with hundread other sound modules like snd, soundcore etc.

I have another onboard sound card, which I have disabled on my BIOS but alsaconf does pick it up. I have not configured it but does some one think that it might also create the problem?

Thanx for any help you can provide,
Old 02-01-2004, 07:46 PM   #2
Registered: Jan 2004
Location: Poland
Distribution: FreeBSD 5.1
Posts: 92

Rep: Reputation: 15
1. Remove all AC97 modules (put their names in /etc/hotplug/blacklist ) and onboard sound card modules, for example:

You can find the whole list by typing lsmod

2. Type alsaconf and configure your right sound card
3. Type alsamixer -c your_card_id (i supose it's 1 or 2) and unmute all channels except SB Live Analog/Digital Output Jack (if you are using SB Live card)
4. Reboot your pc to reload modules
5. If it still doesnt work, try to change modules rights (as root) :
chmod 777 /dev/dsp*
chmod 777 /dev/mixer*

and also:

amixer set Master unmute
amixer set PCM unmute

Switch your audio output, it can be ALSA or OSS (for example for mp3's)
It should work.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 2 doesnot detect Realtex AC'97 sound card/codecs mhbengal Linux - Software 5 05-25-2004 05:12 AM
Fedora Core 2 doesnot detect Realtex AC'97 sound card/codecs mhbengal Linux - Hardware 1 05-24-2004 11:57 PM
Fedora Core 2 doesnot detect Realtex AC'97 sound card/codecs mhbengal Linux - Wireless Networking 2 05-23-2004 11:24 PM
modem ADSL from sapo (Portugal) doesnot work in Suse9.0 lepton Linux - Distributions 0 11-16-2003 01:54 PM
RHN9 - Gnome crash, KDE doesnot work vijlovely Linux - Newbie 2 07-13-2003 08:03 AM

All times are GMT -5. The time now is 06:58 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration