LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices

Reply
 
Search this Thread
Old 04-14-2014, 03:22 PM   #1
julian516
LQ Newbie
 
Registered: Apr 2011
Location: Loveland, CO
Distribution: Debian, LMDE,Xubuntu, Slackware
Posts: 6

Rep: Reputation: Disabled
(solved) Slackware64-14.1 ALSA Configuration?


I decided to investigate Slackware and I thought I was getting along quite well with Slackware64-Xfce until I realized I heard not a sound. Oops, not good. So I have been trying for several days to first diagnose and then repair my problem. No luck thus far. What I hve larned is that I do not understand how to configure ALSA in Slackware.

Various documents on the web suggest using the “ALSA configurator” (alsaconf) to configure ALSA. Apparently that set of tools no longer is packaged with ALSA?

Question: Is there some functional substitute?

If I select ALSA-mixer (alsamixer) it shows me 3 unmuted S/PDIF devices. These evidently relate to the circuits on my System76 laptop labeled as HDA Intel MID which shows priority 0 on the device list.

If I use F6 I can select HDA Intel PCH with priority 1. If I select this I see the ALSA mixer sliders I am accustomed to seeing. The master slider is muted by default. I have learned how to unmute it and save that configuration so that the ALSA mixer is not muted when it comes up. I still hear no sounds of any sort. So that alone does not solve my problem.

Question: Am I correct that I need to set HDA Intel PCH as priority 0 and HDA Intel MID as priority 1 in order to solve my problem? I have no idea how to do that. Can anyone direct me to a document that explains how to do it?

Is there some other way to solve this problem that I have missed?

Thank you for reading this post.

Last edited by julian516; 04-16-2014 at 06:32 PM.
 
Old 04-14-2014, 05:54 PM   #2
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,633
Blog Entries: 3

Rep: Reputation: 221Reputation: 221Reputation: 221
Yes there really is with a little more info.
lets start here http://www.linuxquestions.org/questi...-a-4175497740/

here is another http://www.linuxquestions.org/questi...ce-4175497387/

Last edited by Drakeo; 04-14-2014 at 05:55 PM.
 
Old 04-14-2014, 05:57 PM   #3
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,633
Blog Entries: 3

Rep: Reputation: 221Reputation: 221Reputation: 221
you will see aplay -l will give you the read out that will show you your default card down.
Quote:
ash-4.2$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: VT2020 Analog [VT2020 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: VT2020 Digital [VT2020 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 2: VT2020 Alt Analog [VT2020 Alt Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 3: Headset [HP Digital Stereo Headset], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
this is mine.
but for some reason Slackware liked to put my webcam first or my nvidia hdmi so to fix this problem I did this. I created a /etc/modprobe.d/sound.conf
looked like this.
Quote:
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF version 1.0.25 ---
alias char-major-116 snd
alias char-major-14 soundcore
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd slots=snd-hda-intel,snd-usb-audio
then from http://docs.slackware.com/howtos:har..._snd-hda-intel
you will read how to load the proper module. If the kernel is having issues.

pat named it the /etc/modprobe.d/snd-hda-intel.conf

Quote:
Diagnosing the issue

Execute the command

lsmod | grep snd

in a terminal window. If there is a reference to snd_hda_intel in the output then the snd-hda-intel kernel module has been loaded as the driver for the controller chip and the codec chips on the HD-audio bus.
The fix

The snd-hda-intel kernel module tries to autodetect and configure your sound hardware, but this is not always successful. Some further configuration may help.

Often the fix is simple. Just create a file in the /etc/modprobe.d/ directory and provide suitable options to the snd-hda-intel kernel module. The actual file name is not important although it must have a .conf suffix. You could use snd-hda-intel.conf. Names used by other distributions to hold this information include sound.conf and alsa-base.conf.

A simple way is to execute (as root)

echo "options snd-hda-intel model=auto" > /etc/modprobe.d/snd-hda-intel.conf

If you use an editor to create files in /etc/modprobe.d/ be sure to remove any backup copies.

Last edited by Drakeo; 04-14-2014 at 06:09 PM.
 
Old 04-15-2014, 01:02 AM   #4
padeen
Member
 
Registered: Sep 2009
Location: Perth, W.A.
Distribution: Slackware 14, Debian 7, FreeBSD, OpenBSD
Posts: 179

Rep: Reputation: 35
Just in case Drakeo's post isn't clear to you, you may find that the problem is a missing module that needs to be loaded with modprobe as root.
 
1 members found this post helpful.
Old 04-15-2014, 12:58 PM   #5
ifo
LQ Newbie
 
Registered: Dec 2010
Location: Munich, Germany
Distribution: Slackware64 14.1
Posts: 3

Rep: Reputation: 0
IMHO the easiest solution is to tell which modules you don't want to have as your main sound card. This can also be seen as the reverse configuration of Drakeo.

Example for my setup:

Code:
> cat /etc/modprobe.d/alsa.conf
options snd slots=,cx88_alsa,snd_hda_codec_nvhdmi
This will prefer every other soundcard before using my TV card and my HDMI output. You will just have to replace those with your unwanted driver - as in Drakeo's description lsmod | grep ^snd_pcm should give you the relevant module names. If you want to use it as a reverse list then just don't forget the leading comma after the equals sign. That one line should be everything you need.

Last edited by ifo; 04-15-2014 at 01:01 PM.
 
Old 04-15-2014, 04:25 PM   #6
julian516
LQ Newbie
 
Registered: Apr 2011
Location: Loveland, CO
Distribution: Debian, LMDE,Xubuntu, Slackware
Posts: 6

Original Poster
Rep: Reputation: Disabled
Thank you all! This is what I needed to get some traction on this problem. I will report back hoping we can mark this thread as "solved" when I do so.
 
Old 04-16-2014, 06:31 PM   #7
julian516
LQ Newbie
 
Registered: Apr 2011
Location: Loveland, CO
Distribution: Debian, LMDE,Xubuntu, Slackware
Posts: 6

Original Poster
Rep: Reputation: Disabled
We have a solution thanks to the several people who posted and the HowTos on SlackDocs. Let me report the next steps in my successful search for sound with Slackware64-14.1. Doing so might help someone else.

Drakeo was right. I had missed some relevant documents. Slackdocs/HowTo articles-Hardware contains "Audio and snd-hda-intel"and also "Sound Problems on Slackware." These two documents held the keys to this problem. So here is what I did.

Q. What does aplay -l show?

**** List of PLAYBACK Hardware Devices ****
card 0: MID [HDA Intel MID], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: MID [HDA Intel MID], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: MID [HDA Intel MID], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: VT1802 Analog [VT1802 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 2: VT1802 Alt Analog [VT1802 Alt Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

What I noticed was that the HDMI devices were listed as card 0 while the VT1802 was listed as card 1.

Q. What does lsmod | grep snd show?

snd_hda_codec_via 19806 1
snd_hda_codec_hdmi 29622 1
snd_hda_intel 34861 4
snd_hda_codec 143196 3 snd_hda_codec_hdmi,snd_hda_codec_via,snd_hda_intel

snd_hwdep 6388 1 snd_hda_codec
snd_pcm 76009 3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel

snd_page_alloc 7098 2 snd_pcm,snd_hda_intel
snd_timer 18614 1 snd_pcm
snd 58630 15 snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_via,snd_pcm,snd_hda_codec,snd_hda_intel
soundcore 5354 1 snd

I understood that snd_hda_intel showed the proper module being loaded.

Q. What did alsamixer show?

It showed three S/PDIF devices as 0 HDA Intel MID. Using F6 I went to “1 HDA Intel PCH”. This showed the ALSA mixer controls I would expect to see. The Master was not muted.

Q. What was the solution path?

According to "Sound Problems on Slackware" I should be able to test this card by specifying the card to test as follows: "aplay -D plughw:1,0 test.wav" This returned "No such file or directory." So where was test.wav? This set off a rather long search.

In /usr/share/sounds/alsa/ I did not see test.wav but I did see Noise.wav, so I tried that. "aplay -D plughw:1,0 Noise.wav" returned the same “No such file ..." So I next tried this with the full path to Noise.wav doing "aplay -D plughw:1,0 /usr/share/sounds/alsa/Noise.wav"

This worked! OK, now I knew that the card at 1,0 could make noise. It looked to me that the remaining task was to make it the default card.

So I followed Drakeo and went back to the "Audio and snd-hda-intel" document I had missed initially. I then did

echo "options snd-hda-intel model=auto" > /etc/modprobe.d/snd-hda-intel.conf

A check of modprobe.d showed the file in place. I then rebooted the system.

No joy; alsamixer still reported the HDMI ports as Card 0 and the Intel PCH card as card 1. This was confirmed by aplay -l. If I did cat /etc/modprobe.d/snd-hda-intel.conf it read back “options snd-hda-intel model=auto” as I thought it would.

I then reviewed the several posts on this thread as well as the two HowTos in SlackDocs mentioned earlier. I elected to follow the suggestions in "Sound Problems on Slackware" to create /etc/asound.conf as shown in that document, since card 1, device 0 was also my working alsa card. This seemed to me the simplest approach. With that done I then rebooted hoping to see a change in the default order of preferred sound-cards.

Interesting: There was no apparent change in the order of the cards but asound.conf must route the sound to the proper card because my speakers now work just as they should!

There is one small thing I do not understand but doubtless more experienced Linux folks do. I can no longer start alsa mixer at the cli by simply typing “alsamixer”. Instead I must now specify the card, “alsamixer -c1” If I do that I can control alsamixer from the cli.

I started the Xfce desktop and clicked on the mixer app. Everything worked as it should.

So my problem is solved with my thanks to all who contributed. I learned a lot starting with the fact that the first place to look is SlackDocs!

You know I think Slackware is a keeper and that means I really ought to purchase something from the Slackware store.
 
2 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware64 - 14.0 and Cakephp URL Rewriting Configuration Manuel-H Slackware 4 07-29-2013 08:47 PM
How to get ALSA 1.0.25 on Slackware64 13.37? blue_k Slackware 5 06-28-2012 10:55 PM
[SOLVED] alsa problem on slackware64 machine with nvidia gt430 lpallard Linux - Software 2 02-22-2011 06:18 PM
NO Sound : Slackware64 13.0; Alsa 1.0.18; Audigy 2 (SB0240); NO X-server WetFroggy Slackware 6 09-09-2009 12:10 PM
So, I've installed Slackware64-current. Need some configuration help. glore2002 Slackware 19 08-24-2009 06:24 PM


All times are GMT -5. The time now is 11:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration