LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware - Installation (http://www.linuxquestions.org/questions/slackware-installation-40/)
-   -   small question about lilo (http://www.linuxquestions.org/questions/slackware-installation-40/small-question-about-lilo-640173/)

dissociative 05-05-2008 09:45 PM

small question about lilo
 
what happens is that I had an old slackware installation and now I installed slackware 12.1 in a separate partition, configured lilo and added the both partitions to lilo bootloader, now everytime that I am going to boot the old Slackware installation entry in lilo, it boots but using the kernel of slackware 12.1, the same thing happened me before with older version of slackware, is there a way to both the old install with the correct kernel or I have to use GRUB instead?

I'm using only one harddisk drive and lilo was installed to the MBR with the /etc/lilo.conf file of the Slackware 12.1 install

/dev/sda1 is the old slackware install and /dev/sda5 is slackware 12.1

Code:

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/sda
#compact        # faster, but won't work on all systems.
# Boot BMP Image.
# Bitmap in BMP format: 640x480x8
  bitmap = /boot/slack.bmp
# Menu colors (foreground, background, shadow, highlighted
# foreground, highlighted background, highlighted shadow):
  bmp-colors = 255,0,255,0,255,0
# Location of the option table: location x, location y, number of
# columns, lines per column (max 15), "spill" (this is how many
# entries must be in the first column before the next begins to
# be used.  We don't specify it here, as there's just one column.
  bmp-table = 60,6,1,16
# Timer location x, timer location y, foreground color,
# background color, shadow color.
  bmp-timer = 65,27,0,255
# Standard menu.
# Or, you can comment out the bitmap menu above and
# use a boot message with the standard menu:
#message = /boot/boot_message.txt

# Append any additional kernel parameters:
append=" vt.default_utf8=0"
prompt
timeout = 300
# VESA framebuffer console @ 640x480x256
vga = 0x0F01
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# ramdisk = 0    # paranoia setting
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda1
  label = Slackware
  read-only  # Partitions should be mounted read-only for checking
# Linux bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda5
  label = Slackware12.1
  read-only  # Partitions should be mounted read-only for checking
# Linux bootable partition config ends
# Windows bootable partition config begins
other = /dev/sda3
  label = WindowsXP
  table = /dev/sda
# Windows bootable partition config ends


wheelsg 05-05-2008 11:04 PM

Make sure the entries in lilo.conf point to distinct kernels, and that there are system maps for each. (You might include your lilo.conf in your post, so's we can have an idea of what you're dealing with.)

Bruce Hill 05-07-2008 07:36 AM

The problem is that both kernel labels are pointing to the same kernel,
which is /boot/vmlinuz. You need separate kernel images for each system
you want to boot.

Road_map 05-09-2008 06:01 AM

This works for me, but I don't know if this is the standard solution:
1. Mount your old Slackware partition on Slackware 12.1 (my mount point is /mnt/slack);
2. Make a new folder in /boot (on sda5), where you'll copy your old /boot/*.* files from sda1 (in my case to /boot/oldslack):
Code:

cp /mnt/slack/boot/*.* /boot/oldslack
3. Edit your /etc/lilo.conf file:
Code:


# Linux bootable partition config begins
image = /boot/oldslack/vmlinuz
  root = /dev/sda1
  label = Slackware
  read-only  # Partitions should be mounted read-only for checking
# Linux bootable partition config ends

4. Run lilo and if no errors, then you'll be able to boot from both partitions.

dissociative 05-11-2008 01:20 AM

I solved the problem, first I mounted the partition of Slackware 12.1 from the older slackware installation in /mnt/hd and then edited /etc/lilo.conf adding the boot entry to point to the kernel of the Slackware 12.1 partition this way

image = /mnt/hd/boot/vmlinuz
root = /dev/sda5
label = Slackware
read-only

and now lilo boots Slackware 12.1 with the right kernel


All times are GMT -5. The time now is 02:19 AM.