LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices

Reply
 
Search this Thread
Old 11-16-2013, 02:54 PM   #1
Exaga
LQ Newbie
 
Registered: Nov 2012
Distribution: Slackware Linux
Posts: 11

Rep: Reputation: Disabled
Slackware ARM 14.1 on a Raspberry Pi


Hi Slackers <3

At FatDog.eu we have recently updated our Slackware ARM installer image (16 November 2013), which includes the latest current firmware files alongside Dave Spencerīs original installer. Weīve been reading reports lately that the newest version of the Raspberry Pi does not boot when using our old installer image (01 April 2013) so hopefully this new image will solve that particular issue.

The new installer has been thoroughly tested on Raspberry Pi model B versions (made in UK & China) with Slackware ARM 14.1 as the operating system. Everything seems to be working perfectly.

All comments, feedback and advice is more than welcome, as always.

http://rpi.fatdog.eu

Many thanks,

Last edited by Exaga; 11-17-2013 at 06:24 AM.
 
Old 11-17-2013, 07:11 AM   #2
Penthux
Member
 
Registered: Dec 2008
Location: Middlesbrough, UK
Distribution: Slackware
Posts: 37

Rep: Reputation: 13
Quote:
Originally Posted by Exaga View Post
All comments, feedback and advice is more than welcome, as always.
Installed slackwarearm-14.1 this morning using the new image from Fatdog.eu and it was flawless. Also followed the chronodot rtc guide and that went perfectly as well. The rtc is working as expected but when I type the 'i2cdetect -y 1' command it doesn't display '68' in the output, it displays 'UU'. Any reason for this and does it affect anything?

Cheers :P
 
Old 11-17-2013, 08:11 AM   #3
Exaga
LQ Newbie
 
Registered: Nov 2012
Distribution: Slackware Linux
Posts: 11

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Penthux View Post
The rtc is working as expected but when I type the 'i2cdetect -y 1' command it doesn't display '68' in the output, it displays 'UU'. Any reason for this and does it affect anything?
Didnīt we just have this conversation?

The UU just means the driver for the ChronoDot RTC is using the i2c 0x68 address. If you unload the driver module 68 will be displayed instead of UU. Basically, UU indicates that this address cannot be probed because it is currently in use by a software driver (the rtc-ds1307 module in your case).

Try this...

root@myrasbox:~# rmmod rtc-ds1307
* You have just removed the driver for your ChronoDot RTC *
root@myrasbox:~# i2cdetect -y 1
* The output should display 68 *
root@myrasbox:~# modprobe rtc-ds1307
root@myrasbox:~# i2cdetect -y 1

* The RTC driver has been reloaded and the output should now display UU *


Last edited by Exaga; 11-17-2013 at 08:20 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] ARM Slackware Raspberry Pi - CPU clock carlitoco Slackware 2 07-31-2013 05:44 AM
Installing Slackware ARM on a Raspberry Pi Penthux Slackware - Installation 20 03-24-2013 01:59 PM
LXer: HOWTO: Rebuild Glibc on Slackware ARM 14.0 for the Raspberry Pi LXer Syndicated Linux News 0 11-20-2012 09:42 PM


All times are GMT -5. The time now is 02:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration