LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices

Reply
 
Search this Thread
Old 10-27-2012, 10:13 AM   #1
waynelloydsmith
LQ Newbie
 
Registered: Feb 2012
Location: Canada
Distribution: Slackware 14.1
Posts: 6

Rep: Reputation: Disabled
Slackware 14.0 and ulimits and /sbin/initscript


I've been running Slackware since Windows Vista was released and am very happy with it. This is my first post here but I visit frequently and have found many answers to my problems here. Thanks.
I have just upgraded from Slackware 13.27 to 14.0 and have been cleaning up odds and ends post install as usual.
I was unable to get my /sbin/initscript to run to increase my limits as I had them setup in 13.27
After some digging I typed in "man initscript" and discovered the the initscript file location has been moved to /etc from /sbin.
I relocated my initscript to /etc and now the initscript is running as expected.
The /sbin directory still contains the initscript.sample which should really be in /etc according to the man initscript.
I'm wondering if this is expected behavior or did I install something incorrectly?
 
Old 10-27-2012, 01:10 PM   #2
malekmustaq
Senior Member
 
Registered: Dec 2008
Location: /root
Distribution: Slackware & BSD
Posts: 1,206

Rep: Reputation: 229Reputation: 229Reputation: 229
Hi, welcome to LQ!

Slackware 13.37 uses kernel version 2.6.37.6 while version 14.0 uses kernel version 3.2.29.

It appears the best solution is to fresh install Slackware 14 due to its major release of kernel. This if loss of data is not incurred.

Hope that helps.

Goodluck.
 
Old 10-29-2012, 07:12 AM   #3
GazL
Senior Member
 
Registered: May 2008
Posts: 3,312

Rep: Reputation: Disabled
Quote:
Originally Posted by waynelloydsmith View Post
I'm wondering if this is expected behavior or did I install something incorrectly?
Nah, not your fault. it's just a mistake in packaging. My guess is that at some point upstream changed the location of the file and Pat didn't notice and so didn't change the location that the slackbuild script puts the sample. Personally, I think that sample belongs in /usr/doc/sysvinit rather than either /sbin or /etc anyway, but that's just me.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian and ulimits circus78 Linux - Server 1 02-28-2012 09:32 AM
Setting ulimits rnash AIX 2 08-23-2010 02:22 AM
Suse10.2 : /etc/initscript : line 106 : /sbin/mingetty Input/Output error on reboot chelsea Suse/Novell 5 05-24-2008 01:17 PM
File Descriptors and Ulimits ALInux Linux - Software 1 07-25-2007 06:46 AM
Initscript shahrokhnikou Linux - General 3 10-24-2005 07:40 AM


All times are GMT -5. The time now is 12:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration