LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices

Reply
 
Search this Thread
Old 01-19-2010, 01:11 PM   #1
jaspreetwilly
LQ Newbie
 
Registered: Jan 2010
Posts: 2

Rep: Reputation: 0
Slackware 13.0 CD/DVD rom error, Windows 7 Dual boot.


I have encountered a strange problem, I earlier had Slackware 12.2 & Vista installed successfully. Recently I moved to Windows 7 and tried loading with Slackware 13.0.

I Install Windows 7 first and then Slackware as installing LILO on MBR automatically detects windows and boots respectively. But as I boot my laptop from Slackware bootable DVD it does get boot but setup dont recognoze any CD/DVD rom after booting till Setup. checked "mount" nothing found, Tried mannualy by selecting all different custom options available but no luck. (under dev). even tried changing and Hard Disk partition as well.

As a workaround I copied Slackware files under folder in Windows Partition and installed slackware via windows partition. The problems then were network card config gave an error "cannot parse XML file" and Lilo doesn't boots windows it struck till the point it says windows loading and cursor blinks.

Note: I tried installing other distros Opensuse11.2 & Ubuntu 9.10, installed successfully no prob with CDrom/Network card and windows Dual boot as well. I have tried installing slackware 12.2 but same prob.which worked earlier with Vista.

I am Now working from Ubuntu Live CD.

Here is Fdisk output.

Disk /dev/sda: 78.5 GB, 78518522880 bytes
255 heads, 63 sectors/track, 9546 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xd0f4738c

Device Boot Start End Blocks Id System
/dev/sda1 1 365 2931831 82 Linux swap / Solaris
/dev/sda2 * 366 2189 14651280 83 Linux

Disk /dev/sdb: 1000.2 GB, 1000204884992 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x97107191

Thanks in advance..
 
Old 01-20-2010, 07:20 PM   #2
bobbygr100
LQ Newbie
 
Registered: Jan 2007
Posts: 11

Rep: Reputation: 0
Try using Acronis Disk Director Suite to manage your dual boot. It has an awesome boot manager (the only third party product I know of that supports windows 7). You have all kinds of options, like when you boot - hiding any other partitions you don't want to be seen at startup (yes I know you can do this in the config file for linux by editing fstab, but this is really slick, it's all done on your boot menu).

I have win xp, vista, win7 and Manriva Linux all booting off the same machine. I can add 100 operating systems if I had the disk space!!

Give it a try, and see if you get this resolved.


Bob
 
Old 01-24-2010, 10:39 AM   #3
jaspreetwilly
LQ Newbie
 
Registered: Jan 2010
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks bobbygr100 for reply. But infact tried acronis, its not compatible with Windows 7. may be I tried old version no Idea, but in my case it didn't worked on Windows 7.

But the problem has been resolved, I will update post for my fellows to take benefit.

To me problem seems to be with the Hard Disk Partition as if you install Windows 7 first, it will create one hidden systems partition of around 100mb and that creates problem I thing LILO tries to boot through that partition. I really loved the partition magic utility as that was the only utility that could create linux partitions easily. you can manipulate by resizing and there is no data loss too. but infact that dont work on windows 7, I tried with Windows 7 backward compatibility mode. But no Luck. So what next has to be Partition Magic.

So I installed windows Xp from bootable Drive, Installed Partition magic onto it and created all partitions as desired and this time as partitions were already in place windows 7 didn't created new one and was installed successfully.

Then I installed Slackware (mind it CD/DVD didn't worked I had to copy Slackware image to windows partition and install it, it gave some input/ouput error, trying to access sector out something tried resolving no luck.) and after LILO on MBR. It booted Windows 7 as well..

Finally both worked...

Last edited by jaspreetwilly; 01-24-2010 at 10:40 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 11 + Linux 2.6.17.13-smp + Benq DVD-ROM = Can't read dvd johndlagart Linux - Hardware 2 06-22-2007 01:37 AM
Dual boot windows/slackware, but slackware installed first? Cryptic_K Slackware 3 11-20-2006 12:49 PM
Can Slackware dual boot with windows XP? TigerLinux Slackware 14 10-03-2005 06:27 PM
DVD-ROM/CD-ROM unable to recognize debain boot CD gottfried Linux - Newbie 2 01-20-2004 12:39 PM


All times are GMT -5. The time now is 05:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration