LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices



Reply
 
Search this Thread
Old 12-12-2008, 11:11 AM   #1
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad W520
Posts: 4,676

Rep: Reputation: 1237Reputation: 1237Reputation: 1237Reputation: 1237Reputation: 1237Reputation: 1237Reputation: 1237Reputation: 1237Reputation: 1237
Slackware 12.2 not starting with an initrd


Hello everybody,

I wanted to give a try to this shiny new release on my laptop...

I installed it with the huge kernel. So far, so good.

Then I tried to use the generic-smp-2.6.27.7-smp kernel, with an initrd (because we are on a reiserfs file system).

While booting, at a point of time I get these messages:

Code:
Using /lib/modules/2.6.27.7-smp/kernel/fs/reiserfs/reiserfs.ko
mount: mounting /dev/root on /mnt failed: No such file or directory
ERROR: No /sbin/init found on rootdev (or not mounted). Trouble ahead.
       You can try to fix it. Type 'exit' when things are done
/bin/sh: can't acces tty; job control turned off
/$
Tried a little googling ; somebody had a similar problem with -current but I could not find the answers (the message was only in Google cache):
http://209.85.129.132/search?q=cache...ient=firefox-a

Yes modules for 2.6.27.7-smp are installed in /lib/modules (otherwise I couldn't have made the initrd, anyway).

Last edited by Didier Spaier; 12-12-2008 at 12:29 PM.
 
Old 12-12-2008, 12:22 PM   #2
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,525

Rep: Reputation: 94
Probably you forgot to include the modules for your IDE or SATA driver in the initrd image.

Boot from cd, follow the at the boot prompt given line to use the huge kernel and your root partition so that you can boot into your fresh and shiny Slackware installation
Then login and use the script from Eric: http://www.slackware.com/~alien/tool...d_generator.sh to see which modules are missing. Then just create a new initrd.gz.

Last edited by titopoquito; 12-12-2008 at 12:23 PM.
 
Old 12-12-2008, 12:53 PM   #3
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad W520
Posts: 4,676

Original Poster
Rep: Reputation: 1237Reputation: 1237Reputation: 1237Reputation: 1237Reputation: 1237Reputation: 1237Reputation: 1237Reputation: 1237Reputation: 1237
Problem solved

Thanks titopoquito.

Anyway I solved my problem this way (after reading mkinitrd and mkinitd.conf manual pages) :

cp /etc/initrd.conf.sample /etc/mkinitrd.conf
nano /etc/mkinitrd.conf

My mkinitrd.conf look like this after editing (edited lines only):

SOURCE_TREE="/boot/initrd-tree"
CLEAR_TREE="1"
OUTPUT_IMAGE="/boot/initrd.gz"
KERNEL_VERSION="2.6.27.7-smp"
KEYMAP="fr"
MODULE_LIST="reiserfs"
LUKSDEV="/dev/hda1"
ROOTDEV="/dev/hda1"
ROOTFS="reiserfs"

Then:

mkinitrd -F

and of course:

lilo

did the trick.

I can be wrong but I guess giving the parameters as indicated in this example from README.initrd:
mkinitrd -c -k 2.6.24.5-smp -m reiserfs

is no more enough, I don't know why.

FYI I first issued following command:
mkinitrd -c -k 2.6.27.7-smp -m reiserfs

and got the result shown in my first message.

Last edited by Didier Spaier; 12-12-2008 at 12:57 PM. Reason: typo
 
Old 12-15-2008, 03:56 PM   #4
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 64bit
Posts: 735
Blog Entries: 3

Rep: Reputation: 81
Another person got the same issue and it was solved by using the mkinitrd with "full options".

http://www.linuxquestions.org/questi...55#post3373155

This is the second example mentioned at end of paragraph 3 in file README.initrd
 
Old 12-20-2008, 02:44 PM   #5
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 227Reputation: 227Reputation: 227
Just in case anyone doesn't know there has been an updated package issued here in the patches directory for Slackware 12.2. I recommend installing this.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 12 initrd issue nc3b Slackware 15 04-17-2008 10:05 PM
slackware 11.0 and initrd mscole Slackware 4 10-13-2006 07:44 AM
Kernel Panic (no initrd) after Slackware 10.1 Install kinadian Slackware 3 08-14-2006 08:37 PM
slackware 10.2, kernel 2.6.16, and initrd alphisb0t Slackware 3 03-22-2006 02:58 PM


All times are GMT -5. The time now is 04:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration