LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware - Installation (http://www.linuxquestions.org/questions/slackware-installation-40/)
-   -   Slackware 12.2 not starting with an initrd (http://www.linuxquestions.org/questions/slackware-installation-40/slackware-12-2-not-starting-with-an-initrd-690110/)

Didier Spaier 12-12-2008 10:11 AM

Slackware 12.2 not starting with an initrd
 
Hello everybody,

I wanted to give a try to this shiny new release on my laptop...

I installed it with the huge kernel. So far, so good.

Then I tried to use the generic-smp-2.6.27.7-smp kernel, with an initrd (because we are on a reiserfs file system).

While booting, at a point of time I get these messages:

Code:

Using /lib/modules/2.6.27.7-smp/kernel/fs/reiserfs/reiserfs.ko
mount: mounting /dev/root on /mnt failed: No such file or directory
ERROR: No /sbin/init found on rootdev (or not mounted). Trouble ahead.
      You can try to fix it. Type 'exit' when things are done
/bin/sh: can't acces tty; job control turned off
/$

Tried a little googling ; somebody had a similar problem with -current but I could not find the answers (the message was only in Google cache):
http://209.85.129.132/search?q=cache...ient=firefox-a

Yes modules for 2.6.27.7-smp are installed in /lib/modules (otherwise I couldn't have made the initrd, anyway).

titopoquito 12-12-2008 11:22 AM

Probably you forgot to include the modules for your IDE or SATA driver in the initrd image.

Boot from cd, follow the at the boot prompt given line to use the huge kernel and your root partition so that you can boot into your fresh and shiny Slackware installation :)
Then login and use the script from Eric: http://www.slackware.com/~alien/tool...d_generator.sh to see which modules are missing. Then just create a new initrd.gz.

Didier Spaier 12-12-2008 11:53 AM

Problem solved
 
Thanks titopoquito.

Anyway I solved my problem this way (after reading mkinitrd and mkinitd.conf manual pages) :

cp /etc/initrd.conf.sample /etc/mkinitrd.conf
nano /etc/mkinitrd.conf

My mkinitrd.conf look like this after editing (edited lines only):

SOURCE_TREE="/boot/initrd-tree"
CLEAR_TREE="1"
OUTPUT_IMAGE="/boot/initrd.gz"
KERNEL_VERSION="2.6.27.7-smp"
KEYMAP="fr"
MODULE_LIST="reiserfs"
LUKSDEV="/dev/hda1"
ROOTDEV="/dev/hda1"
ROOTFS="reiserfs"

Then:

mkinitrd -F

and of course:

lilo

did the trick.

I can be wrong but I guess giving the parameters as indicated in this example from README.initrd:
mkinitrd -c -k 2.6.24.5-smp -m reiserfs

is no more enough, I don't know why.

FYI I first issued following command:
mkinitrd -c -k 2.6.27.7-smp -m reiserfs

and got the result shown in my first message.

gegechris99 12-15-2008 02:56 PM

Another person got the same issue and it was solved by using the mkinitrd with "full options".

http://www.linuxquestions.org/questi...55#post3373155

This is the second example mentioned at end of paragraph 3 in file README.initrd

bgeddy 12-20-2008 01:44 PM

Just in case anyone doesn't know there has been an updated package issued here in the patches directory for Slackware 12.2. I recommend installing this.


All times are GMT -5. The time now is 02:12 PM.