LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware - Installation (http://www.linuxquestions.org/questions/slackware-installation-40/)
-   -   Slackware 12.2 + Dell PowerEdge R410 with controller PERC H700 (http://www.linuxquestions.org/questions/slackware-installation-40/slackware-12-2-dell-poweredge-r410-with-controller-perc-h700-4175434225/)

cbastos 10-26-2012 11:58 AM

Slackware 12.2 + Dell PowerEdge R410 with controller PERC H700
 
Hi.
I got a working mail server running Slackware 12.2 with the Dazuko module compiled on it. Now, due to the inrease of the usage i need to move the system to a new machine.
A Dell PowerEdge R410 was bought to move the system on. It has a Raid controller PERC H700 where the SAS disks are attached, some raid 0 volumes were criated to make the disks available to Linux.

When booting with the Slackware 12.2 DVD none of the disks are found and the system hangs although if I boot with the Slackware 13.37 64Bit DVD all the disks are visible and Im able to intall the Slackware.

The trouble is, I cant run the version 13.37 because we use NOD32 for file server on this system and it relies on the old Dazuko module and do not work with the new DazukoFS module. I couldnt compile the legacy Dazuko module nor the redirFS module that is need by Dazuko with the kernel 13.37.

The 12.2 boot hangs at this point:

[ 5.541536] QLogic Fibre Channel HBA Driver: 8.03.05-k0
[ 5.560479] iscsi: registered transport (qla4xxx)
[ 5.583292] QLogic iSCSI HBA Driver
[ 5.601922] Emulex LightPulse Fibre Channel SCSI driver 8.3.18
[ 5.620934] Copyright(c) 2004-2009 Emulex. All rights reserved.
[ 5.639945] Brocade BFA FC/FCOE SCSI driver - version: 2.3.2.0
[ 5.658988] DC390: clustering now enabled by default. If you get problems load
[ 5.678243] with "disable_clustering=1" and report to maintainers
[ 5.697976] megaraid cmm: 2.20.2.7 (Release Date: Sun Jul 16 00:01:03 EST 2006)
[ 5.718164] megaraid: 2.20.5.1 (Release Date: Thu Nov 16 15:32:35 EST 2006)
[ 5.738361] megasas: 00.00.04.31-rc1 Mon. May 3, 11:41:51 PST 2010
[ 5.758913] megasas: 0x1000:0x0079:0x1028:0x1f16: bus 3:slot 0:func 0
[ 5.779931] megaraid_sas 0000:03:00.0: PCI INT A -> GSI 38 (level, low) -> IRQ 38
[ 5.801214] megaraid_sas 0000:03:00.0: setting latency timer to 64
[ 5.801274] megasas: FW now in Ready state

While booting with Slackware 13.37 gives:

[ 5.697976] megaraid cmm: 2.20.2.7 (Release Date: Sun Jul 16 00:01:03 EST 2006)
[ 5.718164] megaraid: 2.20.5.1 (Release Date: Thu Nov 16 15:32:35 EST 2006)
[ 5.738361] megasas: 00.00.04.31-rc1 Mon. May 3, 11:41:51 PST 2010
[ 5.758913] megasas: 0x1000:0x0079:0x1028:0x1f16: bus 3:slot 0:func 0
[ 5.779931] megaraid_sas 0000:03:00.0: PCI INT A -> GSI 38 (level, low) -> IRQ 38
[ 5.801214] megaraid_sas 0000:03:00.0: setting latency timer to 64
[ 5.801274] megasas: FW now in Ready state
[ 5.824299] megasas_init_mfi: fw_support_ieee=67108864
[ 5.830324] scsi0 : LSI SAS based MegaRAID driver
[ 5.873949] scsi 0:0:0:0: Direct-Access SEAGATE ST3146356SS HS10 PQ: 0 ANSI: 5
[ 5.897518] scsi 0:0:1:0: Direct-Access SEAGATE ST3146356SS HS10 PQ: 0 ANSI: 5
[ 5.922252] scsi 0:0:2:0: Direct-Access ATA ST31000524NS KA05 PQ: 0 ANSI: 5
[ 5.947902] scsi 0:0:3:0: Direct-Access ATA ST31000524NS KA05 PQ: 0 ANSI: 5
[ 6.044976] scsi 0:0:32:0: Enclosure DP BACKPLANE 1.07 PQ: 0 ANSI: 5
[ 6.083438] scsi 0:2:0:0: Direct-Access DELL PERC H700 2.30 PQ: 0 ANSI: 5
[ 6.104490] scsi 0:2:1:0: Direct-Access DELL PERC H700 2.30 PQ: 0 ANSI: 5
[ 6.125141] scsi 0:2:2:0: Direct-Access DELL PERC H700 2.30 PQ: 0 ANSI: 5
[ 6.161090] mpt2sas version 06.100.00.00 loaded
[ 6.180916] GDT-HA: Storage RAID Controller Driver. Version: 3.05
[ 6.200839] 3ware Storage Controller device driver for Linux v1.26.02.003.

Do I need to set any parameter at the boot prompt of the Slackware 12.2 so as the disks can be recognized?

If its not possible to boot with the wanted version, anybody knows if the legacy Dazuko module can be compiled with the kerneL 2.6.37?

Any help will be very appreciated.

Regards,
Carlos


All times are GMT -5. The time now is 03:20 AM.