LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices

Reply
 
Search this Thread
Old 11-19-2005, 01:56 PM   #1
slacksteep
LQ Newbie
 
Registered: Nov 2005
Posts: 22

Rep: Reputation: 15
PPPOE problem, and a window manager bad setup!


Hi everybody,
I have recently installed Slackware 10.2 with kernel 2.4 on an extra pc and have come across a few problems.

1.First time i logged in as root, I got carried away and gave intuitively an
# xinit ' 'I don't know where that came from I just typed it in'',
which brought me into the Xfce window manager and everything was cool.
However when after a day or so, I created a user account and tried to initiate the Xfce w.m with the
$ xinit
I got this message:

Fatal server error:Server is already active for display 0
if this server is no longer running,
remove /tmp/.X0-lock and start again.
I did remove .X0-lock and started again but nothing changed!

...another related error message was:

could not initialize font path element /usr/X11R6/lib/X11/fonts/CID

Have I pass some irreversible settings by mistake?
If I add my user-account to user-group 'root' would I resolve the problem?
...but still how will other users, with less privileges, activate a window manager in the future?

2. I have read some HOW-TOs about configuring my dsl connection...(so I can go to the internet and read all the neat instructions and helpful pdfs and not resort to the forum every time I get stuck )
having read the HOW TO for the dsl....I used the 'pppoe' to set up the connection and even though I occasionally managed to see my modem from a browser I did not manage to configure it properly in order to view other web pages...one would think that I have not configured the DNS right but whenever i VI into the 'resolv.conf' file the name servers of my provider are placed in tact. On my three last attempts i did not even get to the point to log on to my modem and the messages I got were the following:

on giving
#pppoe-start
#pppoe-status
NOTE: You have enabled demand-connection;
pppoe-status may be inaccurate.
pppoe-status: Link is down (can't read pppoe PID file /var/run/pppoe.conf-pppoe.pid.pppoe)

otherwise and on the more fortunate occasion when I could log onto my modem via a web-browser on the #pppoe-start command I wud get the message that connection timed-out....and the link-down finger!

Any help is greatly appreciated,

even if its a pointer to a huge PDF guide

Thnx people.
 
Old 11-20-2005, 02:29 AM   #2
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,768

Rep: Reputation: 477Reputation: 477Reputation: 477Reputation: 477Reputation: 477
As user run xwmconfig from the command line to choose xfce as your WM. Then use startx to start -not xinit.
Don't use on-demand with PPPOE. Give the 'server' option for DNS.
Don't add users to root group.
All slackers get the CID fonts error -no problem. When x starts it looks around for lots of things that it CAN use, but doesn't have to have them all in order to run. For example, it also looks for IPV6, but runs fine without it.
 
Old 11-20-2005, 04:13 AM   #3
slacksteep
LQ Newbie
 
Registered: Nov 2005
Posts: 22

Original Poster
Rep: Reputation: 15
Thanx gnsahley,

I already have improved some things while reading an X guide
and will try out ur input
as soon as I log back into the slack-machine!

I did get the internet to work after all...so things will be much easier now!

...as for the X window manager I realised later on that there must be some privilege
grants that I need to configure as a root to the user in order to activate a window
manager cause it seems that so far slackware has constrained the usage of wm inisialisation to the root only.
ur message was definitely reassuring

cheers!!
 
Old 11-20-2005, 06:42 AM   #4
hunterfighter
Member
 
Registered: Oct 2004
Location: Malaysia, Kuala Lumpur
Distribution: FreeBSD
Posts: 65

Rep: Reputation: 15
How do you make your box get it online?
My box still remaining the same error as yours for pppoe-status
 
Old 11-20-2005, 08:08 AM   #5
slacksteep
LQ Newbie
 
Registered: Nov 2005
Posts: 22

Original Poster
Rep: Reputation: 15
Well to tell u the truth hunter I just kept on passing the same information on all network configuration options i was aware of ...and after a few attempts it worked....and what do I mean by that....:

i did ....
#pppoe-start
then gave all the IP, gateway,user account and firewall details i was
prompted for!
then.....
#pppoe-connect
(check to see after that if u get any response from browser no matter if the message u get is not clear)

I also tried the following:

# ifconfig -a eth0 192.168.1.2 netmask 255.255.255.224

(where 192.168.1.2 is my static ip and for the 255.255.... u should use ur providers details)

then
#ifconfig
(just to check u put the right numbers)

then I did....
# route add default gw 192.168.1.1
(u pass YOUR gateway number instead)

then
#route
(just to check)
and i edited the /etc/resolv.conf file by adding my providers nameservers there, which should allready have them on....if u have used the pppoe-start command first)

and finally I also used the
#netconfig
and followed the prompts, i think u should leave this otion last, if previous two fail.

I did all that as root....but i am not sure for the results....somewhere along those settings lies a possible solution. Also check to see that ur ethernet connection is ok (green light on)
and if you manage to see ur router from mozilla or Konqueror browsers, pass some configuration there too.....!

good luckl

Last edited by slacksteep; 11-20-2005 at 08:17 AM.
 
Old 11-20-2005, 10:48 AM   #6
hunterfighter
Member
 
Registered: Oct 2004
Location: Malaysia, Kuala Lumpur
Distribution: FreeBSD
Posts: 65

Rep: Reputation: 15
Now another problem again
I type pppoe-start, it will timed-out occur. Last time it wil not.

I had try your methods,
route add gw 10.1.1.1
Host name look up error.

All of the method, failed.
It was drive me crazy.

Last edited by hunterfighter; 11-20-2005 at 09:42 PM.
 
Old 11-21-2005, 04:04 AM   #7
slacksteep
LQ Newbie
 
Registered: Nov 2005
Posts: 22

Original Poster
Rep: Reputation: 15
mine was timing out as well in the beggining but that was just cause my ethernet wire was not properly in....
make sure u have the right IPs in and the right gateway
I know it can be frustrating....but one should be determined......keep trying....i am afraid i have no more tips to offer.
Did u ever manage to see ur router on the browser....?
 
Old 11-21-2005, 04:50 AM   #8
hunterfighter
Member
 
Registered: Oct 2004
Location: Malaysia, Kuala Lumpur
Distribution: FreeBSD
Posts: 65

Rep: Reputation: 15
Yes I can even configure my router via browser.
Thanks a lot ya. I try to set my router into router mode. Make it autodail was much more easier.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need a Desktop/Window Manager for multiple monitor setup. kierl Linux - Software 1 02-22-2005 02:00 AM
Problem with window manager jeffChuck Slackware 8 11-09-2004 09:22 PM
PPPoE Server Setup problem girish_nats Linux - Software 0 11-02-2004 10:20 PM
adsl-status can't read pppoe PID file with rp-pppoe program setup Smarvy Linux - Newbie 2 03-13-2004 11:35 PM
Help! I screw up really bad -file system- and window manager problems, please help. alkalinelito Linux - General 1 11-23-2001 08:01 AM


All times are GMT -5. The time now is 04:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration