LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware - Installation (http://www.linuxquestions.org/questions/slackware-installation-40/)
-   -   Newie - boot/bash text too small Please help my eyes! (http://www.linuxquestions.org/questions/slackware-installation-40/newie-boot-bash-text-too-small-please-help-my-eyes-4175448536/)

Netnovice 02-04-2013 04:17 AM

Newie - boot/bash text too small Please help my eyes!
 
Hi. Please be kind to total newbie here! (I am proud to say I have managed to download, convert and install Libreoffice under slackware 14. It took me all morning trawling th internet on how to do it but I got there. But that is as far as I have gone.)

Please help. The boot text changes from standard VGA to an 8x8 font whch would be lovely on a proper 50” X-Windows workstation (I saw those things at Uni back in 1992 – huge great things!) but not on my little, underpowered netbook.

The text is so small that it is seriously hurting my eyes. Text in red swims in front of me. I have tried liloconfig to force a standard VGA text mode but Slackware is not having it! It always switches to teenie-tiny mode. (Hey, how can I think of myself as a Dark Linux Root User Overlord when I am using teenie-tiny text?)

I have looked and looked for a solution online. I have found the lilo.conf file – if that’s the issue – and tried appends but I have no real idea what I am doing and no success. But I only installed the OS last night.

This is seriously hurting my eyes so assistance gratefuly received. I can't do much more learning like this. (Yeah, I will get my eyes hecked ot but meantime…)

Many thanks.

TobiSGD 02-04-2013 05:42 AM

It is nopt the text size that switches, it is the screen resolution. In your lilo.conf add the parameter
Code:

video=AAAxBBB
to the append option at the beginning of the file. Replace AAA and BBB with the resolution you want to use (most netbooks have 1024x600 standard resolution).
Then re-run lilo and try it again.

brianL 02-04-2013 05:51 AM

If you want any software, such as LibreOffice, look on these sites first:

http://slackbuilds.org/

http://connie.slackware.com/~alien/slackbuilds/

http://rlworkman.net/pkgs/

Netnovice 02-04-2013 08:33 AM

Quote:

Originally Posted by TobiSGD (Post 4884015)
Replace AAA and BBB with the resolution you want to use (most netbooks have 1024x600 standard resolution).
Then re-run lilo and try it again.

Thanks. I, er, tried that before I came here. I swear, I do check things online before I go posting! ;-)

I tried again and various combinations just now. Nothing.

The thing is that I can set the LILO start resolution fine! The Acer Aspire boots up in whatever mode I choose but partway through the boot process the screen blanks and then returns in tiny mode.

Native resolution of the machine is 1366x768 and Slackware seems insistent on using all of it!

Netnovice 02-04-2013 08:37 AM

BrianL - Thank you so much.

I have much to learn. but I have to give Slackware this much... You actually get software with it in the form of compilers, editors, etc, etc. I tried Kubuntu and found, to my horror, you could do NOTHING without being online and downloading invisible dependencies.

I know slackware has a reputation for being hard but so far I have had more success with it than Kubuntu. I intend for the netbook to be an educational machine and OFFLINE so I need to know how to install stuff from packages. So this looks very helpful.

Thank you again.

TobiSGD 02-04-2013 01:22 PM

Quote:

Originally Posted by Netnovice (Post 4884109)
The Acer Aspire boots up in whatever mode I choose but partway through the boot process the screen blanks and then returns in tiny mode.

Native resolution of the machine is 1366x768 and Slackware seems insistent on using all of it!

This behavior is normal and occurs when the kernel loads the video driver. The video driver determines the recommended resolution and sets the display accordingly. For this reason the video= option was invented, so that you can tell the kernel which resolution you want to use and I wonder why this doesn't work for you.
Have you re-run lilo after you have made the changes to the config file?

Netnovice 02-04-2013 07:40 PM

Rerun LILO?

Ahh! Sorry, I did not know LILO was a command. As I say, I have runing Linux for two days here!
Re-run.

"unrecognised token video"

I placed the video parameter just after append.

Where am I going wrong? Sorry to be a pain. This is all new to me.

Cheers.

Netnovice 02-04-2013 07:50 PM

Exact text enered was

video=640x480

I have tried variations to no avail. Is there some dependency?

TobiSGD 02-04-2013 07:58 PM

You have to run the lilo command to make it aware of the changes.
Your append line in /etc/lilo.conf should be looking somewhat like this:
Code:

append=" vt.default_utf8=1 resume=/dev/sda1"
Of course you will have different parameters there as I have, but it is basically the same for all parameters. Now add the video option there:
Code:

append=" vt.default_utf8=1 resume=/dev/sda1 video=640x480"
and run the lilo program to confirm the changes.

Netnovice 02-04-2013 08:12 PM

Ahh! thank oyu. I think I can see where I am going wrong. he deo parameter needs to be inside the quotes!

No time to check. I wil try again later.

Thanks.

Netnovice 02-05-2013 04:12 AM

Ahhh!

Gotcha! 'video' must be within the quotes after append.

So much to learn...

Many thanks. My eyes thank you from the bottom of their hearts!


All times are GMT -5. The time now is 10:17 AM.