LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices

Reply
 
Search this Thread
Old 01-19-2013, 01:21 AM   #1
slackin1stimer
LQ Newbie
 
Registered: Dec 2012
Distribution: Slackware-14 64
Posts: 6

Rep: Reputation: Disabled
Minor issue with CUPS install and "Encrypted root" setup instructions.


I am still fairly new to Slackware and have only done an install with Slackware 14 64-bit. I did a bit of googling on both the issues I had but found little.

RE: CUPS--The program works as it should but for some reason the install process omits the "/etc/rc.d/rc.cups" file. I tried a direct "installpkg" from the dvd I burned but no luck. Oddly enough though I can "explodepkg" and get the rc.cups file. Problem solved but cause still a mystery to me.

RE: "Encrypted root"--I meticulously followed the instructions included on the DVD but always got stuck at the same point in the boot process. I did SIGNIFICANT Googling to try and find a solution but to no avail. The README_CRYPT.txt leads one to a lilo.conf entry including the line "root = /dev/mapper/cryptroot" which did not work for me. However, by changing the line to
"root = /dev/mapper/lukssdaX" I can unlock and boot my system. And to be clear I certainly don't doubt the author's expertise on this one, but rather am just puzzled why the clear and easy to understand instructions didn't work for me.


Since I managed to solve my issues I suppose this post doesn't constitute a question, but I am curious to know if anyone else ran into the same or similar issues.
 
Old 01-25-2013, 05:49 AM   #2
natharran
Member
 
Registered: Jul 2012
Location: Czech Republic
Distribution: Slackware64 14.1
Posts: 34

Rep: Reputation: Disabled
Thumbs up Re: Encrypted root

Hi,

regarding the encrypted root, I've followed these two videos on Youtube:

http://www.youtube.com/watch?v=yo3qQeWFcV0

http://www.youtube.com/watch?v=BeRTIBsDS3s

The author is using Slackware 13.0, but you can use the same method witch 14.0.

Hope it helps you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] BackTrack 5 R3 boot issue: "/dev/mapper/vg-root does not exist! Dropping to shell!" EStyles Linux - Laptop and Netbook 2 12-07-2012 08:24 PM
newbie question: whats the difference between "su root", "su" and "su -&quo mojarron Slackware 9 12-07-2009 04:08 PM
Logged in as "root"/Fedora 8 but get "Operation not permitted" when using "chmod etc gosunlee Linux - Newbie 7 02-10-2008 05:56 AM
Standard commands give "-bash: open: command not found" even in "su -" and "su root" mibo12 Linux - General 4 11-11-2007 10:18 PM
Cannot install fedora core 1 or core 2: Initial setup crashes: "Unable to mount root" ovelasco Linux - Newbie 10 07-15-2004 07:19 PM


All times are GMT -5. The time now is 05:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration