LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices



Reply
 
Search this Thread
Old 10-19-2007, 09:09 PM   #1
oathkeeper
LQ Newbie
 
Registered: Oct 2007
Posts: 3

Rep: Reputation: 0
lilo gives an error on installation


Hi.
I´m currently trying to install slackware 12 on my pc, the thing is that
lilo doesn´t install when it is asked to, just gives me an error and the installation procedes, and then i can´t boot my pc, i already the safe-disk mod, retried to download/burn again , and still nothing.
Starting to think that slackware doesn´t like me XD
 
Old 10-20-2007, 01:47 AM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Welcome to LQ!

You haven't provided enough details about what you did -- where you tried to install LiLO, etc.

Please read How To Ask Questions The Smart Way. If you have the time, this article is, IMO, well worth a read. If you don't have the time, and you still want to get questions answered by the hacker volunteers who man free software projects, then you really should make the time anyway and read this article.
 
Old 10-20-2007, 06:10 AM   #3
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Also, mind sharing with us the nature of the error that lilo gives you ? I mean, I'm sure I can think of many different errors all potentially generated by lilo, each pointing to a different problem and a different solution.
 
Old 10-20-2007, 11:39 AM   #4
oathkeeper
LQ Newbie
 
Registered: Oct 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Sorry.
I've tried to install lilo with all 3 options (mbr,floppy etc) and it gives an error saying that lilo wasn't installed, and to boot from safe-disk. Then the installation procedes doing everything without error. When i try to boot it from the safe-disk it gives an erro saying "System boot failure - Insert system-disk".
 
Old 10-20-2007, 12:10 PM   #5
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
Firstly check your bios if MBR or virus protection is enabled or not. If enabled, please disable it. When you put Slackware DVD and come to Lilo installation, you will be asked where to install. I suggest that you choose MBR (be aware, that it will replace your default bootloader).
 
Old 10-20-2007, 03:50 PM   #6
SqdnGuns
Member
 
Registered: Aug 2005
Location: Fountain Valley, CA / Thailand
Distribution: Slackware64® 14.0
Posts: 981

Rep: Reputation: 88
Try installing lilo with the expert config. When I install, Slack sees my DVD-RW as SDA and my HDD is SDB, I have to tell it to install it too SDB.
 
Old 10-21-2007, 03:24 PM   #7
oathkeeper
LQ Newbie
 
Registered: Oct 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Amen.
I did it, it was that thingy virus on the bios :P
eheh tks guys
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OS will not boot after good installation. Freezes at startup with error, maybe LILO? ShockProductions Slackware 4 08-06-2007 11:32 AM
Error output with LILO while updating my lilo.config adilturbo Linux - General 4 10-17-2006 05:10 PM
Lilo installation error Nikon01 Slackware 5 08-31-2004 11:28 AM
LILO LinuxEBDA error to /usr/bin/gdm error true_atlantis Slackware 0 04-28-2004 02:31 PM
error loading operating system (lilo error) KoKi Slackware 1 03-03-2004 05:46 PM


All times are GMT -5. The time now is 10:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration