LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware - Installation (http://www.linuxquestions.org/questions/slackware-installation-40/)
-   -   KDE crashing; Xfce patchy on new install of 14_64, v.3.81 (http://www.linuxquestions.org/questions/slackware-installation-40/kde-crashing%3B-xfce-patchy-on-new-install-of-14_64-v-3-81-a-4175468008/)

textillis 07-01-2013 09:48 AM

KDE crashing; Xfce patchy on new install of 14_64, v.3.81
 
1 Attachment(s)
I have slackware 14_64 running, with:
"Welcome to Linux 3.8.1 on tty1"
greeting me just before prompt.

However:
  1. when I startx with KDE, the gui crashes with darkened screen; no mouse or keyboard response;
  2. when I startx with xfce, the gui is still crumbly, patchy, sketchy, improperly rendered; with letters missing from menu items and the system crashing when I launch firefox or thunderbird in KDE; unreadable/unusable in Xfce.(Please see attached png of firefox launched from xfce)
  3. konsole works perfectly; terminal emulator is unusable for reasons given above
Does anyone have any idea what else I could do short of upgrading to -current, as I do not feel competent to do this just yet.

thx in advance ...

ReaperX7 07-01-2013 10:15 PM

Slackware 14, x86 and x64, should only be coming with kernel 3.2.29 by default. How did you get the 3.8.1 kernel?

padeen 07-01-2013 11:26 PM

Re #2: there is a known bug between the latest Firefox and KDE and the oxygen-gtk2 theme which may cause your problem. A recent update to Slackware 14.0 downgrades Firefox to Firefox-17-ESR which fixes the bug. Perhaps that is causing the issue.

textillis 07-02-2013 01:45 AM

Quote:

Originally Posted by ReaperX7 (Post 4982141)
Slackware 14, x86 and x64, should only be coming with kernel 3.2.29 by default. How did you get the 3.8.1 kernel?

I installed it on advice garnered here from Allend, and other experienced members, with the rationale that later kernel might have better support for my ivy bridge CPU with inbuilt graphics.

thanks for response
regs

textillis 07-02-2013 01:46 AM

Quote:

Originally Posted by padeen (Post 4982173)
Re #2: there is a known bug between the latest Firefox and KDE and the oxygen-gtk2 theme which may cause your problem. A recent update to Slackware 14.0 downgrades Firefox to Firefox-17-ESR which fixes the bug. Perhaps that is causing the issue.

Thanks mate; but it won't work under xfce either; in fact, that picture I attached to last post, with flakey firefox image, that was opened in xfce.

cheers,

textillis 07-02-2013 01:48 PM

Quote:

Originally Posted by ReaperX7 (Post 4982141)
Slackware 14, x86 and x64, should only be coming with kernel 3.2.29 by default. How did you get the 3.8.1 kernel?

Now I have -current, that is, 3.7.1, and still no gui, still KDE crashes the system!


All times are GMT -5. The time now is 11:00 PM.