LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices

Reply
 
Search this Thread
Old 05-25-2007, 02:41 PM   #1
rh-penguin
Member
 
Registered: Sep 2006
Location: England, London
Distribution: Debian, BT2
Posts: 57

Rep: Reputation: 15
Install sucessfull but Slack wont boot


hi,

I've installed Slack 11.0 sucessfully(DVD) but when it comes to booting the thing it wont go. All i see is a blank/black screen.
I'm using it on a Laptop.
-2.5Ghz
-512RAM
-40G HD
Lilo installed sucessfully first try and didnt complain about anything.

What could possiby be wrong?

Thanks!
 
Old 05-25-2007, 02:55 PM   #2
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Where did you install lilo ? Should be to MBR. (there was a recent post about this very thing: http://www.linuxquestions.org/questi...d.php?t=556177)
 
Old 05-25-2007, 03:13 PM   #3
rh-penguin
Member
 
Registered: Sep 2006
Location: England, London
Distribution: Debian, BT2
Posts: 57

Original Poster
Rep: Reputation: 15
yup, i chose MBR. I used the 2.6 kernel(huge26.s) for the install. I've got a /root, /swap and /home part. In the link you provided he says
Quote:
got it.
apparently i didn't set up the correct parameters for lilo for my cd drive.
What does he mean? what do i need to do?

Thanks!
 
Old 05-25-2007, 04:04 PM   #4
sparc86
Member
 
Registered: Jul 2006
Location: Joinville, Southern Brazil
Distribution: Debian, CentOS
Posts: 296

Rep: Reputation: 31
Use the slackware CD to boot into your box and then edit the file:

/etc/lilo.conf


and change:

vga=whatever

to


vga=ask


At the next boot, try to boot with the option number 6 or another.
 
Old 05-25-2007, 04:47 PM   #5
rh-penguin
Member
 
Registered: Sep 2006
Location: England, London
Distribution: Debian, BT2
Posts: 57

Original Poster
Rep: Reputation: 15
do i change all of them? I changed one but it hasnt seem to made any difference...
 
Old 05-25-2007, 05:02 PM   #6
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
you change the one that is not commented out.

Code:
# this is a comment
 
Old 05-25-2007, 05:29 PM   #7
rh-penguin
Member
 
Registered: Sep 2006
Location: England, London
Distribution: Debian, BT2
Posts: 57

Original Poster
Rep: Reputation: 15
yup, thats what i did. I also tried the normal option(no GUI) but still nothing...
 
Old 05-25-2007, 05:40 PM   #8
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Technically you also have to 'chroot' into there and run 'lilo' to update the config. I'm sure there's a way to do this when installing ... maybe expert mode for the install lilo part.
 
Old 05-26-2007, 12:54 PM   #9
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,081
Blog Entries: 52

Rep: Reputation: Disabled
Have you installed the kernel-modules?
 
Old 05-26-2007, 01:10 PM   #10
sparc86
Member
 
Registered: Jul 2006
Location: Joinville, Southern Brazil
Distribution: Debian, CentOS
Posts: 296

Rep: Reputation: 31
Ok, let's go.


Insert your slackware CD and boot in your system.

After the login, use the following commands:

mkdir /mnt/hda5 (or whatever you want)
mount /dev/hda5 /mnt/hda5 (or whatever is the number of your harddrive)
chroot /mnt/hda5

vi /etc/lilo.conf (if you didn't make those changes we were talking about yet)

lilo



Ok, now just reboot and it might be working.

Last edited by sparc86; 05-26-2007 at 01:12 PM.
 
  


Reply

Tags
best, installation, post, slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slack wont boot. How do I installpkg e2fsprogs? denning Slackware 8 03-20-2006 04:14 AM
After VFS install (sucessfull) Boot/Shutdown /dev/nbd/1-127 error Giallo998 Linux - Hardware 0 03-06-2005 02:42 AM
Slack Wont Boot 10 HeavyGear Slackware 1 09-13-2004 06:02 PM
Win XP Wont boot after installing Slack 9.1 mtcougar832 Slackware - Installation 12 12-26-2003 02:19 PM
slack 9.0rc1 wont boot with lilo. ratbert90 Slackware 5 03-11-2003 03:04 PM


All times are GMT -5. The time now is 12:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration