Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Slackware - Installation This forum is for the discussion of installation issues with Slackware.


  Search this Thread
Old 08-26-2005, 08:07 AM   #1
LQ Newbie
Registered: Aug 2005
Distribution: Slackware
Posts: 10

Rep: Reputation: 0
Talking HP / Compaq 5i Raid Controllers

Hi All,

I had a hell of a time sussing how do get slackware to install on a 5i Raid control ler but did it in the end, I have documented what I have done (I hope it makes sense) to save others having to pull their hair out

Install Slackware

then reboot onto with the CD and log in as root

then mount /dev/cciss/c0d0p1 /mnt -t ext3

cciss is how the HP/compaq 5i raid controller is known

change to /mnt/etc

make sure your lilo.conf is similar to below

chroot /mnt/

lilo -M /dev/cciss/c0d0 mbr

and reboot )

xxxxxx:/etc# cat lilo.conf
# LILO configuration file
# generated by 'liloconfig'
# Start LILO global section
lba32 # Allow booting past 1024th cylinder with a recent BIOS
boot = /dev/cciss/c0d0p1
#compact # faster, but won't work on all systems.
#timeout = 5
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# ramdisk = 0 # paranoia setting
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/cciss/c0d0p1
label = Slackware
read-only # Non-UMSDOS filesystems should be mounted read-only for checking
# Linux bootable partition config ends

Last edited by Gingergit; 08-26-2005 at 08:13 AM.
Old 08-27-2005, 04:20 PM   #2
Registered: Dec 2004
Location: Netherlands
Distribution: Slackware
Posts: 173

Rep: Reputation: 30
I wish this thread stood here about 3 months ago, hehe

I managed it to install without problems, but had to do quite a bit searching to notice /dev/cciss/c0d0 was the device...

Getting Red-Hat on it (our client eventualy choose Red-Hat (for support issues)) was a little easier
Old 02-11-2009, 11:05 PM   #3
LQ Newbie
Registered: Jun 2006
Posts: 8

Rep: Reputation: 2
Great time saver

Thanks for saving me time, found your post while searching for bugs after clocking some hours with Slackware 12.2, HP DL380 and Raid 5i. Your instructions worked right the first time out and saved me additional hours of tweaking. Thanks again.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
SCSI Raid Controllers tbayboy SUSE / openSUSE 1 09-03-2005 10:39 AM
Linux and cheap raid controllers AndrewMSConvert Linux - Hardware 2 12-01-2004 07:42 PM
IDE Raid Controllers for Fedora? atrixware Linux - Hardware 1 11-09-2004 12:40 AM
RAID Controllers gcombe74 Linux - Hardware 2 01-14-2003 01:49 PM
IDE raid controllers under linux jaysan Linux - Software 10 11-06-2002 02:43 PM

All times are GMT -5. The time now is 06:58 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration