LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices

Reply
 
Search this Thread
Old 08-06-2013, 08:25 PM   #1
j.sudol
LQ Newbie
 
Registered: Aug 2013
Distribution: Slackware 14.0
Posts: 2

Rep: Reputation: Disabled
How to Change Screen Resolution, Command Line


I recently installed Slackware Linux 14.0 on a desktop. Partway through the boot sequence, the screen resolution jumps from what I assume is VGA=normal (in the lilo.conf file) to the highest possible resolution. The text shrinks to the equivalent of six point font on paper, making it quite difficult to read. I will not be using any X-windows environments. I use the computer solely for computation and work entirely from the command line. So, how do I switch the screen resolution or the font size for the command line?
 
Old 08-06-2013, 10:41 PM   #2
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 8,225

Rep: Reputation: 1552Reputation: 1552Reputation: 1552Reputation: 1552Reputation: 1552Reputation: 1552Reputation: 1552Reputation: 1552Reputation: 1552Reputation: 1552Reputation: 1552
I think that the change in text size comes when the video card is detected and the appropriate drivers are loaded. That's just a guess, though.

I googled about a bit and it seems that the answer is to use a framebuffer. I the (search found this article about Lilo and framebuffer. I have no idea whether it will work, but it might be a start.

http://web.njit.edu/all_topics/Prog_...fer-howto.html

I also found several articles that talked about configuring framebuffer when you set up Lilo during install, such as this one.

http://dev.slackware.it/docs/howto.php?page=15

I suspect that you could boot to the install disk and skip to the Install Lilo section and run this, but that's just a guess.

Hope this helps you on your hunt.
 
1 members found this post helpful.
Old 05-19-2014, 05:01 AM   #3
dunne
LQ Newbie
 
Registered: May 2014
Distribution: slackware
Posts: 8

Rep: Reputation: 3
Disabling the framebuffer

Quote:
Originally Posted by j.sudol View Post
I recently installed Slackware Linux 14.0 on a desktop. Partway through the boot sequence, the screen resolution jumps from what I assume is VGA=normal (in the lilo.conf file) to the highest possible resolution. The text shrinks to the equivalent of six point font on paper, making it quite difficult to read. I will not be using any X-windows environments. I use the computer solely for computation and work entirely from the command line. So, how do I switch the screen resolution or the font size for the command line?

I see this is over a year old, but I think my answer may still be helpful
to others who find this through a search.

I had the same problem recently, trying out slackware 14.1. The kernel was
booting up with the normal console, and then switching to the framebuffer
with an unusably-small font (142x80 or something absurd like that). I did a
google search and found several "solutions" that simply didn't work for me.
Finally, I found this:

With a properly-functioning kernel, you can disable framebuffer
console (fbcon) dynamically by adding something like this to the
kernel command line:

fbcon=map:2

(This syntax is also used to assign specific framebuffers to specific
VT ttys, but is also used to disable fbcon altogether if you specify
a framebuffer number that is out of range.)

https://bugzilla.redhat.com/show_bug.cgi?id=146003
So I duly added
Code:
        append="fbcon=map:2"
to the approprate LILO stanza, and that fixed the problem. Now I get the
good old VGA 80x25 on the console.

 
Old 05-19-2014, 06:58 AM   #4
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,650

Rep: Reputation: 1233Reputation: 1233Reputation: 1233Reputation: 1233Reputation: 1233Reputation: 1233Reputation: 1233Reputation: 1233Reputation: 1233
Two ways:

1) Use a Terminus font, that you'll find in /etc/share/kbd/consolefonts [Read the PPS below first]. To try one, for instance size 20 bold:
Code:
setfont -v ter-120b.psf.gz
In the font name argument, 1 is the codepage (should be OK for English), 20 is the size , b stands for bold (you can try also v or n instead). To check what's available:
Code:
( cd /usr/share/kbd/consolefonts
ls -1 ter* 
)
When you are satisfied, just put the setfont command in /etc/rc.d/rc.font and make it executable.

2) Make and install a package for FbTerm. This allows you to use any true type font on the console (not using X). I recommend DejaVu (you can pick DejaVu Sans, DejaVu Sans Mono or DejaVu Serif). Advantages:
  • DejaVu is very good looking IMO
  • It is fully scalable, i.e. you can use any size that you want. Of course you can't do that with a bitmap font.
  • fbterm works directly in a Linux console and in a framebuffer as well (not under X, but it wouldn't be useful there as true type fonts are already available under X).
For instance:
Code:
fbterm -n "DejaVu Sans Mono" -s 26
See "man fbterm" for the details, and don't worry: when writing font names case doesn't matter.

PS Just in case you didn't make a full Slackware installation: you'll need fontconfig and freetype and of course the font you want to use as dependencies of fbterm.

PPS I forgot... Terminus font is not shipped in Slackware 14.0. But that's not an issue, just grab the package you'll find in the ap/ series for Slackware 14.1 on any mirror, there is nothing to compile, so you can safely install it on Slackware 14.0 with the installpkg command.

PPPS I just realized I'm *really* late... Well, maybe that will help some though

Last edited by Didier Spaier; 05-20-2014 at 03:00 PM. Reason: path to consolefonts was wrong; fixed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing screen resolution from the command line fbr Linux - Newbie 5 02-03-2010 08:39 PM
increase command line screen resolution sunpascal Linux - Newbie 4 02-09-2006 01:35 PM
change monitor resolution from command line gschrade Linux - Newbie 2 04-23-2004 04:57 PM
Command to change screen resolution? pilot1 Fedora 7 12-17-2003 04:01 PM
[command line] Resolution change in RedHat 8 asiemer Linux - General 1 07-01-2003 08:04 PM


All times are GMT -5. The time now is 09:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration