LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices

Reply
 
Search this Thread
Old 02-06-2004, 03:08 AM   #1
peppie
LQ Newbie
 
Registered: Dec 2003
Posts: 6

Rep: Reputation: 0
./configure needs GKT


Hi

Just try to compile a new pakage (baycomepp) who is not on the slackware cd or ftp site

The ./configere ends with with:
==========
checking for GTK - version >= 1.2.0... no
*** Could not run GTK test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK was incorrectly installed
*** or that you have moved GTK since it was installed. In the latter case, you
*** may want to edit the gtk-config script: /usr/bin/gtk-config
===========

I have the next GTK pakages on the system:
gtk+-1.2.10-i386-3
gtk+2-2.2.4-i486-1
gtk-engines-2.2.0-i

What do I need more to install?

Just running slackware in the text mode

Peter
 
Old 02-06-2004, 03:15 AM   #2
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Try passing the path to gtk+-1.2.1 to configure, do "./configure --help" to see the correct syntax.
 
Old 02-06-2004, 03:23 AM   #3
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,406

Rep: Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965Reputation: 1965
you need to install gtk-devel to compile source programs for gtk

(minus 2 points bern! that was easy! )
 
Old 02-06-2004, 03:36 AM   #4
peppie
LQ Newbie
 
Registered: Dec 2003
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks for the fast response, but:
Is there a package for gtk-devel for slackware?
The slackeare page gives on GTK only:

gtk+-1.2.10-i386-3
gtk+2-2.2.4-i486-1
gtk-engines-2.2.0-i486-3
libgtkhtml-2.4.1-i486-1


Peter
 
Old 02-06-2004, 04:10 AM   #5
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Peter,
Do you have a link to the program your trying to build?



Quote:
Originally posted by acid_kewpie
you need to install gtk-devel to compile source programs for gtk

(minus 2 points bern! that was easy! )
Slackware does not have so called "devel" packages, we just have packages and source.

 
Old 02-06-2004, 04:23 AM   #6
peppie
LQ Newbie
 
Registered: Dec 2003
Posts: 6

Original Poster
Rep: Reputation: 0
The sorce is at:
http://www.baycom.org/bayweb/term/jn...pp-0.10.tar.gz

Peter
 
Old 02-06-2004, 04:33 AM   #7
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Do you have gtk+-1.2.10-i386-3 instaled?
I do and this is what I get in ./configure
Code:
checking for gtk-config... /usr/bin/gtk-config
checking for GTK - version >= 1.2.0... yes
 
Old 02-06-2004, 08:08 AM   #8
peppie
LQ Newbie
 
Registered: Dec 2003
Posts: 6

Original Poster
Rep: Reputation: 0
Bern

Yes i have installed gtk+-1.2.10-i386-3
And reinstall it again to make sure.
Maybe there is an other pakkage needed?
Stil get ; checking for GTK - version >= 1.2.0... no


peter
 
Old 02-06-2004, 08:19 AM   #9
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
OK, do "make distclean" in baycomepp-0.10/, then su to root and do "ldconfig" then try "./configure" again.
 
Old 02-16-2004, 11:31 PM   #10
rose_bud4201
Member
 
Registered: Aug 2002
Location: St Louis, MO
Distribution: Xubuntu, RHEL, Solaris 10
Posts: 927

Rep: Reputation: 30
Thanks guys, this thread just solved my 'missing gtk' problem!

-Laura
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Configure dhcpd (Configure DHCP Server) hanserver2004 LinuxQuestions.org Member Success Stories 3 10-23-2006 06:39 AM
glib-devels gkt-devels ? shanenin Linux - Software 5 04-27-2005 03:31 PM
configure: error: when trying to install / configure new software ? met tomfer007 Linux - Software 1 07-25-2004 03:52 PM
./configure says gkt-config is not there but it is! saavik Linux - Software 3 12-13-2002 08:22 AM
about gkt+ SUBBU Linux - Software 1 05-21-2002 09:26 AM


All times are GMT -5. The time now is 11:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration