LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware - Installation (http://www.linuxquestions.org/questions/slackware-installation-40/)
-   -   Can't boot slackware 10.2 from hard drive (http://www.linuxquestions.org/questions/slackware-installation-40/cant-boot-slackware-10-2-from-hard-drive-521753/)

Ray Hill 01-22-2007 12:26 PM

Can't boot slackware 10.2 from hard drive
 
I'm installing slackware 10.2 on a new system. The system is:
- Intel motherboard D102GGC2
- Celeron Processor 2.66 GHZ
- WD 80GB SATA150 Hard Drive
- 512 MB DDR2 667 MHZ RAM

I'm using lilo as the boot loader and I've loaded with several different configurations for disk partitions and boot which I'll describe after I describe the problem's symptoms, and for the most part I've used defaults on the slackware cd for setup.

Symptoms:
- I can boot off the slackware install cd (number one)
- I can boot off the floppy bootdisk I make during setup
- I can not boot from my hard drive:
After the BIOS screen (the opportunity to edit BIOS), I see the HD light flicker briefly, the BIOS screen clears, I have an underscore, blinking cursor, and nothing following that. This same process seems to occurs with every configuration I've tried.

Configurations I've tried:
- Disk Partitioning (always used cfdisk):
- I've alternated between /dev/sda1 and sda2 for root and /dev/sda2 and sda1 for swap
- I've alternated between primary and logical partition types for each partition
- I've alternated between ext2 and reiserFS files systems for root


Currently configured as:
- /dev/sda1 Primary Linux swap 1497.01MB
/dev/sda2 Boot Primary Linux ReiserFS 39999.54MB
Pri/Log Free Space 38527.22MB

- During setup I selected sata.i for the kernel

- Note: during every setup lilo fails. After setup, from the slackware cd boot I do the following:
- mkdir /mymnt
- mount /dev/sda2 /mymnt
- vi /mymnt/etc/lilo.conf
the root parameter is always blank. I set root = /dev/sda2
- cp /mymnt/lilo.conf /etc/lilo.conf
- execute lilo
- umount /mynt
- halt

/var/log/messages shows the boots from floppy, but there is nothing that indicates an attempted boot from the hard drive. Same for /var/log/debug, and /var/log/syslog. /var/log/syslog looks good.

I would attach those logs, but I don't seem to have that capability.

I would appreciate any help any of you can provide!
Thanks in advance.

Ray

mikieboy 01-22-2007 02:06 PM

Sounds an obvious question but is your system BIOS set to boot from a SATA drive?

Ray Hill 01-22-2007 03:07 PM

Mikieboy,

Nothing is obvious to me at this point! I checked through my BIOS settings and while I don't see anything that is specifically boot from sata drive, my sata drive is listed in BIOS as the first boot device in the Boot Drive Order list. (Intel's BIOS)

Thanks for the response (and don't hesitate to point to me even what seem to be obvious to most... I could have missed it)

Ray

bioe007 01-22-2007 03:16 PM

where did you install lilo too? (MBR/ROOT) I always do MBR.

If /sbin/lilo or /sbin/liloconfig is not working then I'd not expect your machine to boot properly.

I had similar troubles on my dell laptop with a sata.i kernel installation.

My problem may have been different than yours though: liloconfig would run 'ok' during setup, but later I would see that both fstab and lilo.conf were trying to reference /dev/hdaX for my hard drive.

I ultimately solved this by booting from Slack11CD1 and editing lilo.conf and fstab by hand. then /sbin/lilo worked.

*side note* after doing that and having a working slackware i screwed up lilo again and could not fix it (probably my own limitations)

If you've got the time to try and re-install then you could use the slack11 huge26.s kernel for install/default kernel. that seems to have worked for me.

what does your /etc/fstab and /etc/lilo.conf look like?

Ray Hill 01-22-2007 03:32 PM

bioe007,

I've tried MBR and root. Currently, lilo is installed to root.

here's fstab:
/dev/sda1 swap swap defaults 0 0
/dev/sda2 / reiserfs defaults 1 1
/dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

here's lilo.conf:
# LILO configuration file
# generated by Ray Hill 01/22/07
#
# Start LILO Global Section
lba32
boot = /dev/sda2
vga = 773
# End LILO Global Section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/sda2

label = Linux
read-only
# Linux bootable partition config ends

By the way, I configured my current lilo.conf, but I've started with the system generated lilo.conf a number of times. I've tried commenting out the 'liba32' to not allow booting past 1024th cylinder, I've used vga = normal, and I've tried root = /dev/sda

All seem to produce the same results.

bioe007 01-23-2007 05:23 PM

Quote:

Originally Posted by Ray Hill
/dev/sda2 / reiserfs defaults 1 1

another obvious question, you do have reiserfs filesystem support compiled into your kernel? not as a module? (I expect you're still using a default kernel which should include reiserfs - i think)

another question:

after you do:

# mount /dev/sda2
# /sbin/lilo

what output do you get? Lilo should report something like 'Added Linux'

I could never get lilo to run properly while trying to boot from the Slack CD until I chroot'd.

mikieboy 01-23-2007 06:02 PM

I think if you select Reiserfs as your filesystem type during install, Slackware compiles support into the kernel. It's not something I ever had to do manually in Slack. In any case the system boots from the floppy. I think the problem lies with Lilo or the MBR but I can't figure out what.

Only thing I can suggest that might be worth a try is to install Grub. I've used Grub by preference for the last five years and it has always worked flawlessly. I used to know of a great tutorial on Grub installation/configuration but unfortunately the webpage is no longer available. I'm afraid you'd have to google.

Ray Hill 01-23-2007 11:18 PM

Hey guys,

I got it! It must have been something I was missing or doing wrong. But I'm not sure what. I started over, AGAIN, and deleted both partitions, re-booted to make sure my partitions were gone. Then partitioned with cfdisk, ran set-up with almost total defaults. However, I let set-up call liloconfig, used expert mode, built a new lilo.conf, but DID NOT let set-up try to install lilo. After finishing set-up, I edited lilo.conf to complete the root= parameter, ran lilo, and then was able to boot from my hard drive. I used the Master Boot Record and used 'compact' in lilo.conf.

Finally!

Now about all I need is to find 2 files that are corrupted on my 10.2 CDs. They are:
/var/log/mount/slackware/l/jre-1_5_0_04-i586-2.tgz
/var... /kde/kdelibs-3.4.2-i486-1.tgz

Thanks for your help!

Ray

onebuck 01-24-2007 06:59 AM

Quote:

Originally Posted by Ray Hill
I'm installing slackware 10.2 on a new system. The system is:
- Intel motherboard D102GGC2
- Celeron Processor 2.66 GHZ
- WD 80GB SATA150 Hard Drive
- 512 MB DDR2 667 MHZ RAM
<snip>
- Note: during every setup lilo fails. After setup, from the slackware cd boot I do the following:
- mkdir /mymnt
- mount /dev/sda2 /mymnt
- vi /mymnt/etc/lilo.conf
the root parameter is always blank. I set root = /dev/sda2
- cp /mymnt/lilo.conf /etc/lilo.conf
- execute lilo
- umount /mynt
- halt

I would appreciate any help any of you can provide!
Thanks in advance.

Ray

Hi,

Just a question, did you fail to chroot to the /mymnt?

If you don't chroot to that system then the lilo will not write.

It looks like you just copied your edited lilo.conf.

mikieboy 01-24-2007 07:40 AM

Quote:

Now about all I need is to find 2 files that are corrupted on my 10.2 CDs. They are:
/var/log/mount/slackware/l/jre-1_5_0_04-i586-2.tgz
/var... /kde/kdelibs-3.4.2-i486-1.tgz
Should find jre and kdelibs at www.slackware.org in the package repositories.

Glad you sorted your boot problem,

Mikie


All times are GMT -5. The time now is 07:00 AM.