LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices



Reply
 
Search this Thread
Old 07-09-2007, 03:04 PM   #1
sn9ke_eyes
Member
 
Registered: Feb 2003
Location: Texas
Distribution: slackware 11
Posts: 90

Rep: Reputation: 15
cannot re-mount /dev when encrypting root partition


Doing a clean install of Slackware 12.0 on my laptop

I followed the instructions in README_CRYPT.TXT from the dvd.

I setup /home encrypted, added the encrypted swap, no problems.

I ran into a problem when trying to finish up the encrypted root partition

In the bottom of the readme it has a link to Alien's page which suggests these options
http://alien.slackbook.org/dokuwiki/...lackware:setup

mount -o bind /proc /mnt/proc
mount -o bind /sys /mnt/sys
mount -o bind /dev /mnt/dev
chroot /mnt


The mounts for /proc and /sys work find but the problem I am having is with mounting /dev

I get this error:

mount: wrong fs type, bad option, bad superblock on /dev, missing codepage or other error
 
Old 07-09-2007, 05:37 PM   #2
sn9ke_eyes
Member
 
Registered: Feb 2003
Location: Texas
Distribution: slackware 11
Posts: 90

Original Poster
Rep: Reputation: 15
well I booted off a sysrescuecd and was able to bind /dev with that cd. still not sure why it didn't work with the slack cd. maybe something with the way the slack cd loads the installer fs ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Possible to do dd if=/dev/hda1 ... and afterwards mount this partition ? Xeratul Linux - General 3 11-18-2006 01:30 AM
How to partition /dev/hde1 as / (root) DaZjorz Linux - Hardware 1 07-16-2005 09:56 AM
can't mount /dev/hda1 (my WindowsXP partition) ZoeNStC Linux - General 3 09-18-2004 12:40 PM
encrypting root partition joulupukki Linux - Security 13 05-12-2004 02:46 AM
how to mount /dev/sda1 not only for root? mizuki26 Linux - Newbie 4 11-04-2003 09:15 PM


All times are GMT -5. The time now is 11:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration