LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware - Installation (http://www.linuxquestions.org/questions/slackware-installation-40/)
-   -   btrfs errors on initial boot following Slackware64-current installation (http://www.linuxquestions.org/questions/slackware-installation-40/btrfs-errors-on-initial-boot-following-slackware64-current-installation-4175457664/)

astanton 04-10-2013 09:59 AM

btrfs errors on initial boot following Slackware64-current installation
 
1 Attachment(s)
I installed Slackware w/LVM as per the instructions on the Slackware DVD on Vmware ESXi 5.1.

I successfully created the initrd as per those instructions to for Linux 3.8.4.

I chose ext4 for /boot and btrfs for / and got the error in the image attached to this post.

What can I do to fix this error, enabling the system to boot?

astanton 04-10-2013 06:41 PM

I guess I shouldn't post in this sub-form ever again
 
Wow. I've never seen such a straight-forward post in a Slackware forum go unanswered for so long.

Now that I know better, I'll never post in the "Slackware - Installation" forum again. That's for sure.

A simple,quick search for btrfs yielded 0 results at the main page of docs.slackware.com too.

Here's the solution:

When presented with the prompt in the pic, enter the root password, then:

Code:

# mount -n -o remount,rw /
# cp /bin/true /sbin/btrfs.fsck

Then edit /etc/fstab and change fs_passno to "0" for all mount points that are btrfs (That's the sixth field).

reboot.

GazL 04-11-2013 09:43 AM

Yes, this is a pretty low visibility subforum. I rarely look in here.
It probably also didn't help that 'btrfs' isn't something that many slackers will have played with yet.

allend 04-11-2013 10:06 AM

Quote:

Wow. I've never seen such a straight-forward post in a Slackware forum go unanswered for so long.

Now that I know better, I'll never post in the "Slackware - Installation" forum again. That's for sure.

A simple,quick search for btrfs yielded 0 results at the main page of docs.slackware.com too.
Oh yeah, no response within 9 hours. Like everybody is running Slackware in Vmware ESXi 5.1 with LVM and btrfs, I don't think.

Feel free to write a SlackDocs page.


All times are GMT -5. The time now is 11:43 PM.