LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices

Reply
 
Search this Thread
Old 10-18-2005, 08:03 AM   #1
dismas
LQ Newbie
 
Registered: Sep 2005
Location: a shack in VT, USA
Distribution: Slackware
Posts: 14

Rep: Reputation: 0
blinking cursor and no more upon startup


Okay, I've gone through the install a couple of times now. I've followed the steps in the 2nd ed. of Slackware linux Essentials. When I get everything installed and remove the cd and hit ctrl-alt-del to restart I get the standard HP blue startup screen and then a blinking cursor up in the upper left of the screen. That's all I get though. I can't enter anything on the keyboard or anything. Just the cursor.

It's an old HP 6545C that I put a new 40G drive into.

Any ideas what I'm doing wrong? I just don't know.

Thanks.
 
Old 10-19-2005, 02:40 AM   #2
nelsonlobo
LQ Newbie
 
Registered: Oct 2005
Posts: 7

Rep: Reputation: 0
Hi

What type of processor( PIV or AMD etc) do you have on your system?
If the slackware version is of i386 (or vice versa)than it will give problems like you mentioned.

Regards
Nelson
 
Old 10-19-2005, 02:41 AM   #3
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 727
Blog Entries: 2

Rep: Reputation: 43
Which boot loader are you using, and where are you installing it (master boot record or on a partition)?

Have you tried using a floppy boot disk?
 
Old 10-19-2005, 08:56 PM   #4
dismas
LQ Newbie
 
Registered: Sep 2005
Location: a shack in VT, USA
Distribution: Slackware
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by nelsonlobo
Hi

What type of processor( PIV or AMD etc) do you have on your system?
If the slackware version is of i386 (or vice versa)than it will give problems like you mentioned.
Intel Celeron 500 Megahertz (MHz) processor. The Slackware is the new 10.2.
 
Old 10-19-2005, 08:58 PM   #5
dismas
LQ Newbie
 
Registered: Sep 2005
Location: a shack in VT, USA
Distribution: Slackware
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by ciotog
Which boot loader are you using, and where are you installing it (master boot record or on a partition)?

Have you tried using a floppy boot disk?
LILO and it's on the root partition (if I understand the question since I'm a newb).

The floppy drive started making horrible noises when I started up the computer so it's been disconnected.
 
Old 10-19-2005, 10:38 PM   #6
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 727
Blog Entries: 2

Rep: Reputation: 43
Does the partition where you've installed lilo have the "bootable" flag set? If you're not dual-booting (and even if you are) I would recommend instead to install to the mbr - just change the line
Code:
boot="/dev/hda?"
in /etc/lilo.conf (where the ? is the partition number) to simply
Code:
boot="/dev/hda"
and then rerun /sbin/lilo to reinstall lilo. If you're not even getting to lilo on boot, then it hasn't been installed where it can be seen.
 
Old 10-23-2005, 11:31 AM   #7
dismas
LQ Newbie
 
Registered: Sep 2005
Location: a shack in VT, USA
Distribution: Slackware
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by ciotog
I would recommend instead to install to the mbr - just change the line
The partition did have the bootable flag set. I'm re-installing everything again today. I understood what you had told me to do but I have no idea how to do it. I'm at the part of the install where it asks where I want LILO installed. The third, MBR, option has "(possibly unsafe)" next to it but I'll give it a shot I guess.

And no, I'm not dual booting. Linux will be the only OS on this system.
 
Old 10-23-2005, 11:39 AM   #8
dismas
LQ Newbie
 
Registered: Sep 2005
Location: a shack in VT, USA
Distribution: Slackware
Posts: 14

Original Poster
Rep: Reputation: 0
Talking

Woot!! I got past the damn blinking cursor!!!!

It actually started up and I'm now staring at the prompt: root@darkstar:~# and wondering what to do now!

Thanks for the help!!

I guess now it's time to go
 
Old 10-23-2005, 11:42 AM   #9
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 727
Blog Entries: 2

Rep: Reputation: 43
If you're not dual booting then there's no risk at all installing LILO in the MBR. It's only unsafe when you're dual-booting and the other OS requires their own boot loader to be there.
 
Old 10-23-2005, 12:04 PM   #10
dismas
LQ Newbie
 
Registered: Sep 2005
Location: a shack in VT, USA
Distribution: Slackware
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by ciotog
If you're not dual booting then there's no risk at all installing LILO in the MBR. It's only unsafe when you're dual-booting and the other OS requires their own boot loader to be there.
Ah, okay, that makes sense. The "unsafe" warning pretty much made me shy away from actually attempting it.
 
Old 10-23-2005, 12:09 PM   #11
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
Quote:
Originally posted by dismas
Woot!! I got past the damn blinking cursor!!!!
Type xwmconfig and choose a desktop. Then type startx and enjoy the desktop.
 
Old 10-23-2005, 11:42 PM   #12
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 727
Blog Entries: 2

Rep: Reputation: 43
...After creating a user and logging in as that user, that is
 
Old 11-12-2005, 01:09 PM   #13
davidh_R
LQ Newbie
 
Registered: May 2005
Posts: 5

Rep: Reputation: 0
Im having this same problem, and i remember installing lilo to the superblock. Im not dual booting and i did set the boot flag. Im thinking that i need to install the boot info on the mbr. How do i go about changing that, without going through the entire inatallation process? I can boot from the install cd, and i didnt make a floppy when i was prompted during the install.

Last edited by davidh_R; 11-12-2005 at 01:18 PM.
 
Old 11-13-2005, 02:14 AM   #14
ciotog
Member
 
Registered: Mar 2004
Location: Canada
Distribution: Slackware current
Posts: 727
Blog Entries: 2

Rep: Reputation: 43
If you can boot from the installation cd you should be able to mount the root partition somewhere (/mnt/linux for example), chroot to /mnt/linux, edit /etc/lilo.conf to tell it to install in the mbr (by changing the boot= option as mentioned above), run /sbin/lilo then reboot.

Or you can go through the setup process again, but skip the package installation step.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
grub (blinking cursor) - won't boot php4u Fedora - Installation 2 04-04-2005 10:23 AM
FC3 install hangs with blinking cursor Ericccarlson Fedora - Installation 1 03-30-2005 10:11 AM
Blank screen with blinking cursor on boot (yoper) Fisslefink Linux - Newbie 3 02-15-2005 05:16 PM
aterm blinking cursor siskel Linux - General 0 10-31-2004 09:56 PM
slowing down blinking cursor jester_69 Linux - General 0 02-25-2004 06:43 PM


All times are GMT -5. The time now is 07:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration