LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices

Reply
 
Search this Thread
Old 10-20-2008, 04:35 AM   #1
jowa45
Member
 
Registered: Apr 2007
Location: Stockholm, Sweden
Distribution: Slackware11&12
Posts: 94

Rep: Reputation: 15
Blackbox goes into limbo


When Slackware 12 was released I installed it in an oldish (1998) laptop with somewhat limited capacity.
At that time I only needed and installed the tty stuff (a ap d e ) and have been using it regularly.

Yesterday I thought I would like to try the blackbox window manager and I
installed everything in x and blackbox in xap.
I changed that link in/etc/X11/xinit from the default kde to blackbox.

On the command startx I see a quick flash of that Xauthority text.
Then the whole thing goes into limbo.
No response whatsoever from mouse or keyboard.
All I see is a blank screen.
If I switch off and start again it still works perfectly well as a tty only machine.

What have I missed ?

Any help on x-server fault finding appreciated.

Also maybe it was not necessary to install all of x.
What packages are needed just to get blackbox running?

John

Last edited by jowa45; 10-20-2008 at 04:43 AM.
 
Old 10-20-2008, 11:02 PM   #2
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 11,215
Blog Entries: 3

Rep: Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437Reputation: 1437
Hi,

You did run the 'xorgconfig'? You can 'man xorgconfig' to get a better understanding of the command.
 
Old 10-21-2008, 08:11 AM   #3
jowa45
Member
 
Registered: Apr 2007
Location: Stockholm, Sweden
Distribution: Slackware11&12
Posts: 94

Original Poster
Rep: Reputation: 15
I will try xorgconfig this evening.
The manual is not exactly verbose.
I might not know all the answers.

Yesterday evening I tried X -configure.
It gave me a configuration file and encouraged me to try
X -config /root/xorg.conf.new but it only went into limbo again.

As I installed all of x I could also try twm.

John
 
Old 10-21-2008, 08:26 AM   #4
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,177

Rep: Reputation: 541Reputation: 541Reputation: 541Reputation: 541Reputation: 541Reputation: 541
If xorgconfig is confusing for you I suggest that you try xorgsetup. xorgsetup will automatically generate xorg.conf for you and set-up x windows for you. If that fails you can try to manually edit xorg.conf (see below).

# nano /etc/X11/xorg.conf

You can run # xwmconfig to change the environment that you use (KDE, Blackbox, etc., depending on the environments that you've installed of course)
 
Old 10-23-2008, 06:52 AM   #5
jowa45
Member
 
Registered: Apr 2007
Location: Stockholm, Sweden
Distribution: Slackware11&12
Posts: 94

Original Poster
Rep: Reputation: 15
After trying a few of these tools I settled for this one :-

Code:
xorgcfg -textmode
This gave an easy to use menu.
It stayed in tty.

After a lot of trial and error I found something that did not go into limbo.

However it did not startx.
It gave up with the famous last words :-

Quote:
Fatal server error:
could not open default font 'fixed'
X.org Foundation list this as by far the most popular FAQ.

Comparing it with another Slackware installation which works I dont see the difference.

This is the first time I have had to look at X.
Always worked out of the box before.

Anyone know how to read those font.alias files?
What font is fixed looking for?

John

Edit
Seems a few others have had this type of problem recently.
Will be trying ideas posted by keefaz.

Last edited by jowa45; 10-23-2008 at 10:47 AM.
 
  


Reply

Tags
blackbox, xserver


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I am in A LIMBO HERE..Please help as400 Solaris / OpenSolaris 1 07-23-2006 09:23 AM
WINDOWS in ncurses, newwin limbo Nevion Programming 6 12-10-2003 12:20 AM
red hat limbo ronss Linux - Distributions 2 09-03-2002 05:14 PM
Limbo beta mikeshn Linux - Distributions 2 08-26-2002 02:18 AM
Red Hat 8.0 Limbo? mikeshn Linux - General 1 07-25-2002 10:17 PM


All times are GMT -5. The time now is 05:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration