LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices



Reply
 
Search this Thread
Old 12-07-2013, 05:37 AM   #1
Captain Pinkeye
Member
 
Registered: Oct 2012
Location: The Czech Republic
Posts: 201

Rep: Reputation: Disabled
14.1 installler bugs


1) The new font is, well, new. It has problem with non-ASCII (us-acentos keymap, see attached). Nobody checked this? Really? The installed system uses the old style cli font that works well, so i don't understand why the installer changed this.

2) My main gripe. When i select the categories to install, then 'expert', i can move through each category to fine tune the packages. The problem is (and is there since at least 13.37), the Cancel button doesn't cancel. It just happily continues and then starts to install, just like the 'OK' button does.

I take it as the advantage of unstable buggy distros that forces you to reinstall each month - their installer is thoroughly checked.
Attached Images
File Type: png Slackware-intl.png (4.0 KB, 29 views)

Last edited by Captain Pinkeye; 12-07-2013 at 05:38 AM. Reason: clarification
 
Old 12-07-2013, 06:47 PM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad W520
Posts: 4,680

Rep: Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240Reputation: 1240
1) It's hard to say what went wrong not knowing which character should have been displayed instead of the little black square. For your information, depending on usage of KMS or not at boot time, font loaded is either /usr/share/kbd/consolefonts/ter-120b.psf.gz or /usr/share/kbd/consolefonts/ter-c14v.psf.gz. The first one maps iso01, iso15 and cp1252 that cover ISO8859-1, ISO8859-15, Windows-1252 codepages, the second one cp1251, iso05 that cover Windows-1251, ISO8859-5 codepages. You can check yourself the presence of the glyph for the character you want to display loading the font (if not already done) then typing "showconsolefont" on the console. Also, AFAIK all characters you need to type during installation are printable ASCII ones anyway.

Last edited by Didier Spaier; 12-08-2013 at 04:58 AM.
 
Old 12-08-2013, 05:29 AM   #3
drmozes
Slackware Contributor
 
Registered: Apr 2008
Location: Surrey, England
Distribution: Slackware
Posts: 179

Rep: Reputation: 145Reputation: 145
Quote:
Originally Posted by Captain Pinkeye View Post
1) The new font is, well, new. It has problem with non-ASCII (us-acentos keymap, see attached). Nobody checked this? Really? The installed system uses the old style cli font that works well, so i don't understand why the installer changed this.

2) My main gripe. When i select the categories to install, then 'expert', i can move through each category to fine tune the packages. The problem is (and is there since at least 13.37), the Cancel button doesn't cancel. It just happily continues and then starts to install, just like the 'OK' button does.

I take it as the advantage of unstable buggy distros that forces you to reinstall each month - their installer is thoroughly checked.
To work around it, boot with the kernel parameter 'nofont' which you can enter at the ISOLINUX Boot prompt.
 
Old 12-09-2013, 12:02 PM   #4
Captain Pinkeye
Member
 
Registered: Oct 2012
Location: The Czech Republic
Posts: 201

Original Poster
Rep: Reputation: Disabled
Thank you guys for your response, and both for the detailed info and the tip.
It has problems with umlaut characters, like and , i didn't try any other special characters. It is true that it doesn't affect the installation itself or the installed system, but i still think it is bug/oversight, so i reported it too.

My main concern is the "Cancel button that doesn't cancel". I encounter it continually during my adventures with Slackware, yet no one ever mentioned it anywhere (as far as i can see), so i decided to post. The installer doesn't feel very robust with this sort of thing.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
i have the bugs Premananth Linux - Server 2 09-14-2012 05:11 AM
Bugs EYEdROP Linux - General 1 11-07-2007 09:50 AM
is it bugs?????? please help me take a look. hackintosh Suse/Novell 0 10-03-2007 04:42 AM
Getting black screen when FC5 x86-64 graphical installler starts X on my laptop johnemb Fedora - Installation 12 05-20-2006 09:54 AM
installler shell script nirav.jani Programming 1 09-27-2005 10:23 PM


All times are GMT -5. The time now is 06:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration