LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware - ARM (http://www.linuxquestions.org/questions/slackware-arm-108/)
-   -   Installing SlackARM 14.1 on Raspberry Pi (model B, NOT Micron) (http://www.linuxquestions.org/questions/slackware-arm-108/installing-slackarm-14-1-on-raspberry-pi-model-b-not-micron-4175494904/)

andrixnet 02-14-2014 08:21 AM

Installing SlackARM 14.1 on Raspberry Pi (model B, NOT Micron)
 
I am trying to install SlackwareARM on my RaspberryPI, which is model B purchased in dec.2012 (so it's not the Micron variant).

I am trying to use the instructions and files from FatDog here: http://rpi.fatdog.eu/index.php?p=home as they seem to be the most up to date.

Unfortunately I haven't had any luck.
The image (rpi-slackwarearm-install_17Jan14_fd.img.xz) fails to boot.
On power on, the power led is on, the ACT led flashes only once, the TV screen stays black.
I have tried several SD cards.
My target SDcard is a Sandisk Ultra SDHC class 10, 16GB, which is among the confirmed well working cards.

Raspbian images work fine, tested with an early 2013 image and with the current image from their website: http://www.raspberrypi.org/downloads
(2014-01-07-wheezy-raspbian.zip)

A 14.0 full install image from Stanley Garvey did work for me some months ago, but I do want to make my own installation, and make it 14.1.

I have tried looking here: http://elinux.org/R-Pi_Troubleshooti...ecific_pattern but nothing seems to apply. (mine is not Micron).

I got the files from here https://github.com/raspberrypi/firmw...ee/master/boot and replaced them one by one on the boot partition. The bootcode.bin is the only one identical in the FatDog image and from github.
I replaced the .dat and .elf files, tried, then replaced the kernel as well, tried, nothing. Not even the rainbow screen.

I got the *.dat *.elf and kernel files from the current raspbian image and put them on my card. Still nothing.
(ok, the kernel modules from initrd would mismatch, but that should be an error at a later stage).

I recreated the initrd.gz with modules and firmware from raspbian, still nothing. (since it doesn't boot at all, the problem surely isn't there.)

Next I'll try to patch in the slackware miniroot into the raspbian sd, but still, why doesn't it boot?

andrixnet 02-14-2014 11:15 AM

Well, this is kinda embarrasing.
Actually it does work. I am using a TV connected via composite input.

In Raspbian config.txt :
Code:

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

In FatDog's image, config.txt :
Code:

hdmi_force_hotplug=1
I commented this line and rebooted. It worked!

In the guide it says:
Quote:

a monitor/tv/screen to display output via HDMI or RCA video socket with the relevant cable(s).
I have found nothing indicating that editing of this file might be required at this stage.
(the config.txt in this image, not in general).

@FatDog: Please update your guide at this stage: http://rpi.fatdog.eu/index.php?p=sdconfig and say that in config.txt
Code:

hdmi_force_hotplug=1
may need commenting if one uses composite video output instead of HDMI, when using the boot image needed to perform installation process.

@FatDog: Thank you for your in depth guide to slackware on the RPI.

andrixnet 02-14-2014 01:11 PM

One more thing:

Upon finishing installation, removing the uneeded kernels and installing /raspi-extra/kernel* /raspi-extra/raspi* results in yet again a config.txt that has hdmi_force_hotplug=1

So my freshly installed PI rebooted and started properly, only with no signal on the composite output.

So I connected to it over the network and commented the line.

@FatDog: the package installer (doinst.sh) that contains config.txt in raspi-extra should place the file as config.txt.new and check rather then overwrite.

@FatDog: sorry to write here, I tried to register on the forums at fatdog.eu, but I kept getting the registration form even though I filled out all the fields.

andrixnet 02-14-2014 03:32 PM

Thanks FatDog, Dave, Stanlez Garvez and everzone else that made Slackware on the PI possible.

andrixnet 02-15-2014 01:49 AM

RPiconfig - eLinux.org
Quote:

hdmi_force_hotplug Pretends HDMI hotplug signal is asserted so it appears a HDMI display is attached

Code:

hdmi_force_hotplug=1 Use HDMI mode even if no HDMI monitor is detected

So indeed, the config said use HDMI output regardless.
That is why I saw nothing on the composite and the little data loaded by booting this image is why the ACT led flashed so little.

Exaga 09-15-2014 07:01 AM

Quote:

Originally Posted by andrixnet (Post 5118059)
RPiconfig - eLinux.org

So indeed, the config said use HDMI output regardless.
That is why I saw nothing on the composite and the little data loaded by booting this image is why the ACT led flashed so little.

hdmi_force_hotplug=1

This setting comes from a time when the Raspberry Pi refused to boot unless there was a hdmi cable detected - and was subsequently patched in later firmware revisions. Itīs no longer required for the Slackware ARM installer we provide on fatdog.eu so I apologise for your slight headaches over the issue which you have experienced. This setting will be removed in the next installer we release.

frushiyama 09-23-2014 07:56 PM

[wrong post]
Sorry, please delete


All times are GMT -5. The time now is 05:19 AM.