LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM
User Name
Password
Slackware - ARM This forum is for the discussion of Slackware ARM.

Notices


Reply
  Search this Thread
Old 12-21-2016, 06:57 AM   #1
ag33k
Member
 
Registered: Mar 2013
Location: Portugal
Distribution: Slackware
Posts: 65

Rep: Reputation: Disabled
"Give root password for maintenance or press CTRL+D to continue" problem enter root password


Hello,

I had seen this message a lot of times on Slackware and now in SlackwareARM:

"Give root password for maintenance or press CTRL+D to continue"

When I enter the root password it doesn't work! Never worked!

I think is a problem with my keyboard layout. Maybe isn't configured at that time.

In Slackware isn't a big problem.

I always have USB pen drive with Slackware on it, with me. I boot from the USB pen drive and use fsck and problem solved.

But in SlackwareARM I can't do this! Or at least I don't know how to do it.

There is any way to solve this?

Or I have to search a way to boot from an USB pen drive in my RPi just to solve this sort of things?
 
Old 12-21-2016, 07:57 AM   #2
glorsplitz
Member
 
Registered: Dec 2002
Distribution: slackware!
Posts: 434

Rep: Reputation: 75
"Give root password for maintenance or press CTRL+D to continue"

What was going on with your system when this message appeared. Was system in X, command line, booting?
 
Old 12-21-2016, 10:41 AM   #3
ag33k
Member
 
Registered: Mar 2013
Location: Portugal
Distribution: Slackware
Posts: 65

Original Poster
Rep: Reputation: Disabled
Sorry about the lack of details!

It is a problem with fsck at boot.

It started booting and checking one of my sdcard partitions but it didn't finished.
And I received that message.
I entered the root password and nothing happened!

In Slackware I already experienced the same problem with fsck. And I use a Slackware Install USB pen drive.

In SlackwareARM I removed the card and made the fsck in other computer using a micro SD card reader.

I think the problem is that the keyboard layout is not configured at the time. And because of that I can't enter my root password correctly.

BTW: This RPi is a RPi 3.
 
Old 12-21-2016, 11:09 AM   #4
hazel
Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: Debian, Crux, LFS, AntiX, NuTyX
Posts: 919

Rep: Reputation: 390Reputation: 390Reputation: 390Reputation: 390
I notice that you're Portuguese. Presumably you use a native keymap, but at this stage the startup scripts are expecting a standard US keyboard. I can think of two possible ways round this:

1) Set the console keymap to be US but use Portuguese in X, where I assume you do most of your work.
2) Learn the US mapping of your root password and use that.
 
Old 12-21-2016, 01:24 PM   #5
Penthux
Member
 
Registered: Dec 2008
Location: Middlesbrough, UK
Distribution: Slackware
Posts: 137

Rep: Reputation: 32
Quote:
Originally Posted by hazel View Post
I notice that you're Portuguese. Presumably you use a native keymap, but at this stage the startup scripts are expecting a standard US keyboard. I can think of two possible ways round this:

1) Set the console keymap to be US but use Portuguese in X, where I assume you do most of your work.
2) Learn the US mapping of your root password and use that.
Would specifying "kbd=pt" in the 'cmdline.txt' file before booting also achieve this? Better destructions: http://sarpi.fatdog.eu/index.php?p=preinstall
 
Old 12-21-2016, 02:42 PM   #6
drmozes
Slackware Contributor
 
Registered: Apr 2008
Location: Surrey, England
Distribution: Slackware
Posts: 509

Rep: Reputation: 388Reputation: 388Reputation: 388Reputation: 388
Quote:
Originally Posted by Penthux View Post
Would specifying "kbd=pt" in the 'cmdline.txt' file before booting also achieve this? Better destructions: http://sarpi.fatdog.eu/index.php?p=preinstall
No because that is not an official Kernel parameter (linux-x.x.x/Documentation/kernel-parameters.txt): it's set as a helper for the installer.
Also the key map is not loaded by rc.keymap until rc.M - fsck is run in rc.S.

You could boot back in to the installer to fix this.

Last edited by drmozes; 12-21-2016 at 02:49 PM.
 
Old 12-21-2016, 06:07 PM   #7
Penthux
Member
 
Registered: Dec 2008
Location: Middlesbrough, UK
Distribution: Slackware
Posts: 137

Rep: Reputation: 32
Quote:
Originally Posted by drmozes View Post
No because that is not an official Kernel parameter (linux-x.x.x/Documentation/kernel-parameters.txt): it's set as a helper for the installer.
Also the key map is not loaded by rc.keymap until rc.M - fsck is run in rc.S.

You could boot back in to the installer to fix this.
Ah, my bad. I must admit I've got installers on the brain lately.
 
Old 12-23-2016, 03:19 AM   #8
louigi600
Member
 
Registered: Dec 2013
Location: Italy
Distribution: Slackware
Posts: 471
Blog Entries: 12

Rep: Reputation: 43
On slackwarearm rc.keymap is executed from rc.M and it defaults to UK map while the fsck stuff is done from rc.S.
I suppose you could force a
Code:
/usr/bin/loadkeys pt.map
somewhere in rc.S before the fsck stuff is done.
 
Old 01-04-2017, 07:45 PM   #9
ag33k
Member
 
Registered: Mar 2013
Location: Portugal
Distribution: Slackware
Posts: 65

Original Poster
Rep: Reputation: Disabled
The easiest solution that I could find:

Get an US keyboard and plug it on a USB port just for this!

Unplugged it after the fsck is done!
 
Old 01-12-2017, 04:23 PM   #10
SCerovec
Senior Member
 
Registered: Oct 2006
Location: Cp6uja
Distribution: Slackware on x86 and arm
Posts: 1,069
Blog Entries: 2

Rep: Reputation: 126Reputation: 126
and there are quite handy USB to wireless keyboards that fit in a pocket these days
with a sweep-pad even!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Give root password for maintenance (or type control-D to continue) rutacele Linux - Newbie 3 12-04-2012 09:40 AM
Give root password for maintenance mijohnst Linux - General 5 12-29-2010 10:07 AM
Error Message "Press Ctrl+d or provide root password coolinux Linux - Newbie 5 09-01-2009 09:20 AM
where is the "enter root password or Contrl-D to continue" after FS repair at boot jg167 Red Hat 0 11-17-2004 01:20 AM


All times are GMT -5. The time now is 12:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration