LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-09-2004, 02:42 PM   #1
KingofBLASH
Member
 
Registered: Sep 2003
Distribution: Just upgraded to Slackware 10.0
Posts: 91

Rep: Reputation: 15
ZAxisMapping under Slackware 10.0 doesn't work


I have tried using the line:

Option "ZAxisMapping" "4 5"
and then I tried
Option "ZAxisMapping" "Y"
(but never at the same time)

in the Section "InputDevice" of the following x.org config files:
/etc/X11/xorg.conf
/etc/X11/xorg.conf-fbdev
/etc/X11/xorg.conf-vesa

Currently I put those lines in all three, yet my scroll wheel still doesn't work. According to the log in /var/log/Xorg.0.log it's using the config file "/etc/X11/xorg.conf"

Anybody know how to get my scroll wheel working?

Also, anybody know how to change the screen resolution? I used xorgsetup to set up my card automatically, and all of a sudden I'm using 1600x1200 resolution versus my comfortable 1280x1024
 
Old 09-09-2004, 02:46 PM   #2
Jaster150
LQ Newbie
 
Registered: Sep 2004
Distribution: Slackware
Posts: 29

Rep: Reputation: 15
you have a 7 button mouse I assume? that is, wheel and 2 side buttons. If so, add change your xorg.conf to read:

Option "Buttons" "7"
Option "ZAxisMapping "6 7"

save, restart x and you should be good. If not, in command line run xmodmap -e "pointer = 1 2 3 6 7 4 5"

to get the side buttons to work I use imwheel, I don't have the site offhand but you can google it. Check this forum for how to set that up.
 
Old 09-09-2004, 02:48 PM   #3
kodon
Member
 
Registered: Jul 2004
Location: [jax][fl][usa]
Distribution: Slackware64-current
Posts: 796

Rep: Reputation: 31
make sure you are using the correct protocol
 
Old 09-09-2004, 02:49 PM   #4
Jaster150
LQ Newbie
 
Registered: Sep 2004
Distribution: Slackware
Posts: 29

Rep: Reputation: 15
Quote:
Originally posted by kodon
make sure you are using the correct protocol
Good point. I use an intellimouse explorer but I find that "ImPS/2" and "ExplorerPS/2" don't work too well for me so I just use "auto" and it works fine.
 
Old 09-09-2004, 03:06 PM   #5
folkenfanel
Member
 
Registered: Sep 2004
Location: formerly Fanelia and Zaibach
Distribution: Slackware-current with KDE 4.8.5
Posts: 301

Rep: Reputation: 35
Lightbulb change resolution

Hi

You can also modify the resolution manually by messing up with the x.org config file:

in the section "screen" you should see (basically) resolutions for different color depths (e.g. for 8, 16, 24...). There you have to look for the depth you use, and delete the ugly part ("1600x1200"). The first one in the line is the "standard" one for that color depth so you can also put 1024x768 first and it will run first.

OR

you can always run xorgconfig and modify it interactively (but i'm not sure whether after that you will need to reconfigure your mouse).
 
Old 09-21-2004, 09:17 PM   #6
Dswissmiss
Member
 
Registered: Mar 2004
Location: New York
Distribution: Gentoo, xubuntu
Posts: 91

Rep: Reputation: 15
Has this been solved yet? I just switched back from gentoo, and I can't get my wheel to work either. I used to use IMPS/2, /dev/psaux, and ZAxisMapping 4 5 to get it to work.

any ideas?
 
Old 09-21-2004, 09:29 PM   #7
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "Buttons" "5"
Option "ZAxisMapping" "4 5"

That works for me (Microsoft 1.1a).
Read for a similar thread some days ago about a logitech mx mouse where he had 7 buttons.

Last edited by gbonvehi; 09-21-2004 at 09:31 PM.
 
Old 09-21-2004, 10:01 PM   #8
Dswissmiss
Member
 
Registered: Mar 2004
Location: New York
Distribution: Gentoo, xubuntu
Posts: 91

Rep: Reputation: 15
Hey cool!
Thanx a lot
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cant get slackware to work... Du_chef Linux - Newbie 6 11-15-2005 04:30 PM
"ZAxisMapping" numbers Slaxx Linux - Software 4 11-06-2004 06:13 PM
ZAxisMapping does not work in slackware 10 Timeturtle Slackware 12 08-21-2004 06:33 AM
Option "ZAxisMapping" "4 5" won't work apax Linux - Hardware 7 11-06-2003 09:41 AM
Roller mouse ZAxisMapping jamaso Linux - Newbie 9 12-19-2001 09:43 PM


All times are GMT -5. The time now is 06:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration