LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 08-18-2004, 09:46 PM   #1
Timeturtle
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 42

Rep: Reputation: 15
ZAxisMapping does not work in slackware 10


I just got a new computer and installed slackware 10 on it. I had slackware 10 installed on my old computer with no problem. I get everything up and running and I add the option "ZAxisMapping" "4 5" to my xorg.conf and expect it to make my scroll mouse work fine, but for the first time ever, ZAxisMapping does nothing. I am extremely confused as to why this is not working. Any info on how to get my scroll wheel working would be greatly appreciated. It is a logitech wheel mouse if that helps anyone.

Thanks.
 
Old 08-18-2004, 09:54 PM   #2
Zcat
LQ Newbie
 
Registered: Aug 2004
Distribution: SlackWare 10.0
Posts: 9

Rep: Reputation: 0
Did you change your proto to "IMPS2" because Slack will set it to "PS2!

See this == /http://img.photobucket.com/albums/v336/nixfreek/snapshot1.png
 
Old 08-18-2004, 11:41 PM   #3
Mephisto
Member
 
Registered: Oct 2002
Location: Washington D.C, USA
Distribution: Slack 12, Etch, Gutsy
Posts: 453

Rep: Reputation: 30
Quote:
Originally posted by Zcat
Did you change your proto to "IMPS2" because Slack will set it to "PS2!

See this == /http://img.photobucket.com/albums/v336/nixfreek/snapshot1.png
That should read IMPS/2 I believe (missing the slash)

Cheers

EDIT: Picture is right though.

Last edited by Mephisto; 08-18-2004 at 11:44 PM.
 
Old 08-19-2004, 10:21 AM   #4
Nikon01
Member
 
Registered: Jul 2003
Distribution: Slackware 10.0
Posts: 196

Rep: Reputation: 30
Also you may need to addthe line:

Option "Buttons" "5"

I know I had to. If that doesn't make it work I have no clue as to what will....
 
Old 08-19-2004, 10:27 AM   #5
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 74
If IMPS/2 doesn't work, you may have to try auto. I've noticd that on some distros I have to choose "Auto" as the protocol and on others "IMPS/2" to make the same mouse work.
 
Old 08-19-2004, 08:46 PM   #6
Timeturtle
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 42

Original Poster
Rep: Reputation: 15
After it didnt work, I checked and changed the protocol to IMPS/2, and that still did nothing. I added the Buttons "5" and that also did nothing. I havent tried auto, and I will do that next. I have used Slackware dozens of times, and this is the first time it hasnt worked. Btw, I am using xorg.conf instead of xfree86. Maybe x.org has some different means of getting it to work, i dont know. It shouldnt, because zaxismapping has worked for me on xorg before.

Thanks for all the fast replies.
 
Old 08-19-2004, 08:56 PM   #7
Mephisto
Member
 
Registered: Oct 2002
Location: Washington D.C, USA
Distribution: Slack 12, Etch, Gutsy
Posts: 453

Rep: Reputation: 30
Can you post your mouse InputDevice section from xorg.conf?
 
Old 08-19-2004, 10:05 PM   #8
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Rep: Reputation: 46
I had this issue with a fresh install on my laptop. It's not a logitech mouse, but built-in track-button (eraser style) with a couple of buttons for the up and down, versus a wheel.

It worked great in slack 9.0, 9.1, but when I got 10 on there, the same settings I'd always used didn't take for some reason.

So I dug up an old backup copy of an XF86Config-4 file that I had on this laptop before, renamed it to xorg.conf, and the wheel started working again. I took a close look, and besides some commented out sections -- the two input device sections for the mouse were identical! I couldn't explain it. Here's my working section, though.

Code:
Section "InputDevice"

    Identifier  "Mouse1"
    Driver      "mouse"
    Option "Protocol"    "IMPS/2"
    Option "ZAxisMapping" "4 5"

    Option "Device"      "/dev/mouse"
#   Option "Device"      "/dev/psaux"

EndSection
And this is the one that works for my desktop, with a logitech USB wheel mouse. I never encountered the problem on that machine.

Code:
Section "InputDevice"

# Identifier and driver

    Identifier  "Mouse1"
    Driver "mouse"
    Option "Protocol"   "ImPS/2"
    Option "ZAxisMapping"   "4 5"
    Option "Device"     "/dev/mouse"
EndSection
And yes, ImPS/2 does have a lowercase m there, instead of the uppercase M everyone seems to think is important.

Maybe these will help you.

--Shade

edit to add:
I just remembered a weird incident I had two years ago when first trying to set up X on a new machine... For some reason, the configfile had "ghost returns" or lots of extra space at the end of some lines, which for some reason, through a bug I guess, caused the lines to be ignored. On a reallll long shot, check to make sure the line ends right at the last character and there's no empty space at the end. I think I introduced that problem because of crossing file types -- I had downloaded the config file onto a windows machine, put it onto a floppy, and transferred it to my linux box. I think windows uses different control characters by default which might have done it.


Last edited by Shade; 08-19-2004 at 10:09 PM.
 
Old 08-20-2004, 10:56 PM   #9
Timeturtle
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 42

Original Poster
Rep: Reputation: 15
I have reformatted and reinstalled slackware, and this problem still exists. I have tried every type of protocol available and made very sure that my xorg.conf is correct.
Code:
Section "InputDevice"

# Identifier and driver

    Identifier  "Mouse1"
    Driver      "mouse"

    Option "ZAxisMapping" "4 5"

# On platforms where PnP mouse detection is supported the following
# protocol setting can be used when using a newer PnP mouse:

    Option     "Protocol"      "IMPS/2"
    Option "Device"      "/dev/mouse"

EndSection
I have used this configuration hundreds of times, but it will just not work on this computer.

Last edited by Timeturtle; 08-20-2004 at 10:58 PM.
 
Old 08-21-2004, 12:31 AM   #10
mago
Member
 
Registered: Apr 2004
Location: Costa Rica
Distribution: slack current with 2.6.16.18 (still off the hook)
Posts: 284

Rep: Reputation: 33
I'm running Slack 10, fresh install, this is what I added to the xorg.conf to get the wheel going....

will read like this:
Code:
Option "Protocol"    "IMPS/2"
    Option "ZaxisMapping" "4 5"
    Option "Buttons"  "3"
 
Old 08-21-2004, 02:00 AM   #11
endfx
Member
 
Registered: May 2003
Location: Canada
Distribution: Debian
Posts: 105

Rep: Reputation: 15
The only thing I can suggest is to change the order of you options, for instance put the protocal before the ZAxisMapping:

Code:
Section "InputDevice"

# Identifier and driver

    Identifier  "Mouse1"
    Driver      "mouse"   
    Option     "Protocol"      "IMPS/2"
    Option "Device"      "/dev/mouse"

    Option "ZAxisMapping" "4 5"

# On platforms where PnP mouse detection is supported the following
# protocol setting can be used when using a newer PnP mouse:

EndSection
Another thing you might wanna check out is the Emulate3Buttons option. It should be commented out:

Code:
#    Option "Emulate3Buttons"
#    Option "Emulate3Timeout"    "50"
At least it is on mine, and it seems to be working.
 
Old 08-21-2004, 04:38 AM   #12
major.tom
Member
 
Registered: Jun 2003
Location: Canada
Distribution: Slackware (current); Gentoo (newbie)
Posts: 142

Rep: Reputation: 15
Here's a silly question, but what does `ls -l /dev/mouse` give you?

Garry
 
Old 08-21-2004, 07:33 AM   #13
AxeZ
Member
 
Registered: Sep 2002
Location: Novi Sad, Vojvodina
Distribution: Slackware, FreeBSD
Posts: 386

Rep: Reputation: 32
Quote:
Originally posted by major.tom
Here's a silly question, but what does `ls -l /dev/mouse` give you?

Garry

Exactly I was going to ask that.
if it's USB rat it should point to /dev/input/mice
if PS/2 , should point to /dev/psaux
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cant get slackware to work... Du_chef Linux - Newbie 6 11-15-2005 05:30 PM
"ZAxisMapping" numbers Slaxx Linux - Software 4 11-06-2004 07:13 PM
ZAxisMapping under Slackware 10.0 doesn't work KingofBLASH Slackware 7 09-21-2004 11:01 PM
Option "ZAxisMapping" "4 5" won't work apax Linux - Hardware 7 11-06-2003 10:41 AM
Roller mouse ZAxisMapping jamaso Linux - Newbie 9 12-19-2001 10:43 PM


All times are GMT -5. The time now is 07:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration