LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-22-2010, 09:27 AM   #1
matters
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 281

Rep: Reputation: Disabled
youtube flash problem firefox 3.6.12


Hi guys! I installed flashplayer-plugin from alienbob repository. for some reason when i watch youtube video any it loads slow. but in normal window it can play but if i want to switch to full screen after a while firefox instance closed, and i tried to open also specific youtube channel that i used to browse, now firefox tries to load the page but firefox also closes.

before it used to work normally. how can i figure out what causes the problem?

thank you very much!
 
Old 11-22-2010, 11:45 AM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,373

Rep: Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557
Open firefox, set as url "aboutlugins" and hit return.
Flash has a version number What is it?
The version that solved it for me (in 32 bit) Shockwave Flash 10.1 r82
I get no video in fullscreen on 64 bit for some sites - youtube is ok, but rte.ie/player is not.

BTW, there is also youtube-dl, which is a script to download the movie. You can than attack it with mplayer with more choice & fewer issues.
 
Old 11-22-2010, 01:37 PM   #3
matters
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 281

Original Poster
Rep: Reputation: Disabled
File: libflashplayer.so
Version:
Shockwave Flash 10.1 r82

my glxgears reports me very slow frames around 300 max
and before it was around 1400
 
Old 11-22-2010, 01:49 PM   #4
eSelix
Senior Member
 
Registered: Oct 2009
Location: Wroclaw, Poland
Distribution: Arch, Kubuntu
Posts: 1,218

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
Check your graphics drivers. If they are loaded in Xorg.0.log Do you use Compiz or similar software?

Last edited by eSelix; 11-22-2010 at 01:50 PM.
 
Old 11-22-2010, 04:16 PM   #5
matters
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 281

Original Poster
Rep: Reputation: Disabled
when i create xorg.conf with xorgsetup driver module loads successfuly
but heres the message im concerned
Code:
glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
257 frames in 5.0 seconds = 51.397 FPS
299 frames in 5.0 seconds = 59.614 FPS
301 frames in 5.0 seconds = 60.012 FPS
301 frames in 5.0 seconds = 60.013 FPS
ive never expirienced yet Running synchronized to the vertical refresh msg im wondering if this is normal? how to fix this?

no i dont use compiz

Last edited by matters; 11-22-2010 at 05:47 PM.
 
Old 11-23-2010, 03:25 AM   #6
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,373

Rep: Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557
51-60 fps from glxgears is shameful. Your monitor probably refreshes faster than that. Don't adjust it's size, btw. Even a couple of hundred fps is slow. The only things that slow are ancient, or ati based. In the drawer I have a 10 years old nvidia mx-440 which runs @ 2200 fps, which is ok. What video card have you and what driver are you using if you have an xorg.conf?
 
Old 11-23-2010, 04:01 AM   #7
eSelix
Senior Member
 
Registered: Oct 2009
Location: Wroclaw, Poland
Distribution: Arch, Kubuntu
Posts: 1,218

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
Quote:
Originally Posted by matters View Post
when i create xorg.conf with xorgsetup driver module loads successfuly
but heres the message im concerned
So, show your xorg.conf.
 
Old 11-23-2010, 06:27 AM   #8
matters
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 281

Original Poster
Rep: Reputation: Disabled
heres my Xorg.0.log

Code:
 cat /var/log/Xorg.0.log
[  4282.412] 
X.Org X Server 1.9.2
Release Date: 2010-10-30
[  4282.419] X Protocol Version 11, Revision 0
[  4282.422] Build Operating System: Slackware 13.1 Slackware Linux Project
[  4282.424] Current Operating System: Linux parade 2.6.35.7-smp #1 SMP Sun Oct 10 21:43:07 CDT 2010 i686
[  4282.426] Kernel command line: BOOT_IMAGE=Linux ro root=fd04 video = 640x480
[  4282.429] Build Date: 20 November 2010  11:40:12PM
[  4282.431]  
[  4282.433] Current version of pixman: 0.20.0
[  4282.436] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[  4282.440] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  4282.468] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Nov 23 12:57:54 2010
[  4282.538] (==) Using config file: "/etc/X11/xorg.conf"
[  4282.541] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  4282.579] (==) ServerLayout "X.org Configured"
[  4282.579] (**) |-->Screen "Screen0" (0)
[  4282.579] (**) |   |-->Monitor "Monitor0"
[  4282.580] (**) |   |-->Device "Card0"
[  4282.580] (**) |-->Input Device "Mouse0"
[  4282.580] (**) |-->Input Device "Keyboard0"
[  4282.580] (==) Automatically adding devices
[  4282.580] (==) Automatically enabling devices
[  4282.580] (WW) The directory "/usr/share/fonts/local" does not exist.
[  4282.580] 	Entry deleted from font path.
[  4282.645] (WW) The directory "/usr/share/fonts/CID" does not exist.
[  4282.645] 	Entry deleted from font path.
[  4282.686] (WW) The directory "/usr/share/fonts/local" does not exist.
[  4282.686] 	Entry deleted from font path.
[  4282.686] (WW) The directory "/usr/share/fonts/CID" does not exist.
[  4282.686] 	Entry deleted from font path.
[  4282.686] (**) FontPath set to:
	/usr/share/fonts/TTF,
	/usr/share/fonts/OTF,
	/usr/share/fonts/Type1,
	/usr/share/fonts/misc,
	/usr/share/fonts/75dpi/:unscaled,
	/usr/share/fonts/100dpi/:unscaled,
	/usr/share/fonts/75dpi,
	/usr/share/fonts/100dpi,
	/usr/share/fonts/cyrillic,
	/usr/share/fonts/TTF,
	/usr/share/fonts/OTF,
	/usr/share/fonts/Type1,
	/usr/share/fonts/misc,
	/usr/share/fonts/75dpi/:unscaled,
	/usr/share/fonts/100dpi/:unscaled,
	/usr/share/fonts/75dpi,
	/usr/share/fonts/100dpi,
	/usr/share/fonts/cyrillic
[  4282.686] (**) ModulePath set to "/usr/lib/xorg/modules"
[  4282.686] (WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[  4282.686] (WW) Disabling Mouse0
[  4282.686] (WW) Disabling Keyboard0
[  4282.686] (II) Loader magic: 0x81f1640
[  4282.686] (II) Module ABI versions:
[  4282.686] 	X.Org ANSI C Emulation: 0.4
[  4282.686] 	X.Org Video Driver: 8.0
[  4282.686] 	X.Org XInput driver : 11.0
[  4282.687] 	X.Org Server Extension : 4.0
[  4282.688] (--) PCI:*(0:0:2:0) 8086:2572:1849:2572 rev 2, Mem @ 0xf0000000/134217728, 0xff280000/524288, I/O @ 0x0000ec00/8
[  4282.688] (II) Open ACPI successful (/var/run/acpid.socket)
[  4282.688] (II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
[  4282.688] (II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
[  4282.688] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[  4282.688] (II) "record" will be loaded. This was enabled by default and also specified in the config file.
[  4282.688] (II) "dri" will be loaded. This was enabled by default and also specified in the config file.
[  4282.688] (II) "dri2" will be loaded. This was enabled by default and also specified in the config file.
[  4282.688] (II) LoadModule: "record"
[  4282.717] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[  4282.717] (II) Module record: vendor="X.Org Foundation"
[  4282.717] 	compiled for 1.9.2, module version = 1.13.0
[  4282.717] 	Module class: X.Org Server Extension
[  4282.717] 	ABI class: X.Org Server Extension, version 4.0
[  4282.717] (II) Loading extension RECORD
[  4282.717] (II) LoadModule: "glx"
[  4282.717] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  4282.727] (II) Module glx: vendor="X.Org Foundation"
[  4282.727] 	compiled for 1.9.2, module version = 1.0.0
[  4282.727] 	ABI class: X.Org Server Extension, version 4.0
[  4282.728] (==) AIGLX enabled
[  4282.728] (II) Loading extension GLX
[  4282.728] (II) LoadModule: "extmod"
[  4282.734] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[  4282.734] (II) Module extmod: vendor="X.Org Foundation"
[  4282.734] 	compiled for 1.9.2, module version = 1.0.0
[  4282.734] 	Module class: X.Org Server Extension
[  4282.734] 	ABI class: X.Org Server Extension, version 4.0
[  4282.734] (II) Loading extension MIT-SCREEN-SAVER
[  4282.734] (II) Loading extension XFree86-VidModeExtension
[  4282.734] (II) Loading extension XFree86-DGA
[  4282.734] (II) Loading extension DPMS
[  4282.735] (II) Loading extension XVideo
[  4282.735] (II) Loading extension XVideo-MotionCompensation
[  4282.735] (II) Loading extension X-Resource
[  4282.735] (II) LoadModule: "dbe"
[  4282.742] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[  4282.742] (II) Module dbe: vendor="X.Org Foundation"
[  4282.743] 	compiled for 1.9.2, module version = 1.0.0
[  4282.743] 	Module class: X.Org Server Extension
[  4282.743] 	ABI class: X.Org Server Extension, version 4.0
[  4282.743] (II) Loading extension DOUBLE-BUFFER
[  4282.743] (II) LoadModule: "dri2"
[  4282.743] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[  4282.761] (II) Module dri2: vendor="X.Org Foundation"
[  4282.761] 	compiled for 1.9.2, module version = 1.2.0
[  4282.761] 	ABI class: X.Org Server Extension, version 4.0
[  4282.761] (II) Loading extension DRI2
[  4282.761] (II) LoadModule: "dri"
[  4282.761] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[  4282.761] (II) Module dri: vendor="X.Org Foundation"
[  4282.761] 	compiled for 1.9.2, module version = 1.0.0
[  4282.761] 	ABI class: X.Org Server Extension, version 4.0
[  4282.761] (II) Loading extension XFree86-DRI
[  4282.761] (II) LoadModule: "intel"
[  4282.835] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[  4282.851] (II) Module intel: vendor="X.Org Foundation"
[  4282.851] 	compiled for 1.9.2, module version = 2.13.0
[  4282.851] 	Module class: X.Org Video Driver
[  4282.851] 	ABI class: X.Org Video Driver, version 8.0
[  4282.851] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
	i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
	E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
	965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
	4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
	Sandybridge, Sandybridge, Sandybridge, Sandybridge, Sandybridge,
	Sandybridge, Sandybridge
[  4282.852] (--) using VT number 7

[  4283.026] drmOpenDevice: node name is /dev/dri/card0
[  4283.026] drmOpenDevice: open result is 11, (OK)
[  4283.026] drmOpenByBusid: Searching for BusID pci:0000:00:02.0
[  4283.026] drmOpenDevice: node name is /dev/dri/card0
[  4283.026] drmOpenDevice: open result is 11, (OK)
[  4283.026] drmOpenByBusid: drmOpenMinor returns 11
[  4283.026] drmOpenByBusid: Interface 1.4 failed, trying 1.1
[  4283.026] drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
[  4283.026] (**) intel(0): Depth 24, (--) framebuffer bpp 32
[  4283.026] (==) intel(0): RGB weight 888
[  4283.026] (==) intel(0): Default visual is TrueColor
[  4283.026] (II) intel(0): Integrated Graphics Chipset: Intel(R) 865G
[  4283.026] (--) intel(0): Chipset: "865G"
[  4283.026] (**) intel(0): Tiling enabled
[  4283.027] (**) intel(0): SwapBuffers wait enabled
[  4283.027] (==) intel(0): video overlay key set to 0x101fe
[  4283.037] (II) intel(0): Output VGA1 using monitor section Monitor0
[  4283.054] (II) intel(0): EDID for output VGA1
[  4283.054] (II) intel(0): Not using default mode "640x350" (vrefresh out of range)
[  4283.054] (II) intel(0): Not using default mode "320x175" (doublescan mode not supported)
[  4283.054] (II) intel(0): Not using default mode "640x400" (vrefresh out of range)
[  4283.054] (II) intel(0): Not using default mode "320x200" (doublescan mode not supported)
[  4283.054] (II) intel(0): Not using default mode "720x400" (vrefresh out of range)
[  4283.054] (II) intel(0): Not using default mode "360x200" (doublescan mode not supported)
[  4283.054] (II) intel(0): Not using default mode "320x240" (doublescan mode not supported)
[  4283.054] (II) intel(0): Not using default mode "320x240" (doublescan mode not supported)
[  4283.054] (II) intel(0): Not using default mode "320x240" (doublescan mode not supported)
[  4283.054] (II) intel(0): Not using default mode "640x480" (vrefresh out of range)
[  4283.054] (II) intel(0): Not using default mode "320x240" (doublescan mode not supported)
[  4283.054] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[  4283.054] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[  4283.054] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[  4283.054] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[  4283.054] (II) intel(0): Not using default mode "800x600" (vrefresh out of range)
[  4283.054] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[  4283.054] (II) intel(0): Not using default mode "1024x768i" (vrefresh out of range)
[  4283.054] (II) intel(0): Not using default mode "512x384i" (doublescan mode not supported)
[  4283.054] (II) intel(0): Not using default mode "512x384" (doublescan mode not supported)
[  4283.054] (II) intel(0): Not using default mode "512x384" (doublescan mode not supported)
[  4283.054] (II) intel(0): Not using default mode "512x384" (doublescan mode not supported)
[  4283.054] (II) intel(0): Not using default mode "1024x768" (vrefresh out of range)
[  4283.054] (II) intel(0): Not using default mode "512x384" (doublescan mode not supported)
[  4283.054] (II) intel(0): Not using default mode "576x432" (doublescan mode not supported)
[  4283.054] (II) intel(0): Not using default mode "640x480" (doublescan mode not supported)
[  4283.054] (II) intel(0): Not using default mode "1280x960" (vrefresh out of range)
[  4283.054] (II) intel(0): Not using default mode "640x480" (doublescan mode not supported)
[  4283.054] (II) intel(0): Not using default mode "640x512" (doublescan mode not supported)
[  4283.054] (II) intel(0): Not using default mode "640x512" (doublescan mode not supported)
[  4283.054] (II) intel(0): Not using default mode "1280x1024" (vrefresh out of range)
[  4283.054] (II) intel(0): Not using default mode "640x512" (doublescan mode not supported)
[  4283.054] (II) intel(0): Not using default mode "800x600" (doublescan mode not supported)
[  4283.054] (II) intel(0): Not using default mode "800x600" (doublescan mode not supported)
[  4283.054] (II) intel(0): Not using default mode "1600x1200" (hsync out of range)
[  4283.054] (II) intel(0): Not using default mode "800x600" (doublescan mode not supported)
[  4283.055] (II) intel(0): Not using default mode "1600x1200" (hsync out of range)
[  4283.055] (II) intel(0): Not using default mode "800x600" (doublescan mode not supported)
[  4283.055] (II) intel(0): Not using default mode "1600x1200" (vrefresh out of range)
[  4283.055] (II) intel(0): Not using default mode "800x600" (doublescan mode not supported)
[  4283.055] (II) intel(0): Not using default mode "1792x1344" (hsync out of range)
[  4283.055] (II) intel(0): Not using default mode "896x672" (doublescan mode not supported)
[  4283.055] (II) intel(0): Not using default mode "1792x1344" (hsync out of range)
[  4283.055] (II) intel(0): Not using default mode "896x672" (doublescan mode not supported)
[  4283.055] (II) intel(0): Not using default mode "1856x1392" (hsync out of range)
[  4283.055] (II) intel(0): Not using default mode "928x696" (doublescan mode not supported)
[  4283.055] (II) intel(0): Not using default mode "1856x1392" (hsync out of range)
[  4283.055] (II) intel(0): Not using default mode "928x696" (doublescan mode not supported)
[  4283.055] (II) intel(0): Not using default mode "1920x1440" (hsync out of range)
[  4283.055] (II) intel(0): Not using default mode "960x720" (doublescan mode not supported)
[  4283.055] (II) intel(0): Not using default mode "1920x1440" (hsync out of range)
[  4283.055] (II) intel(0): Not using default mode "960x720" (doublescan mode not supported)
[  4283.055] (II) intel(0): Not using default mode "416x312" (doublescan mode not supported)
[  4283.055] (II) intel(0): Not using default mode "700x525" (doublescan mode not supported)
[  4283.055] (II) intel(0): Not using default mode "700x525" (doublescan mode not supported)
[  4283.055] (II) intel(0): Not using default mode "1920x1440" (vrefresh out of range)
[  4283.055] (II) intel(0): Not using default mode "960x720" (doublescan mode not supported)
[  4283.055] (II) intel(0): Not using default mode "2048x1536" (hsync out of range)
[  4283.055] (II) intel(0): Not using default mode "1024x768" (doublescan mode not supported)
[  4283.055] (II) intel(0): Not using default mode "2048x1536" (hsync out of range)
[  4283.055] (II) intel(0): Not using default mode "1024x768" (doublescan mode not supported)
[  4283.055] (II) intel(0): Not using default mode "2048x1536" (vrefresh out of range)
[  4283.055] (II) intel(0): Not using default mode "1024x768" (doublescan mode not supported)
[  4283.055] (II) intel(0): Printing probed modes for output VGA1
[  4283.055] (II) intel(0): Modeline "1024x768"x75.0   78.75  1024 1040 1136 1312  768 769 772 800 +hsync +vsync (60.0 kHz)
[  4283.055] (II) intel(0): Modeline "1600x1200"x65.0  175.50  1600 1664 1856 2160  1200 1201 1204 1250 +hsync +vsync (81.2 kHz)
[  4283.055] (II) intel(0): Modeline "1600x1200"x60.0  162.00  1600 1664 1856 2160  1200 1201 1204 1250 +hsync +vsync (75.0 kHz)
[  4283.055] (II) intel(0): Modeline "1400x1050"x74.8  155.80  1400 1464 1784 1912  1050 1052 1064 1090 +hsync +vsync (81.5 kHz)
[  4283.055] (II) intel(0): Modeline "1400x1050"x60.0  122.00  1400 1488 1640 1880  1050 1052 1064 1082 +hsync +vsync (64.9 kHz)
[  4283.055] (II) intel(0): Modeline "1280x1024"x75.0  135.00  1280 1296 1440 1688  1024 1025 1028 1066 +hsync +vsync (80.0 kHz)
[  4283.055] (II) intel(0): Modeline "1280x1024"x60.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz)
[  4283.055] (II) intel(0): Modeline "1280x960"x60.0  108.00  1280 1376 1488 1800  960 961 964 1000 +hsync +vsync (60.0 kHz)
[  4283.055] (II) intel(0): Modeline "1152x864"x75.0  108.00  1152 1216 1344 1600  864 865 868 900 +hsync +vsync (67.5 kHz)
[  4283.055] (II) intel(0): Modeline "1024x768"x70.1   75.00  1024 1048 1184 1328  768 771 777 806 -hsync -vsync (56.5 kHz)
[  4283.055] (II) intel(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz)
[  4283.055] (II) intel(0): Modeline "832x624"x74.6   57.28  832 864 928 1152  624 625 628 667 -hsync -vsync (49.7 kHz)
[  4283.055] (II) intel(0): Modeline "800x600"x72.2   50.00  800 856 976 1040  600 637 643 666 +hsync +vsync (48.1 kHz)
[  4283.055] (II) intel(0): Modeline "800x600"x75.0   49.50  800 816 896 1056  600 601 604 625 +hsync +vsync (46.9 kHz)
[  4283.055] (II) intel(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz)
[  4283.056] (II) intel(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz)
[  4283.056] (II) intel(0): Modeline "848x480"x60.0   33.75  848 864 976 1088  480 486 494 517 +hsync +vsync (31.0 kHz)
[  4283.056] (II) intel(0): Modeline "640x480"x72.8   31.50  640 664 704 832  480 489 492 520 -hsync -vsync (37.9 kHz)
[  4283.056] (II) intel(0): Modeline "640x480"x75.0   31.50  640 656 720 840  480 481 484 500 -hsync -vsync (37.5 kHz)
[  4283.056] (II) intel(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 489 492 525 -hsync -vsync (31.5 kHz)
[  4283.056] (II) intel(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz)
[  4283.056] (II) intel(0): Output VGA1 connected
[  4283.056] (II) intel(0): Using user preference for initial modes
[  4283.056] (II) intel(0): Output VGA1 using initial mode 1024x768
[  4283.056] (II) intel(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[  4283.056] (II) intel(0): Kernel page flipping support detected, enabling
[  4283.056] (==) intel(0): DPI set to (96, 96)
[  4283.056] (II) Loading sub module "fb"
[  4283.056] (II) LoadModule: "fb"
[  4283.056] (II) Loading /usr/lib/xorg/modules/libfb.so
[  4283.057] (II) Module fb: vendor="X.Org Foundation"
[  4283.057] 	compiled for 1.9.2, module version = 1.0.0
[  4283.057] 	ABI class: X.Org ANSI C Emulation, version 0.4
[  4283.057] (==) Depth 24 pixmap format is 32 bpp
[  4283.057] (==) intel(0): VideoRam: 131072 KB
[  4283.073] (II) intel(0): [DRI2] Setup complete
[  4283.073] (II) intel(0): [DRI2]   DRI driver: i915
[  4283.073] (II) intel(0): Allocated new frame buffer 1024x768 stride 4096, tiled
[  4283.073] (II) UXA(0): Driver registered support for the following operations:
[  4283.073] (II)         solid
[  4283.074] (II)         copy
[  4283.074] (II)         composite (RENDER acceleration)
[  4283.074] (II)         put_image
[  4283.074] (II)         get_image
[  4283.074] (==) intel(0): Backing store disabled
[  4283.074] (==) intel(0): Silken mouse enabled
[  4283.074] (II) intel(0): Initializing HW Cursor
[  4283.170] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[  4283.170] (==) intel(0): DPMS enabled
[  4283.170] (==) intel(0): Intel XvMC decoder disabled
[  4283.170] (II) intel(0): Set up overlay video
[  4283.170] (II) intel(0): direct rendering: DRI2 Enabled
[  4283.170] (--) RandR disabled
[  4283.170] (II) Initializing built-in extension Generic Event Extension
[  4283.170] (II) Initializing built-in extension SHAPE
[  4283.170] (II) Initializing built-in extension MIT-SHM
[  4283.170] (II) Initializing built-in extension XInputExtension
[  4283.170] (II) Initializing built-in extension XTEST
[  4283.170] (II) Initializing built-in extension BIG-REQUESTS
[  4283.171] (II) Initializing built-in extension SYNC
[  4283.171] (II) Initializing built-in extension XKEYBOARD
[  4283.171] (II) Initializing built-in extension XC-MISC
[  4283.171] (II) Initializing built-in extension XINERAMA
[  4283.171] (II) Initializing built-in extension XFIXES
[  4283.171] (II) Initializing built-in extension RENDER
[  4283.171] (II) Initializing built-in extension RANDR
[  4283.171] (II) Initializing built-in extension COMPOSITE
[  4283.171] (II) Initializing built-in extension DAMAGE
[  4283.265] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[  4283.265] (II) AIGLX: enabled GLX_INTEL_swap_event
[  4283.266] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[  4283.266] (II) AIGLX: enabled GLX_SGI_make_current_read
[  4283.266] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[  4283.266] (II) AIGLX: Loaded and initialized /usr/lib/xorg/modules/dri/i915_dri.so
[  4283.266] (II) GLX: Initialized DRI2 GL provider for screen 0
[  4283.267] (II) intel(0): Setting screen physical size to 270 x 203
[  4284.045] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[  4284.045] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  4284.045] (**) Power Button: Applying InputClass "keyboard-all"
[  4284.045] (II) LoadModule: "evdev"
[  4284.071] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[  4284.072] (II) Module evdev: vendor="X.Org Foundation"
[  4284.072] 	compiled for 1.9.2, module version = 2.5.0
[  4284.072] 	Module class: X.Org XInput Driver
[  4284.072] 	ABI class: X.Org XInput driver, version 11.0
[  4284.072] (**) Power Button: always reports core events
[  4284.072] (**) Power Button: Device: "/dev/input/event2"
[  4284.076] (--) Power Button: Found keys
[  4284.076] (II) Power Button: Configuring as keyboard
[  4284.076] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[  4284.076] (**) Option "xkb_rules" "evdev"
[  4284.076] (**) Option "xkb_model" "evdev"
[  4284.076] (**) Option "xkb_layout" "us"
[  4284.076] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[  4284.132] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[  4284.132] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[  4284.132] (**) Power Button: Applying InputClass "keyboard-all"
[  4284.132] (**) Power Button: always reports core events
[  4284.132] (**) Power Button: Device: "/dev/input/event1"
[  4284.135] (--) Power Button: Found keys
[  4284.135] (II) Power Button: Configuring as keyboard
[  4284.135] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
[  4284.135] (**) Option "xkb_rules" "evdev"
[  4284.135] (**) Option "xkb_model" "evdev"
[  4284.135] (**) Option "xkb_layout" "us"
[  4284.135] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[  4284.138] (II) config/udev: Adding input device MLK Trust Mouse 15206 (/dev/input/event3)
[  4284.138] (**) MLK Trust Mouse 15206: Applying InputClass "evdev pointer catchall"
[  4284.138] (**) MLK Trust Mouse 15206: Applying InputClass "evdev keyboard catchall"
[  4284.138] (**) MLK Trust Mouse 15206: Applying InputClass "keyboard-all"
[  4284.138] (**) MLK Trust Mouse 15206: always reports core events
[  4284.138] (**) MLK Trust Mouse 15206: Device: "/dev/input/event3"
[  4284.141] (--) MLK Trust Mouse 15206: Found 9 mouse buttons
[  4284.141] (--) MLK Trust Mouse 15206: Found scroll wheel(s)
[  4284.141] (--) MLK Trust Mouse 15206: Found relative axes
[  4284.141] (--) MLK Trust Mouse 15206: Found x and y relative axes
[  4284.141] (--) MLK Trust Mouse 15206: Found absolute axes
[  4284.141] (--) MLK Trust Mouse 15206: Found keys
[  4284.141] (II) MLK Trust Mouse 15206: Configuring as mouse
[  4284.141] (II) MLK Trust Mouse 15206: Configuring as keyboard
[  4284.141] (**) MLK Trust Mouse 15206: YAxisMapping: buttons 4 and 5
[  4284.141] (**) MLK Trust Mouse 15206: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[  4284.141] (II) XINPUT: Adding extended input device "MLK Trust Mouse 15206" (type: KEYBOARD)
[  4284.141] (**) Option "xkb_rules" "evdev"
[  4284.141] (**) Option "xkb_model" "evdev"
[  4284.141] (**) Option "xkb_layout" "us"
[  4284.141] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
[  4284.141] (**) MLK Trust Mouse 15206: (accel) keeping acceleration scheme 1
[  4284.141] (**) MLK Trust Mouse 15206: (accel) acceleration profile 0
[  4284.141] (**) MLK Trust Mouse 15206: (accel) acceleration factor: 2.000
[  4284.141] (**) MLK Trust Mouse 15206: (accel) acceleration threshold: 4
[  4284.141] (II) MLK Trust Mouse 15206: initialized for relative axes.
[  4284.141] (WW) MLK Trust Mouse 15206: ignoring absolute axes.
[  4284.142] (II) config/udev: Adding input device MLK Trust Mouse 15206 (/dev/input/mouse0)
[  4284.142] (**) MLK Trust Mouse 15206: Applying InputClass "keyboard-all"
[  4284.142] (**) MLK Trust Mouse 15206: always reports core events
[  4284.142] (**) MLK Trust Mouse 15206: Device: "/dev/input/mouse0"
[  4284.146] (EE) ioctl EVIOCGNAME failed: Inappropriate ioctl for device
[  4284.148] (II) UnloadModule: "evdev"
[  4284.148] (EE) PreInit returned NULL for "MLK Trust Mouse 15206"
[  4284.159] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[  4284.159] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[  4284.159] (**) AT Translated Set 2 keyboard: Applying InputClass "keyboard-all"
[  4284.159] (**) AT Translated Set 2 keyboard: always reports core events
[  4284.159] (**) AT Translated Set 2 keyboard: Device: "/dev/input/event0"
[  4284.162] (--) AT Translated Set 2 keyboard: Found keys
[  4284.162] (II) AT Translated Set 2 keyboard: Configuring as keyboard
[  4284.162] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
[  4284.162] (**) Option "xkb_rules" "evdev"
[  4284.162] (**) Option "xkb_model" "evdev"
[  4284.162] (**) Option "xkb_layout" "us"
[  4284.162] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
and heres current xorg.conf

Code:
Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/lib/xorg/modules"
	FontPath     "/usr/share/fonts/local"
	FontPath     "/usr/share/fonts/TTF"
	FontPath     "/usr/share/fonts/OTF"
	FontPath     "/usr/share/fonts/Type1"
	FontPath     "/usr/share/fonts/misc"
	FontPath     "/usr/share/fonts/CID"
	FontPath     "/usr/share/fonts/75dpi/:unscaled"
	FontPath     "/usr/share/fonts/100dpi/:unscaled"
	FontPath     "/usr/share/fonts/75dpi"
	FontPath     "/usr/share/fonts/100dpi"
	FontPath     "/usr/share/fonts/cyrillic"
EndSection

Section "Module"
	Load  "record"
	Load  "glx"
	Load  "extmod"
	Load  "dbe"
	Load  "dri2"
	Load  "dri"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Samsung"
	ModelName    "SyncMaster 940bw"
	Horizsync  30-81
	VertRefresh 56-75
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "AccelMethod"        	# [<str>]
        #Option     "DRI"                	# [<bool>]
        #Option     "ColorKey"           	# <i>
        #Option     "VideoKey"           	# <i>
        #Option     "FallbackDebug"      	# [<bool>]
        #Option     "Tiling"             	# [<bool>]
        #Option     "Shadow"             	# [<bool>]
        #Option     "SwapbuffersWait"    	# [<bool>]
        #Option     "XvMC"               	# [<bool>]
        #Option     "XvPreferOverlay"    	# [<bool>]
        #Option     "DebugFlushBatches"  	# [<bool>]
        #Option     "DebugFlushCaches"   	# [<bool>]
        #Option     "DebugWait"          	# [<bool>]
	Identifier  "Card0"
	Driver      "intel"
	BusID       "PCI:0:2:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	DefaultDepth 24
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1024x768"
	EndSubSection
EndSection
after adding horizsync and vertrefresh now glxgears gives 375 frames 75 fps compared to before 300 frames

thanks guys
wondering what else need to be added
 
Old 11-23-2010, 08:26 AM   #9
eSelix
Senior Member
 
Registered: Oct 2009
Location: Wroclaw, Poland
Distribution: Arch, Kubuntu
Posts: 1,218

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
For performance test do not use glxgears, it is not a benchmark, but only utility showing that OpenGL works and as we see it works. So the problem is with flash. Try file from Adobe site.
 
Old 11-23-2010, 08:34 AM   #10
matters
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 281

Original Poster
Rep: Reputation: Disabled
ive downloaded from adobe site

same result. video is lagging, but bandwith is okay

EDIT: by downloading rpm, closing running firefox, and installing adobe flash player theres no youtube video lag anymore.

Last edited by matters; 11-24-2010 at 05:06 AM.
 
Old 11-26-2010, 08:12 AM   #11
Linux.tar.gz
Senior Member
 
Registered: Dec 2003
Location: Paris
Distribution: Slackware forever.
Posts: 2,227

Rep: Reputation: 86
glxinfo

Do you have : "direct rendering: Yes" ?
 
Old 11-26-2010, 05:02 PM   #12
matters
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 281

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Linux.tar.gz View Post
glxinfo

Do you have : "direct rendering: Yes" ?
yes i do
 
Old 11-27-2010, 02:57 AM   #13
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,373

Rep: Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557
Quote:
Originally Posted by eSelix View Post
For performance test do not use glxgears, it is not a benchmark, but only utility showing that OpenGL works and as we see it works. So the problem is with flash. Try file from Adobe site.
Agreed. It tests a tiny fraction of what a video card should do. But it is also a useful snapshot comparison, as we all have it. We all know that a few thousand fps in glxgears is good, a few hundred is passable, and worse indicates a problem. I've tried installing the phoronix test suite. If the poster had given us numbers from phoronix tests, they certainly wouldn't have meant much to me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem: Youtube video screen - Shockwave flash - White screen. Firefox. NOoBuntuLinux Ubuntu 5 04-29-2010 08:44 PM
firefox flash player problem(youtube) paind Linux - Software 1 07-14-2007 04:06 PM
Firefox youtube flash crashes koensmet Linux - Software 4 05-31-2007 04:48 PM
firefox 1.5.0.10-0.1.el4 crashing on youtube and other flash websites jkovats Red Hat 1 05-22-2007 01:07 PM
Problem with sound firefox in ubuntu 6.10 (Flash(Youtube)) javierfut Linux - General 2 12-15-2006 09:19 AM


All times are GMT -5. The time now is 12:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration