LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-08-2012, 03:57 AM   #1
688a
Member
 
Registered: Sep 2012
Location: Hong Kong
Distribution: Slackware14 (3.7)
Posts: 51

Rep: Reputation: Disabled
xwmconfig becomes funny!


Hi there,

I've just found this funny characters on my xwmconfig. It happens on the text mode, and it is ok in the terminal. I think it's something related to the encoding, but I can't recall what I did...
Any idea how to fix it?

http://farm9.staticflickr.com/8038/8...7bc6ec88ae.jpg

Thx.

Last edited by 688a; 10-08-2012 at 03:59 AM.
 
Old 10-09-2012, 01:11 PM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,043

Rep: Reputation: 977Reputation: 977Reputation: 977Reputation: 977Reputation: 977Reputation: 977Reputation: 977Reputation: 977
What says "echo $LANG"?
 
Old 10-09-2012, 09:21 PM   #3
688a
Member
 
Registered: Sep 2012
Location: Hong Kong
Distribution: Slackware14 (3.7)
Posts: 51

Original Poster
Rep: Reputation: Disabled
I know what I've done to mess the xwmconfig. I'd edited the /etc/profile.d/lang.sh and set
from
Quote:
export LANG=en_US
to
Quote:
export LANG=en_US.UTF-8
I did it because the system didn't show the Chinese and Japanese characters!

What can I do to show the characters without setting the $LANG?
 
Old 10-10-2012, 03:06 AM   #4
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Ruhr Area, Germany
Distribution: Slackware64 14.0
Posts: 1,517

Rep: Reputation: 90
Quote:
Originally Posted by 688a View Post
I know what I've done to mess the xwmconfig. I'd edited the /etc/profile.d/lang.sh and set
from

to


I did it because the system didn't show the Chinese and Japanese characters!

What can I do to show the characters without setting the $LANG?
Have you tried setting the locale to utf8 AND adding a line "unicode_start" to /etc/rc.d/rc.local?
 
Old 10-10-2012, 03:37 AM   #5
kabamaru
Member
 
Registered: Dec 2011
Location: Greece
Distribution: Slackware
Posts: 276

Rep: Reputation: 133Reputation: 133
I have edited lang.sh to use UTF-8 like you did and xwmconfig runs fine. Do you have this line in your /etc/lilo.conf?

Code:
append="vt.default_utf8=1"
or maybe you chose a custom font during installation?

Last edited by kabamaru; 10-10-2012 at 03:39 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Lawyer's Funny AntiLinux FUD Turns Out to be Not So Funny LXer Syndicated Linux News 0 08-11-2008 04:00 AM
xwmconfig slinky2004 Linux - General 1 10-25-2004 02:27 AM
gnome and xwmconfig paul62 Slackware 1 09-20-2004 01:02 PM


All times are GMT -5. The time now is 10:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration